diff mbox series

package/libpwquality: support python bindings with python3

Message ID 20220206121652.30854-1-peter@korsgaard.com
State Accepted
Headers show
Series package/libpwquality: support python bindings with python3 | expand

Commit Message

Peter Korsgaard Feb. 6, 2022, 12:16 p.m. UTC
The python bindings support python3 as well, so enable it if python3 is
enabled.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
---
 package/libpwquality/libpwquality.mk | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Peter Korsgaard Feb. 7, 2022, 6:19 p.m. UTC | #1
>>>>> "Peter" == Peter Korsgaard <peter@korsgaard.com> writes:

 > The python bindings support python3 as well, so enable it if python3 is
 > enabled.

 > Signed-off-by: Peter Korsgaard <peter@korsgaard.com>

Committed, thanks.
diff mbox series

Patch

diff --git a/package/libpwquality/libpwquality.mk b/package/libpwquality/libpwquality.mk
index 7c0c5df38e..54a03be453 100644
--- a/package/libpwquality/libpwquality.mk
+++ b/package/libpwquality/libpwquality.mk
@@ -12,9 +12,9 @@  LIBPWQUALITY_INSTALL_STAGING = YES
 LIBPWQUALITY_DEPENDENCIES = cracklib
 LIBPWQUALITY_LICENSE_FILES = COPYING
 
-ifeq ($(BR2_PACKAGE_PYTHON),y)
+ifeq ($(BR2_PACKAGE_PYTHON)$(BR2_PACKAGE_PYTHON3),y)
 LIBPWQUALITY_CONF_OPTS += --enable-python-bindings
-LIBPWQUALITY_DEPENDENCIES += python
+LIBPWQUALITY_DEPENDENCIES += $(if $(BR2_PACKAGE_PYTHON3),python3,python)
 LIBPWQUALITY_MAKE_ENV += $(PKG_PYTHON_DISTUTILS_ENV)
 else
 LIBPWQUALITY_CONF_OPTS += --disable-python-bindings