diff mbox series

[1/1] package/lighttpd: add pgsql support

Message ID 20220126211749.1550932-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/lighttpd: add pgsql support | expand

Commit Message

Fabrice Fontaine Jan. 26, 2022, 9:17 p.m. UTC
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/lighttpd/Config.in   | 10 ++++++++++
 package/lighttpd/lighttpd.mk |  8 +++++++-
 2 files changed, 17 insertions(+), 1 deletion(-)

Comments

Arnout Vandecappelle Feb. 5, 2022, 10:54 p.m. UTC | #1
On 26/01/2022 22:17, Fabrice Fontaine wrote:
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

  Applied to master, thanks.

  Regards,
  Arnout

> ---
>   package/lighttpd/Config.in   | 10 ++++++++++
>   package/lighttpd/lighttpd.mk |  8 +++++++-
>   2 files changed, 17 insertions(+), 1 deletion(-)
> 
> diff --git a/package/lighttpd/Config.in b/package/lighttpd/Config.in
> index eb8ab480a0..57bb756603 100644
> --- a/package/lighttpd/Config.in
> +++ b/package/lighttpd/Config.in
> @@ -86,6 +86,16 @@ config BR2_PACKAGE_LIGHTTPD_PCRE
>   	help
>   	  Enable PCRE support. Needed to support mod_rewrite
>   
> +config BR2_PACKAGE_LIGHTTPD_PGSQL
> +	bool "pgsql support"
> +	depends on BR2_USE_MMU # postgresql
> +	select BR2_PACKAGE_POSTGRESQL
> +	help
> +	  Enable postgres support for lighttpd mod_vhostdb_pgsql.
> +
> +comment "pgsql support needs a toolchain w/ wchar"
> +	depends on !BR2_USE_WCHAR
> +
>   config BR2_PACKAGE_LIGHTTPD_WEBDAV
>   	bool "webdav support"
>   	select BR2_PACKAGE_LIBXML2
> diff --git a/package/lighttpd/lighttpd.mk b/package/lighttpd/lighttpd.mk
> index 90b4ba0a72..595c59cb37 100644
> --- a/package/lighttpd/lighttpd.mk
> +++ b/package/lighttpd/lighttpd.mk
> @@ -22,7 +22,6 @@ LIGHTTPD_CONF_OPTS = \
>   	-Dwith_nettle=false \
>   	-Dwith_nss=false \
>   	-Dwith_pcre=false \
> -	-Dwith_pgsql=false \
>   	-Dwith_sasl=false \
>   	-Dwith_wolfssl=false \
>   	-Dwith_xattr=false \
> @@ -101,6 +100,13 @@ else
>   LIGHTTPD_CONF_OPTS += -Dwith_pcre2=false
>   endif
>   
> +ifeq ($(BR2_PACKAGE_LIGHTTPD_PGSQL),y)
> +LIGHTTPD_DEPENDENCIES += postgresql
> +LIGHTTPD_CONF_OPTS += -Dwith_pgsql=true
> +else
> +LIGHTTPD_CONF_OPTS += -Dwith_pgsql=false
> +endif
> +
>   ifeq ($(BR2_PACKAGE_LIGHTTPD_WEBDAV),y)
>   LIGHTTPD_DEPENDENCIES += libxml2 sqlite
>   LIGHTTPD_CONF_OPTS += -Dwith_webdav_props=true
diff mbox series

Patch

diff --git a/package/lighttpd/Config.in b/package/lighttpd/Config.in
index eb8ab480a0..57bb756603 100644
--- a/package/lighttpd/Config.in
+++ b/package/lighttpd/Config.in
@@ -86,6 +86,16 @@  config BR2_PACKAGE_LIGHTTPD_PCRE
 	help
 	  Enable PCRE support. Needed to support mod_rewrite
 
+config BR2_PACKAGE_LIGHTTPD_PGSQL
+	bool "pgsql support"
+	depends on BR2_USE_MMU # postgresql
+	select BR2_PACKAGE_POSTGRESQL
+	help
+	  Enable postgres support for lighttpd mod_vhostdb_pgsql.
+
+comment "pgsql support needs a toolchain w/ wchar"
+	depends on !BR2_USE_WCHAR
+
 config BR2_PACKAGE_LIGHTTPD_WEBDAV
 	bool "webdav support"
 	select BR2_PACKAGE_LIBXML2
diff --git a/package/lighttpd/lighttpd.mk b/package/lighttpd/lighttpd.mk
index 90b4ba0a72..595c59cb37 100644
--- a/package/lighttpd/lighttpd.mk
+++ b/package/lighttpd/lighttpd.mk
@@ -22,7 +22,6 @@  LIGHTTPD_CONF_OPTS = \
 	-Dwith_nettle=false \
 	-Dwith_nss=false \
 	-Dwith_pcre=false \
-	-Dwith_pgsql=false \
 	-Dwith_sasl=false \
 	-Dwith_wolfssl=false \
 	-Dwith_xattr=false \
@@ -101,6 +100,13 @@  else
 LIGHTTPD_CONF_OPTS += -Dwith_pcre2=false
 endif
 
+ifeq ($(BR2_PACKAGE_LIGHTTPD_PGSQL),y)
+LIGHTTPD_DEPENDENCIES += postgresql
+LIGHTTPD_CONF_OPTS += -Dwith_pgsql=true
+else
+LIGHTTPD_CONF_OPTS += -Dwith_pgsql=false
+endif
+
 ifeq ($(BR2_PACKAGE_LIGHTTPD_WEBDAV),y)
 LIGHTTPD_DEPENDENCIES += libxml2 sqlite
 LIGHTTPD_CONF_OPTS += -Dwith_webdav_props=true