diff mbox series

[RFC,v2,3/7] package/musepack: use MUSEPACK_NINJA_OPTS

Message ID 20220121154235.798255-4-aperez@igalia.com
State Changes Requested
Headers show
Series Use Ninja as build tool for CMake-based packages | expand

Commit Message

Adrian Perez de Castro Jan. 21, 2022, 3:42 p.m. UTC
Replace the usage of MUSEPACK_MAKE with MUSEPACK_NINJA_OPTS to disable
the parallel build. Unfortunately switching to Ninja for building CMake
packages has not solved the parallel build issues.

Signed-off-by: Adrian Perez de Castro <aperez@igalia.com>
---
Changes v1 -> v2:
  - Tweak muspack package to disallow parallel builds with Ninja.
---
 package/musepack/musepack.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Arnout Vandecappelle July 24, 2022, 1:18 p.m. UTC | #1
On 21/01/2022 16:42, Adrian Perez de Castro wrote:
> Replace the usage of MUSEPACK_MAKE with MUSEPACK_NINJA_OPTS to disable
> the parallel build. Unfortunately switching to Ninja for building CMake
> packages has not solved the parallel build issues.
> 
> Signed-off-by: Adrian Perez de Castro <aperez@igalia.com>
> ---
> Changes v1 -> v2:
>    - Tweak muspack package to disallow parallel builds with Ninja.
> ---
>   package/musepack/musepack.mk | 2 +-
>   1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/package/musepack/musepack.mk b/package/musepack/musepack.mk
> index fc66c684a5..000db5fd76 100644
> --- a/package/musepack/musepack.mk
> +++ b/package/musepack/musepack.mk
> @@ -9,8 +9,8 @@ MUSEPACK_SITE = http://files.musepack.net/source
>   MUSEPACK_SOURCE = musepack_src_$(MUSEPACK_VERSION).tar.gz
>   MUSEPACK_DEPENDENCIES = libcuefile libreplaygain
>   MUSEPACK_INSTALL_STAGING = YES
> -MUSEPACK_MAKE = $(MAKE1)
>   MUSEPACK_LICENSE = BSD-3-Clause (*mpcdec), LGPL-2.1+ (*mpcenc)
>   MUSEPACK_LICENSE_FILES = libmpcdec/COPYING libmpcenc/quant.c
> +MUSEPACK_NINJA_OPTS = -j1

  Ah, right, for something like this we *do* need <PKG>_BUILD_OPTS...

  Regards,
  Arnout

>   
>   $(eval $(cmake-package))
diff mbox series

Patch

diff --git a/package/musepack/musepack.mk b/package/musepack/musepack.mk
index fc66c684a5..000db5fd76 100644
--- a/package/musepack/musepack.mk
+++ b/package/musepack/musepack.mk
@@ -9,8 +9,8 @@  MUSEPACK_SITE = http://files.musepack.net/source
 MUSEPACK_SOURCE = musepack_src_$(MUSEPACK_VERSION).tar.gz
 MUSEPACK_DEPENDENCIES = libcuefile libreplaygain
 MUSEPACK_INSTALL_STAGING = YES
-MUSEPACK_MAKE = $(MAKE1)
 MUSEPACK_LICENSE = BSD-3-Clause (*mpcdec), LGPL-2.1+ (*mpcenc)
 MUSEPACK_LICENSE_FILES = libmpcdec/COPYING libmpcenc/quant.c
+MUSEPACK_NINJA_OPTS = -j1
 
 $(eval $(cmake-package))