diff mbox series

[1/1] package/domoticz: fix build with libexecinfo

Message ID 20220107204754.1462472-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/domoticz: fix build with libexecinfo | expand

Commit Message

Fabrice Fontaine Jan. 7, 2022, 8:47 p.m. UTC
Fix build failure raised since the addition of the libexecinfo package
in commit eea8ba446c10701a273432552108d80fb2224ef4

Fixes:
 - Not autobuilder failures (yet)

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/domoticz/domoticz.mk | 5 +++++
 1 file changed, 5 insertions(+)

Comments

Arnout Vandecappelle Jan. 8, 2022, 3:11 p.m. UTC | #1
On 07/01/2022 21:47, Fabrice Fontaine wrote:
> Fix build failure raised since the addition of the libexecinfo package
> in commit eea8ba446c10701a273432552108d80fb2224ef4
> 
> Fixes:
>   - Not autobuilder failures (yet)
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

  Applied to master, thanks.

  Regards,
  Arnout

> ---
>   package/domoticz/domoticz.mk | 5 +++++
>   1 file changed, 5 insertions(+)
> 
> diff --git a/package/domoticz/domoticz.mk b/package/domoticz/domoticz.mk
> index 826e6f5e58..0d1088d395 100644
> --- a/package/domoticz/domoticz.mk
> +++ b/package/domoticz/domoticz.mk
> @@ -41,6 +41,11 @@ DOMOTICZ_CONF_OPTS += \
>   	-DUSE_BUILTIN_SQLITE=OFF \
>   	-DUSE_BUILTIN_MQTT=OFF
>   
> +ifeq ($(BR2_PACKAGE_LIBEXECINFO),y)
> +DOMOTICZ_DEPENDENCIES += libexecinfo
> +DOMOTICZ_CONF_OPTS += -DEXECINFO_LIBRARIES=-lexecinfo
> +endif
> +
>   ifeq ($(BR2_PACKAGE_LIBUSB),y)
>   DOMOTICZ_DEPENDENCIES += libusb
>   DOMOTICZ_CONF_OPTS += -DWITH_LIBUSB=ON
>
diff mbox series

Patch

diff --git a/package/domoticz/domoticz.mk b/package/domoticz/domoticz.mk
index 826e6f5e58..0d1088d395 100644
--- a/package/domoticz/domoticz.mk
+++ b/package/domoticz/domoticz.mk
@@ -41,6 +41,11 @@  DOMOTICZ_CONF_OPTS += \
 	-DUSE_BUILTIN_SQLITE=OFF \
 	-DUSE_BUILTIN_MQTT=OFF
 
+ifeq ($(BR2_PACKAGE_LIBEXECINFO),y)
+DOMOTICZ_DEPENDENCIES += libexecinfo
+DOMOTICZ_CONF_OPTS += -DEXECINFO_LIBRARIES=-lexecinfo
+endif
+
 ifeq ($(BR2_PACKAGE_LIBUSB),y)
 DOMOTICZ_DEPENDENCIES += libusb
 DOMOTICZ_CONF_OPTS += -DWITH_LIBUSB=ON