diff mbox series

[1/1] package/mdadm: disable -Werror

Message ID 20220105180453.388499-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/mdadm: disable -Werror | expand

Commit Message

Fabrice Fontaine Jan. 5, 2022, 6:04 p.m. UTC
Disable -Werror by setting CWFLAGS to ""
This will avoid the following build failure raised since bump to version
4.2 in commit b03fc7974536378ba102418451ba7e9801bc6251:

mdadm.c: In function 'main':
mdadm.c:156:28: error: this statement may fall through [-Werror=implicit-fallthrough=]
  154 |    if (mode == ASSEMBLE || mode == BUILD ||
      |        ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Fixes:
 - http://autobuild.buildroot.org/results/c0f216b7aadb794110409d03dcef7fa58e833cd4

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/mdadm/mdadm.mk | 1 +
 1 file changed, 1 insertion(+)

Comments

Peter Korsgaard Jan. 7, 2022, 5:46 p.m. UTC | #1
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > Disable -Werror by setting CWFLAGS to ""
 > This will avoid the following build failure raised since bump to version
 > 4.2 in commit b03fc7974536378ba102418451ba7e9801bc6251:

 > mdadm.c: In function 'main':
 > mdadm.c:156:28: error: this statement may fall through [-Werror=implicit-fallthrough=]
 >   154 |    if (mode == ASSEMBLE || mode == BUILD ||
 >       |        ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

 > Fixes:
 >  - http://autobuild.buildroot.org/results/c0f216b7aadb794110409d03dcef7fa58e833cd4

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed, thanks.
diff mbox series

Patch

diff --git a/package/mdadm/mdadm.mk b/package/mdadm/mdadm.mk
index 6ee0bb60c9..0a2eb4e5bd 100644
--- a/package/mdadm/mdadm.mk
+++ b/package/mdadm/mdadm.mk
@@ -16,6 +16,7 @@  MDADM_BUILD_OPTS = \
 	CC=$(TARGET_CC) \
 	COROSYNC=-DNO_COROSYNC \
 	DLM=-DNO_DLM \
+	CWFLAGS="" \
 	CXFLAGS="$(MDADM_CXFLAGS)" \
 	CPPFLAGS="$(TARGET_CPPFLAGS) -DBINDIR=\\\"/sbin\\\"" \
 	CHECK_RUN_DIR=0