diff mbox series

Makefile: fix build failure due to buggy 'make' version 4.3

Message ID 20211230215631.2024770-1-giulio.benetti@benettiengineering.com
State Rejected
Headers show
Series Makefile: fix build failure due to buggy 'make' version 4.3 | expand

Commit Message

Giulio Benetti Dec. 30, 2021, 9:56 p.m. UTC
Make version 4.3 is buggy in various ways, so let's skip it by checking
RUNNING_MAKE_VERSION against the SKIP_MAKE_VERSION list. This way, if other
make versions show up we can add them to SKIP_MAKE_VERSION list.

Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
---
 Makefile | 6 ++++++
 1 file changed, 6 insertions(+)

Comments

Giulio Benetti Dec. 30, 2021, 10:31 p.m. UTC | #1
On 30/12/21 22:56, Giulio Benetti wrote:
> Make version 4.3 is buggy in various ways, so let's skip it by checking
> RUNNING_MAKE_VERSION against the SKIP_MAKE_VERSION list. This way, if other
> make versions show up we can add them to SKIP_MAKE_VERSION list.
> 
> Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
> ---
>   Makefile | 6 ++++++
>   1 file changed, 6 insertions(+)
> 
> diff --git a/Makefile b/Makefile
> index 0b8c7b2867..a07c05f8aa 100644
> --- a/Makefile
> +++ b/Makefile
> @@ -105,6 +105,12 @@ ifneq ($(firstword $(sort $(RUNNING_MAKE_VERSION) $(MIN_MAKE_VERSION))),$(MIN_MA
>   $(error You have make '$(RUNNING_MAKE_VERSION)' installed. GNU make >= $(MIN_MAKE_VERSION) is required)
>   endif
>   
> +# Check for make versions to skip because of their bugs
> +SKIP_MAKE_VERSION = 4.3
> +ifneq ($(filter $(RUNNING_MAKE_VERSION),$(SKIP_MAKE_VERSION)),)
> +$(error You have make '$(RUNNING_MAKE_VERSION)' installed. GNU make != $(SKIP_MAKE_VERSION) is required)
> +endif
> +
>   # absolute path
>   TOPDIR := $(CURDIR)
>   CONFIG_CONFIG_IN = Config.in
> 

We can't avoid using make 4.3, so please ignore this patch. I'm going to 
work around the problem it causes, basically:
- 'make printvars' won't work stating that is supported by make 4.3
- host-libnss(probably libnss too) will be built or with MAKE1 or with 
BR2_MAKE

Best regards
diff mbox series

Patch

diff --git a/Makefile b/Makefile
index 0b8c7b2867..a07c05f8aa 100644
--- a/Makefile
+++ b/Makefile
@@ -105,6 +105,12 @@  ifneq ($(firstword $(sort $(RUNNING_MAKE_VERSION) $(MIN_MAKE_VERSION))),$(MIN_MA
 $(error You have make '$(RUNNING_MAKE_VERSION)' installed. GNU make >= $(MIN_MAKE_VERSION) is required)
 endif
 
+# Check for make versions to skip because of their bugs
+SKIP_MAKE_VERSION = 4.3
+ifneq ($(filter $(RUNNING_MAKE_VERSION),$(SKIP_MAKE_VERSION)),)
+$(error You have make '$(RUNNING_MAKE_VERSION)' installed. GNU make != $(SKIP_MAKE_VERSION) is required)
+endif
+
 # absolute path
 TOPDIR := $(CURDIR)
 CONFIG_CONFIG_IN = Config.in