diff mbox series

[1/1] package/owfs: bump to version 3.2p4

Message ID 20211230165512.2747364-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/owfs: bump to version 3.2p4 | expand

Commit Message

Fabrice Fontaine Dec. 30, 2021, 4:55 p.m. UTC
- Drop patch (already in version)
- Update indentation in hash file (two spaces)

https://github.com/owfs/owfs/releases/tag/v3.2p4

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 .../0001-Fix-compilation-with-GCC10.patch     | 41 -------------------
 package/owfs/owfs.hash                        |  6 +--
 package/owfs/owfs.mk                          |  2 +-
 3 files changed, 4 insertions(+), 45 deletions(-)
 delete mode 100644 package/owfs/0001-Fix-compilation-with-GCC10.patch

Comments

Thomas Petazzoni Dec. 30, 2021, 8:17 p.m. UTC | #1
On Thu, 30 Dec 2021 17:55:12 +0100
Fabrice Fontaine <fontaine.fabrice@gmail.com> wrote:

> - Drop patch (already in version)
> - Update indentation in hash file (two spaces)
> 
> https://github.com/owfs/owfs/releases/tag/v3.2p4
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
>  .../0001-Fix-compilation-with-GCC10.patch     | 41 -------------------
>  package/owfs/owfs.hash                        |  6 +--
>  package/owfs/owfs.mk                          |  2 +-
>  3 files changed, 4 insertions(+), 45 deletions(-)
>  delete mode 100644 package/owfs/0001-Fix-compilation-with-GCC10.patch

Applied to master, thanks.

Thomas
diff mbox series

Patch

diff --git a/package/owfs/0001-Fix-compilation-with-GCC10.patch b/package/owfs/0001-Fix-compilation-with-GCC10.patch
deleted file mode 100644
index 49b703ee28..0000000000
--- a/package/owfs/0001-Fix-compilation-with-GCC10.patch
+++ /dev/null
@@ -1,41 +0,0 @@ 
-From 43a4bc6b750c37f585d03b14941f3633ed5348d8 Mon Sep 17 00:00:00 2001
-From: "Azamat H. Hackimov" <azamat.hackimov@gmail.com>
-Date: Tue, 9 Jun 2020 11:30:38 +0300
-Subject: [PATCH] Fix compilation with GCC10
-
-Fixed compilation with -fno-common, which enabled in GCC 10 by default.
-See https://bugs.gentoo.org/707438.
-[Retrieved from:
-https://github.com/owfs/owfs/commit/43a4bc6b750c37f585d03b14941f3633ed5348d8]
-Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
----
- module/owserver/src/c/owserver.c       | 2 ++
- module/owserver/src/include/owserver.h | 2 +-
- 2 files changed, 3 insertions(+), 1 deletion(-)
-
-diff --git a/module/owserver/src/c/owserver.c b/module/owserver/src/c/owserver.c
-index db29988e..2ed29161 100644
---- a/module/owserver/src/c/owserver.c
-+++ b/module/owserver/src/c/owserver.c
-@@ -36,6 +36,8 @@
- 
- #include "owserver.h"
- 
-+pthread_mutex_t persistence_mutex ;
-+
- /* --- Prototypes ------------ */
- static void SetupAntiloop(int argc, char **argv);
- 
-diff --git a/module/owserver/src/include/owserver.h b/module/owserver/src/include/owserver.h
-index 8be582f0..a257ed02 100644
---- a/module/owserver/src/include/owserver.h
-+++ b/module/owserver/src/include/owserver.h
-@@ -18,7 +18,7 @@
- #include "ow.h"
- #include "ow_connection.h"
- 
--pthread_mutex_t persistence_mutex ;
-+extern pthread_mutex_t persistence_mutex ;
- #define PERSISTENCELOCK    _MUTEX_LOCK(   persistence_mutex ) ;
- #define PERSISTENCEUNLOCK  _MUTEX_UNLOCK( persistence_mutex ) ;
- 
diff --git a/package/owfs/owfs.hash b/package/owfs/owfs.hash
index 4c6b15a4e1..e2c51077ac 100644
--- a/package/owfs/owfs.hash
+++ b/package/owfs/owfs.hash
@@ -1,4 +1,4 @@ 
 # Locally calculated
-sha256 b8d33eba57d4a2f6c8a11ff23f233e3248bd75a42c8219b058a888846edd8717  owfs-3.2p3.tar.gz
-sha256 1f0527ab035eefb5197c68633d06f50f5077c719d82a99344702ceaca29150b9  COPYING
-sha256 8a6601b893d5784d931b2ede64a406fac463acfbb7014914e27de4d6e68457c3  COPYING.LIB
+sha256  af0a5035f3f3df876ca15aea13486bfed6b3ef5409dee016db0be67755c35fcc  owfs-3.2p4.tar.gz
+sha256  1f0527ab035eefb5197c68633d06f50f5077c719d82a99344702ceaca29150b9  COPYING
+sha256  8a6601b893d5784d931b2ede64a406fac463acfbb7014914e27de4d6e68457c3  COPYING.LIB
diff --git a/package/owfs/owfs.mk b/package/owfs/owfs.mk
index 10543d3698..7c69a5251b 100644
--- a/package/owfs/owfs.mk
+++ b/package/owfs/owfs.mk
@@ -4,7 +4,7 @@ 
 #
 ################################################################################
 
-OWFS_VERSION = 3.2p3
+OWFS_VERSION = 3.2p4
 OWFS_SITE = https://github.com/owfs/owfs/releases/download/v$(OWFS_VERSION)
 OWFS_DEPENDENCIES = host-pkgconf
 OWFS_CONF_OPTS = --disable-owperl --without-perl5 --disable-owtcl --without-tcl