diff mbox series

[1/1] package/python-cycler: bump to version 0.11.0

Message ID 20211229102927.535401-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/python-cycler: bump to version 0.11.0 | expand

Commit Message

Fabrice Fontaine Dec. 29, 2021, 10:29 a.m. UTC
- python 2 support has been dropped since
  https://github.com/matplotlib/cycler/commit/2a8831489b8ea05614459afb3135db3248890268
- Update indentation in hash file (two spaces)

https://github.com/matplotlib/cycler/releases/tag/v0.11.0

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/python-cycler/Config.in          | 1 +
 package/python-cycler/python-cycler.hash | 7 ++++---
 package/python-cycler/python-cycler.mk   | 4 ++--
 3 files changed, 7 insertions(+), 5 deletions(-)

Comments

Thomas Petazzoni Dec. 29, 2021, 5:33 p.m. UTC | #1
On Wed, 29 Dec 2021 11:29:27 +0100
Fabrice Fontaine <fontaine.fabrice@gmail.com> wrote:

> - python 2 support has been dropped since
>   https://github.com/matplotlib/cycler/commit/2a8831489b8ea05614459afb3135db3248890268
> - Update indentation in hash file (two spaces)
> 
> https://github.com/matplotlib/cycler/releases/tag/v0.11.0
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
>  package/python-cycler/Config.in          | 1 +
>  package/python-cycler/python-cycler.hash | 7 ++++---
>  package/python-cycler/python-cycler.mk   | 4 ++--
>  3 files changed, 7 insertions(+), 5 deletions(-)

Applied to master, thanks.

Thomas
diff mbox series

Patch

diff --git a/package/python-cycler/Config.in b/package/python-cycler/Config.in
index 813bc69dd4..39ff23e45f 100644
--- a/package/python-cycler/Config.in
+++ b/package/python-cycler/Config.in
@@ -1,5 +1,6 @@ 
 config BR2_PACKAGE_PYTHON_CYCLER
 	bool "python-cycler"
+	depends on BR2_PACKAGE_PYTHON3
 	help
 	  Creates a Cycler objects much like cycler, but
 	  includes input validation.
diff --git a/package/python-cycler/python-cycler.hash b/package/python-cycler/python-cycler.hash
index 8255458b26..cef416a86d 100644
--- a/package/python-cycler/python-cycler.hash
+++ b/package/python-cycler/python-cycler.hash
@@ -1,4 +1,5 @@ 
-# sha256 from https://pypi.org/project/cyclic/#files
-sha256	cd7b2d1018258d7247a71425e9f26463dfb444d411c39569972f4ce586b0c9d8  cycler-0.10.0.tar.gz
+# md5, sha256 from https://pypi.org/pypi/cycler/json
+md5  4d0c25f418956e91c47163179682e0ef  cycler-0.11.0.tar.gz
+sha256  9c87405839a19696e837b3b818fed3f5f69f16f1eec1a1ad77e043dcea9c772f  cycler-0.11.0.tar.gz
 # Locally computed sha256 checksums
-sha256	f1218143d766da3fea66f13396b7f15df46a83303f29bf96ba6e98eb4d42f408  LICENSE
+sha256  f1218143d766da3fea66f13396b7f15df46a83303f29bf96ba6e98eb4d42f408  LICENSE
diff --git a/package/python-cycler/python-cycler.mk b/package/python-cycler/python-cycler.mk
index fcdcb148a1..03155d7241 100644
--- a/package/python-cycler/python-cycler.mk
+++ b/package/python-cycler/python-cycler.mk
@@ -4,9 +4,9 @@ 
 #
 ################################################################################
 
-PYTHON_CYCLER_VERSION = 0.10.0
+PYTHON_CYCLER_VERSION = 0.11.0
 PYTHON_CYCLER_SOURCE = cycler-$(PYTHON_CYCLER_VERSION).tar.gz
-PYTHON_CYCLER_SITE = https://files.pythonhosted.org/packages/c2/4b/137dea450d6e1e3d474e1d873cd1d4f7d3beed7e0dc973b06e8e10d32488
+PYTHON_CYCLER_SITE = https://files.pythonhosted.org/packages/34/45/a7caaacbfc2fa60bee42effc4bcc7d7c6dbe9c349500e04f65a861c15eb9
 PYTHON_CYCLER_LICENSE = BSD-3-Clause
 PYTHON_CYCLER_LICENSE_FILES = LICENSE
 PYTHON_CYCLER_SETUP_TYPE = setuptools