diff mbox series

[v2,1/3] package/cross-ldd: new package

Message ID 20211219073119.1087539-1-thierry.bultel@linatsea.fr
State Superseded
Headers show
Series [v2,1/3] package/cross-ldd: new package | expand

Commit Message

Thierry Bultel Dec. 19, 2021, 7:31 a.m. UTC
cross-ldd works just as ldd, but supports
other architectures. It is needed by dracut, for instance.

Signed-off-by: Thierry Bultel <thierry.bultel@linatsea.fr>
---
Changes v1 -> v2:
  - simplified the download (suggested by Arnoult)
---
 package/Config.in              |  1 +
 package/cross-ldd/Config.in    |  7 +++++++
 package/cross-ldd/cross-ldd.mk | 15 +++++++++++++++
 3 files changed, 23 insertions(+)
 create mode 100644 package/cross-ldd/Config.in
 create mode 100644 package/cross-ldd/cross-ldd.mk
diff mbox series

Patch

diff --git a/package/Config.in b/package/Config.in
index bcb23132c9..5d0f858c03 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -162,6 +162,7 @@  menu "Development tools"
 	source "package/check/Config.in"
 	source "package/cmake/Config.in"
 	source "package/cppunit/Config.in"
+	source "package/cross-ldd/Config.in"
 	source "package/cukinia/Config.in"
 	source "package/cunit/Config.in"
 	source "package/cvs/Config.in"
diff --git a/package/cross-ldd/Config.in b/package/cross-ldd/Config.in
new file mode 100644
index 0000000000..3858fbc5fe
--- /dev/null
+++ b/package/cross-ldd/Config.in
@@ -0,0 +1,7 @@ 
+config BR2_PACKAGE_HOST_CROSS_LDD
+	bool "cross-ldd"
+	help
+	  ldd drop-in replacement for cross-compilation
+	  toolchains.
+	  This is the officially supported version mentioned
+	  in the dracut documentation
diff --git a/package/cross-ldd/cross-ldd.mk b/package/cross-ldd/cross-ldd.mk
new file mode 100644
index 0000000000..6b507a651a
--- /dev/null
+++ b/package/cross-ldd/cross-ldd.mk
@@ -0,0 +1,15 @@ 
+################################################################################
+#
+# cross-ldd
+#
+################################################################################
+
+CROSS_LDD_VERSION = 6c9c724ebd6a29c279c6e5734e44c07f067808ec
+CROSS_LDD_SOURCE = $(CROSS_LDD_VERSION).tar.gz
+CROSS_LDD_SITE = https://gist.github.com/jerome-pouiller/c403786c1394f53f44a3b61214489e6f/archive
+
+define HOST_CROSS_LDD_INSTALL_CMDS
+	install -m 755 $(@D)/cross-compile-ldd $(TARGET_CROSS)ldd
+endef
+
+$(eval $(host-generic-package))