diff mbox series

[v2,5/6] package/luajit: disable 64 bit GC objects

Message ID 20211112190650.84234-6-romain.naour@gmail.com
State Accepted
Headers show
Series rework luvi test in gitlab after luajit version bump. | expand

Commit Message

Romain Naour Nov. 12, 2021, 7:06 p.m. UTC
From: Francois Perrad <fperrad@gmail.com>

Luvi uses the cross bytecode generation of host-luajit
the bytecode format has 2 flavors, depending of GC64 option.

Since the commit https://github.com/LuaJIT/LuaJIT/commit/bd00094c3b50e193fb32aad79b7ea8ea6b78ed25
GC64 mode is enable by default on all 64bits platform.

With this patch, luajit and host-luajit are built with the same option,
so the bytecode generated by host-luajit is valid on luajit.

Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
[Romain:
  - update commit title
  - add a comment about missing LUAJIT_ENABLE_GC64]
Signed-off-by: Romain Naour <romain.naour@gmail.com>
---
The luvi test still doesn't works all the time since the output of
"luvi -v" is not reproducible
---
 package/luajit/luajit.mk | 2 ++
 1 file changed, 2 insertions(+)
diff mbox series

Patch

diff --git a/package/luajit/luajit.mk b/package/luajit/luajit.mk
index fbbd8ebc70..89b164c96d 100644
--- a/package/luajit/luajit.mk
+++ b/package/luajit/luajit.mk
@@ -26,8 +26,10 @@  endif
 # libraries are installed.
 ifeq ($(BR2_ARCH_IS_64),y)
 LUAJIT_HOST_CC = $(HOSTCC)
+# There is no LUAJIT_ENABLE_GC64 option.
 else
 LUAJIT_HOST_CC = $(HOSTCC) -m32
+LUAJIT_XCFLAGS += -DLUAJIT_DISABLE_GC64
 endif
 
 # We unfortunately can't use TARGET_CONFIGURE_OPTS, because the luajit