diff mbox series

core/pkg-generic: also list files installed in images/

Message ID 20211109170420.1948423-1-yann.morin.1998@free.fr
State Handled Elsewhere
Headers show
Series core/pkg-generic: also list files installed in images/ | expand

Commit Message

Yann E. MORIN Nov. 9, 2021, 5:04 p.m. UTC
Some packages install nothing in target nor staging, but install images
(like the kernel vmlinux, or a bootloader boot blob...)

If we want to apropriately account for the files installed by each
package, we also need to take images/ into account.

Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
Cc: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Cc: Herve Codina <herve.codina@bootlin.com>
---
 package/pkg-generic.mk | 2 ++
 1 file changed, 2 insertions(+)

Comments

Herve Codina Nov. 11, 2021, 3:11 p.m. UTC | #1
Hi,

On Tue,  9 Nov 2021 18:04:20 +0100
"Yann E. MORIN" <yann.morin.1998@free.fr> wrote:

> Some packages install nothing in target nor staging, but install images
> (like the kernel vmlinux, or a bootloader boot blob...)
> 
> If we want to apropriately account for the files installed by each
> package, we also need to take images/ into account.
> 
> Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
> Cc: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
> Cc: Herve Codina <herve.codina@bootlin.com>
> ---

Just a typo:
s/apropriately/appropriately/

Ok for the patch content.

Best regards,
Hervé
Peter Korsgaard Dec. 12, 2021, 10:13 p.m. UTC | #2
>>>>> "Yann" == Yann E MORIN <yann.morin.1998@free.fr> writes:

 > Some packages install nothing in target nor staging, but install images
 > (like the kernel vmlinux, or a bootloader boot blob...)

 > If we want to apropriately account for the files installed by each
 > package, we also need to take images/ into account.

 > Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
 > Cc: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
 > Cc: Herve Codina <herve.codina@bootlin.com>

Committed to 2021.02.x and 2021.08.x, thanks.
diff mbox series

Patch

diff --git a/package/pkg-generic.mk b/package/pkg-generic.mk
index ab48240283..5626af1d87 100644
--- a/package/pkg-generic.mk
+++ b/package/pkg-generic.mk
@@ -276,6 +276,7 @@  $(BUILD_DIR)/%/.stamp_configured:
 	$(call prepare-per-package-directory,$($(PKG)_FINAL_DEPENDENCIES))
 	@$(call pkg_size_before,$(TARGET_DIR))
 	@$(call pkg_size_before,$(STAGING_DIR),-staging)
+	@$(call pkg_size_before,$(BINARIES_DIR),-images)
 	@$(call pkg_size_before,$(HOST_DIR),-host)
 	$(call fixup-libtool-files,$(NAME),$(HOST_DIR))
 	$(call fixup-libtool-files,$(NAME),$(STAGING_DIR))
@@ -402,6 +403,7 @@  $(BUILD_DIR)/%/.stamp_target_installed:
 $(BUILD_DIR)/%/.stamp_installed:
 	@$(call pkg_size_after,$(TARGET_DIR))
 	@$(call pkg_size_after,$(STAGING_DIR),-staging)
+	@$(call pkg_size_after,$(BINARIES_DIR),-images)
 	@$(call pkg_size_after,$(HOST_DIR),-host)
 	@$(call check_bin_arch)
 	$(Q)touch $@