diff mbox series

[v2,1/1] package/python-cryptography: add host-python3-six host dependency

Message ID 20211103201932.296897-1-james.hilliard1@gmail.com
State Accepted
Headers show
Series [v2,1/1] package/python-cryptography: add host-python3-six host dependency | expand

Commit Message

James Hilliard Nov. 3, 2021, 8:19 p.m. UTC
This dependency wasn't added during the removal of
python3-cryptography.

The conversion/dropping of python3-cryptography was done with commits
[1] and [2], and the commit log of [1] states the dropping of the
host-python3-six dependency was intentionally:

        [...]
        While at it, drop host-python3-pip and host-python3-six as these
        dependencies are not needed. Indeed, pip was never a dependency of
        cryptography and six is not a dependency with python3 and will be
        dropped in version 3.4 and
        https://github.com/pyca/cryptography/commit/e66db8079d3fbd0110e87ece1fd48f4bfd9e48b9
        [...]

But the package python-cryptography is still at version 3.3.2 (and
clearly depends on six)

[1] https://git.buildroot.net/buildroot/commit/?id=95a63a34ac9204c4fe069154783bd97ed48c3ae2
[2] https://git.buildroot.net/buildroot/commit/?id=43147827a7b759248288fad1d97130c027c23e9a

Fixes:
 - http://autobuild.buildroot.net/results/971/9711ccebb9c3e2fa8f17d969d8b431d4301677e3/build-end.log

Reviewed-by: Peter Seiderer <ps.report@gmx.net>
Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
---
Changes v1 -> v2:
  - add explanation for six being required still
---
 package/python-cryptography/python-cryptography.mk | 5 ++++-
 1 file changed, 4 insertions(+), 1 deletion(-)

Comments

Thomas Petazzoni Nov. 4, 2021, 8:19 p.m. UTC | #1
On Wed,  3 Nov 2021 14:19:32 -0600
James Hilliard <james.hilliard1@gmail.com> wrote:

> This dependency wasn't added during the removal of
> python3-cryptography.
> 
> The conversion/dropping of python3-cryptography was done with commits
> [1] and [2], and the commit log of [1] states the dropping of the
> host-python3-six dependency was intentionally:
> 
>         [...]
>         While at it, drop host-python3-pip and host-python3-six as these
>         dependencies are not needed. Indeed, pip was never a dependency of
>         cryptography and six is not a dependency with python3 and will be
>         dropped in version 3.4 and
>         https://github.com/pyca/cryptography/commit/e66db8079d3fbd0110e87ece1fd48f4bfd9e48b9
>         [...]
> 
> But the package python-cryptography is still at version 3.3.2 (and
> clearly depends on six)
> 
> [1] https://git.buildroot.net/buildroot/commit/?id=95a63a34ac9204c4fe069154783bd97ed48c3ae2
> [2] https://git.buildroot.net/buildroot/commit/?id=43147827a7b759248288fad1d97130c027c23e9a
> 
> Fixes:
>  - http://autobuild.buildroot.net/results/971/9711ccebb9c3e2fa8f17d969d8b431d4301677e3/build-end.log
> 
> Reviewed-by: Peter Seiderer <ps.report@gmx.net>
> Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
> ---
> Changes v1 -> v2:
>   - add explanation for six being required still
> ---
>  package/python-cryptography/python-cryptography.mk | 5 ++++-
>  1 file changed, 4 insertions(+), 1 deletion(-)

Applied to master, thanks. I am curious to hear why the target version
of python-cryptography does not need python-six. Is it because our
target Python interpreter is recent enough that it implements all what
python-cryptography needs, without python-six as a "compatibility"
layer?

Thanks!

Thomas
diff mbox series

Patch

diff --git a/package/python-cryptography/python-cryptography.mk b/package/python-cryptography/python-cryptography.mk
index e21b9db042..081dfc06a0 100644
--- a/package/python-cryptography/python-cryptography.mk
+++ b/package/python-cryptography/python-cryptography.mk
@@ -14,7 +14,10 @@  PYTHON_CRYPTOGRAPHY_CPE_ID_VENDOR = cryptography_project
 PYTHON_CRYPTOGRAPHY_CPE_ID_PRODUCT = cryptography
 PYTHON_CRYPTOGRAPHY_DEPENDENCIES = host-python-cffi openssl
 HOST_PYTHON_CRYPTOGRAPHY_NEEDS_HOST_PYTHON = python3
-HOST_PYTHON_CRYPTOGRAPHY_DEPENDENCIES = host-python3-cffi host-openssl
+HOST_PYTHON_CRYPTOGRAPHY_DEPENDENCIES = \
+	host-python3-cffi \
+	host-python3-six \
+	host-openssl
 
 $(eval $(python-package))
 $(eval $(host-python-package))