diff mbox series

Makefile: include *.patch in check-package

Message ID 20211025192813.159336-1-arnout@mind.be
State Superseded
Headers show
Series Makefile: include *.patch in check-package | expand

Commit Message

Arnout Vandecappelle Oct. 25, 2021, 7:28 p.m. UTC
Since a long time, we have a check-package check for patches. Make sure
that this check runs in 'make check-package', by including *.patch in
the find expression.

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
---
DO NOT APPLY!

At the moment, this causes about 100 check-package failures due to PATCH
1/1 and missing SoBs. We first need to fix all those, but I don't have
the time/energy for it at the moment.
---
 Makefile | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/Makefile b/Makefile
index c960b53a6d..c2f9f19b0f 100644
--- a/Makefile
+++ b/Makefile
@@ -1224,7 +1224,7 @@  check-flake8:
 	| xargs -- python3 -m flake8 --statistics
 
 check-package:
-	find $(TOPDIR) -type f \( -name '*.mk' -o -name '*.hash' -o -name 'Config.*' \) \
+	find $(TOPDIR) -type f \( -name '*.mk' -o -name '*.hash' -o -name 'Config.*' -o -name '*.patch' \) \
 		-exec ./utils/check-package {} +
 
 include docs/manual/manual.mk