diff mbox series

package/zfs: bump version to 2.0.6

Message ID 20211025123117.3605744-1-salvador.joseluis@gmail.com
State Changes Requested
Headers show
Series package/zfs: bump version to 2.0.6 | expand

Commit Message

José Luis Salvador Rufo Oct. 25, 2021, 12:31 p.m. UTC
Added patch from upstream that fixes the `make` executed from the
`kernel.m4` in cross-platform-compilations environments.

As this version brings support for kernel up to 5.14, we update the
test cases to use the 5.14 kernel.

Signed-off-by: José Luis Salvador Rufo <salvador.joseluis@gmail.com>
---
I didn't find another alternative yet to:
```
ZFS_MAKE_ENV = $(LINUX_MAKE_FLAGS)
ZFS_CONF_ENV = $(LINUX_MAKE_FLAGS)
```
Any suggestion?

 package/zfs/zfs.hash                      |  5 ++--
 package/zfs/zfs.mk                        |  8 ++++-
 support/testing/tests/package/test_zfs.py | 36 ++++++++---------------
 3 files changed, 22 insertions(+), 27 deletions(-)

Comments

Thomas Petazzoni Nov. 14, 2021, 3:23 p.m. UTC | #1
Hello José,

On Mon, 25 Oct 2021 14:31:18 +0200
José Luis Salvador Rufo <salvador.joseluis@gmail.com> wrote:

> Added patch from upstream that fixes the `make` executed from the
> `kernel.m4` in cross-platform-compilations environments.

There is no patch added in this proposed patch. It seems like this
commit log was not properly updated now that you're bumping to a new
version of ZFS.

> As this version brings support for kernel up to 5.14, we update the
> test cases to use the 5.14 kernel.
> 
> Signed-off-by: José Luis Salvador Rufo <salvador.joseluis@gmail.com>
> ---
> I didn't find another alternative yet to:
> ```
> ZFS_MAKE_ENV = $(LINUX_MAKE_FLAGS)
> ZFS_CONF_ENV = $(LINUX_MAKE_FLAGS)
> ```
> Any suggestion?

Did you try the suggestion from Arnout, which he made on August 28? See
https://lore.kernel.org/buildroot/1433accf-3050-0f2e-9701-3da87c8c7c12@mind.be/


> -class TestZfsGlibc(infra.basetest.BRTest):
> -    config = \
> -        """
> +class TestZfsBase(infra.basetest.BRTest):
> +    config = """

It seems like you are also refactoring the ZFS test cases to avoid
duplicating the configuration for the glibc and uclibc cases. This is a
good idea, but it should be done in a separate patch, before the ZFS
bump.

Thanks!

Thomas
diff mbox series

Patch

diff --git a/package/zfs/zfs.hash b/package/zfs/zfs.hash
index 7f4f5a59f8..0662959f6b 100644
--- a/package/zfs/zfs.hash
+++ b/package/zfs/zfs.hash
@@ -1,5 +1,6 @@ 
-# From https://github.com/openzfs/zfs/releases/download/zfs-2.0.5/zfs-2.0.5.sha256.asc
-sha256  3a17498d704ebf4c5d7231660f6fb44ae07a1545519f567452a4270851a86ec9  zfs-2.0.5.tar.gz
+# From https://github.com/openzfs/zfs/releases/download/zfs-2.0.6/zfs-2.0.6.sha256.asc
+sha256  44b22166b103022e3ca67cb713abdc991e274ed141b6a30568a1bd5c80b2aa95  zfs-2.0.6.tar.gz
+sha256  6ebc1cb552f1428606b6e75d2c95574685bab71a9cd8e3679d416f486dc05b74  ed3a3bdb0d59772ae4b8719cb6ffa690627bf112.patch
 
 # Hash for license files:
 sha256  1ffb70c33c4f79f04e947facc5c7851f289609256aacb47fc115f700427d9520  LICENSE
diff --git a/package/zfs/zfs.mk b/package/zfs/zfs.mk
index 3b1afb419a..259af99f39 100644
--- a/package/zfs/zfs.mk
+++ b/package/zfs/zfs.mk
@@ -4,15 +4,21 @@ 
 #
 ################################################################################
 
-ZFS_VERSION = 2.0.5
+ZFS_VERSION = 2.0.6
 ZFS_SITE = https://github.com/openzfs/zfs/releases/download/zfs-$(ZFS_VERSION)
 ZFS_LICENSE = CDDL
 ZFS_LICENSE_FILES = LICENSE COPYRIGHT
 ZFS_CPE_ID_VENDOR = openzfs
 ZFS_CPE_ID_PRODUCT = openzfs
 
+ZFS_PATCH = https://github.com/openzfs/zfs/commit/ed3a3bdb0d59772ae4b8719cb6ffa690627bf112.patch
 ZFS_AUTORECONF = YES
 
+# cross compile environment for linux kernel module
+ZFS_MAKE_ENV = $(LINUX_MAKE_FLAGS)
+# `./configure` will execute a `make modules` test case
+ZFS_CONF_ENV = $(LINUX_MAKE_FLAGS)
+
 ZFS_DEPENDENCIES = libaio openssl udev util-linux zlib
 
 # sysvinit installs only a commented-out modules-load.d/ config file
diff --git a/support/testing/tests/package/test_zfs.py b/support/testing/tests/package/test_zfs.py
index 772a66c1e4..03bcfb3c8c 100644
--- a/support/testing/tests/package/test_zfs.py
+++ b/support/testing/tests/package/test_zfs.py
@@ -3,17 +3,15 @@  import os
 import infra.basetest
 
 
-class TestZfsGlibc(infra.basetest.BRTest):
-    config = \
-        """
+class TestZfsBase(infra.basetest.BRTest):
+    config = """
         BR2_x86_64=y
         BR2_x86_corei7=y
         BR2_TOOLCHAIN_EXTERNAL=y
-        BR2_TOOLCHAIN_EXTERNAL_BOOTLIN_X86_64_CORE_I7_GLIBC_STABLE=y
         BR2_ROOTFS_DEVICE_CREATION_DYNAMIC_EUDEV=y
         BR2_LINUX_KERNEL=y
         BR2_LINUX_KERNEL_CUSTOM_VERSION=y
-        BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE="5.12.13"
+        BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE="5.14.14"
         BR2_LINUX_KERNEL_USE_CUSTOM_CONFIG=y
         BR2_LINUX_KERNEL_CUSTOM_CONFIG_FILE="board/qemu/x86_64/linux.config"
         BR2_PACKAGE_ZFS=y
@@ -26,6 +24,13 @@  class TestZfsGlibc(infra.basetest.BRTest):
         # BR2_TARGET_ROOTFS_TAR is not set
         """
 
+
+class TestZfsGlibc(TestZfsBase):
+    config = TestZfsBase.config + \
+        """
+        BR2_TOOLCHAIN_EXTERNAL_BOOTLIN_X86_64_CORE_I7_GLIBC_STABLE=y
+        """
+
     def test_run(self):
         kernel = os.path.join(self.builddir, "images", "bzImage")
         cpio_file = os.path.join(self.builddir, "images", "rootfs.cpio")
@@ -60,27 +65,10 @@  class TestZfsGlibc(infra.basetest.BRTest):
             self.assertRunOk(cmd)
 
 
-class TestZfsUclibc(infra.basetest.BRTest):
-    config = \
+class TestZfsUclibc(TestZfsBase):
+    config = TestZfsBase.config + \
         """
-        BR2_x86_64=y
-        BR2_x86_corei7=y
-        BR2_TOOLCHAIN_EXTERNAL=y
         BR2_TOOLCHAIN_EXTERNAL_BOOTLIN_X86_64_CORE_I7_UCLIBC_STABLE=y
-        BR2_ROOTFS_DEVICE_CREATION_DYNAMIC_EUDEV=y
-        BR2_LINUX_KERNEL=y
-        BR2_LINUX_KERNEL_CUSTOM_VERSION=y
-        BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE="5.12.13"
-        BR2_LINUX_KERNEL_USE_CUSTOM_CONFIG=y
-        BR2_LINUX_KERNEL_CUSTOM_CONFIG_FILE="board/qemu/x86_64/linux.config"
-        BR2_PACKAGE_ZFS=y
-        BR2_PACKAGE_PYTHON3=y
-        BR2_PACKAGE_PYTHON_CFFI=y
-        BR2_PACKAGE_PYTHON_SETUPTOOLS=y
-        BR2_PACKAGE_ZLIB_NG=y
-        BR2_PACKAGE_LIBRESSL=y
-        BR2_TARGET_ROOTFS_CPIO=y
-        # BR2_TARGET_ROOTFS_TAR is not set
         """
 
     def test_run(self):