diff mbox series

[1/2] package/ipcalc: add libmaxminddb support

Message ID 20211020165446.2754391-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/2] package/ipcalc: add libmaxminddb support | expand

Commit Message

Fabrice Fontaine Oct. 20, 2021, 4:54 p.m. UTC
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/ipcalc/ipcalc.mk | 11 ++++++++---
 1 file changed, 8 insertions(+), 3 deletions(-)

Comments

Thomas Petazzoni Oct. 20, 2021, 9:36 p.m. UTC | #1
On Wed, 20 Oct 2021 18:54:45 +0200
Fabrice Fontaine <fontaine.fabrice@gmail.com> wrote:

> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
>  package/ipcalc/ipcalc.mk | 11 ++++++++---
>  1 file changed, 8 insertions(+), 3 deletions(-)

Both applied to master, thanks!

Thomas
diff mbox series

Patch

diff --git a/package/ipcalc/ipcalc.mk b/package/ipcalc/ipcalc.mk
index ff9d643389..145b6904b9 100644
--- a/package/ipcalc/ipcalc.mk
+++ b/package/ipcalc/ipcalc.mk
@@ -10,8 +10,13 @@  IPCALC_SOURCE = ipcalc-$(IPCALC_VERSION).tar.bz2
 IPCALC_LICENSE = GPL-2.0+
 IPCALC_LICENSE_FILES = COPYING
 
-IPCALC_CONF_OPTS = \
-	-Duse_maxminddb=disabled \
-	-Duse_geoip=disabled
+IPCALC_CONF_OPTS = -Duse_geoip=disabled
+
+ifeq ($(BR2_PACKAGE_LIBMAXMINDDB),y)
+IPCALC_CONF_OPTS += -Duse_maxminddb=enabled
+IPCALC_DEPENDENCIES += host-pkgconf libmaxminddb
+else
+IPCALC_CONF_OPTS += -Duse_maxminddb=disabled
+endif
 
 $(eval $(meson-package))