diff mbox series

[1/1] package/python-libusb1: needs python3

Message ID 20211016134011.3092826-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/python-libusb1: needs python3 | expand

Commit Message

Fabrice Fontaine Oct. 16, 2021, 1:40 p.m. UTC
python2 support has been dropped since version 1.10.0 and
https://github.com/vpelletier/python-libusb1/commit/69fd5a3ed2f674d412131dfaf24bbc2534f3cf13
resulting in the following build failure since bump to version 2.0.1 in
commit 6703b94f24320316ddfc2a3ec3e40fe3876dc8c8:

Traceback (most recent call last):
  File "setup.py", line 22, in <module>
    from html.parser import HTMLParser
ImportError: No module named html.parser

Fixes:
 - http://autobuild.buildroot.org/results/fe011ccb7eac1be9762919f9feda35114e752d8a

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/python-libusb1/Config.in | 2 ++
 1 file changed, 2 insertions(+)

Comments

Arnout Vandecappelle Oct. 25, 2021, 8:15 p.m. UTC | #1
On 16/10/2021 15:40, Fabrice Fontaine wrote:
> python2 support has been dropped since version 1.10.0 and
> https://github.com/vpelletier/python-libusb1/commit/69fd5a3ed2f674d412131dfaf24bbc2534f3cf13
> resulting in the following build failure since bump to version 2.0.1 in
> commit 6703b94f24320316ddfc2a3ec3e40fe3876dc8c8:
> 
> Traceback (most recent call last):
>    File "setup.py", line 22, in <module>
>      from html.parser import HTMLParser
> ImportError: No module named html.parser
> 
> Fixes:
>   - http://autobuild.buildroot.org/results/fe011ccb7eac1be9762919f9feda35114e752d8a
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

  Applied to master, thanks.

  Regards,
  Arnout

> ---
>   package/python-libusb1/Config.in | 2 ++
>   1 file changed, 2 insertions(+)
> 
> diff --git a/package/python-libusb1/Config.in b/package/python-libusb1/Config.in
> index e464a0394d..fbad70c375 100644
> --- a/package/python-libusb1/Config.in
> +++ b/package/python-libusb1/Config.in
> @@ -1,5 +1,6 @@
>   config BR2_PACKAGE_PYTHON_LIBUSB1
>   	bool "python-libusb1"
> +	depends on BR2_PACKAGE_PYTHON3
>   	depends on BR2_TOOLCHAIN_HAS_THREADS # libusb
>   	depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_9 # libusb
>   	select BR2_PACKAGE_LIBUSB
> @@ -9,5 +10,6 @@ config BR2_PACKAGE_PYTHON_LIBUSB1
>   	  http://github.com/vpelletier/python-libusb1
>   
>   comment "python-libusb1 needs a toolchain w/ threads, gcc >= 4.9"
> +	depends on BR2_PACKAGE_PYTHON3
>   	depends on !BR2_TOOLCHAIN_HAS_THREADS || \
>   		!BR2_TOOLCHAIN_GCC_AT_LEAST_4_9
>
diff mbox series

Patch

diff --git a/package/python-libusb1/Config.in b/package/python-libusb1/Config.in
index e464a0394d..fbad70c375 100644
--- a/package/python-libusb1/Config.in
+++ b/package/python-libusb1/Config.in
@@ -1,5 +1,6 @@ 
 config BR2_PACKAGE_PYTHON_LIBUSB1
 	bool "python-libusb1"
+	depends on BR2_PACKAGE_PYTHON3
 	depends on BR2_TOOLCHAIN_HAS_THREADS # libusb
 	depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_9 # libusb
 	select BR2_PACKAGE_LIBUSB
@@ -9,5 +10,6 @@  config BR2_PACKAGE_PYTHON_LIBUSB1
 	  http://github.com/vpelletier/python-libusb1
 
 comment "python-libusb1 needs a toolchain w/ threads, gcc >= 4.9"
+	depends on BR2_PACKAGE_PYTHON3
 	depends on !BR2_TOOLCHAIN_HAS_THREADS || \
 		!BR2_TOOLCHAIN_GCC_AT_LEAST_4_9