diff mbox series

[1/1] package/micropython: depends on host-python3

Message ID 20211014213025.66942-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/micropython: depends on host-python3 | expand

Commit Message

Fabrice Fontaine Oct. 14, 2021, 9:30 p.m. UTC
Replace BR2_PYTHON3_HOST_DEPENDENCY by host-python3 to avoid the
following build failure raised since bump to version 1.17 in commit
32b2a03745785afeb496979aa3c0f654bc6063ce:

Traceback (most recent call last):
  File "../py/makeversionhdr.py", line 117, in <module>
    make_version_header(sys.argv[1])
  File "../py/makeversionhdr.py", line 79, in make_version_header
    info = get_version_info_from_docs_conf()
  File "../py/makeversionhdr.py", line 67, in get_version_info_from_docs_conf
    for line in f:
  File "/usr/lib/python3.5/encodings/ascii.py", line 26, in decode
    return codecs.ascii_decode(input, self.errors)[0]
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc2 in position 2154: ordinal not in range(128)

Indeed, this build failure is not reproduced by host-python3 (in version
3.9.7) so it is probably an issue with python 3.5 (which is 6-years old).

Fixes:
 - http://autobuild.buildroot.org/results/96f7b81f5d14715b0b6673a8016a31e9e1552d0b

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/micropython/micropython.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Chris Packham Oct. 15, 2021, 7:22 a.m. UTC | #1
On Fri, 15 Oct 2021, 10:32 AM Fabrice Fontaine, <fontaine.fabrice@gmail.com>
wrote:

> Replace BR2_PYTHON3_HOST_DEPENDENCY by host-python3 to avoid the
> following build failure raised since bump to version 1.17 in commit
> 32b2a03745785afeb496979aa3c0f654bc6063ce:
>
> Traceback (most recent call last):
>   File "../py/makeversionhdr.py", line 117, in <module>
>     make_version_header(sys.argv[1])
>   File "../py/makeversionhdr.py", line 79, in make_version_header
>     info = get_version_info_from_docs_conf()
>   File "../py/makeversionhdr.py", line 67, in
> get_version_info_from_docs_conf
>     for line in f:
>   File "/usr/lib/python3.5/encodings/ascii.py", line 26, in decode
>     return codecs.ascii_decode(input, self.errors)[0]
> UnicodeDecodeError: 'ascii' codec can't decode byte 0xc2 in position 2154:
> ordinal not in range(128)
>
> Indeed, this build failure is not reproduced by host-python3 (in version
> 3.9.7) so it is probably an issue with python 3.5 (which is 6-years old).
>
> Fixes:
>  -
> http://autobuild.buildroot.org/results/96f7b81f5d14715b0b6673a8016a31e9e1552d0b
>
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
>

Thanks, I'd seen the failures but been unable to reproduce them. I figured
it was something to do with the python installation on the builders but
hadn't been able to dig into it.

It's a pity we're now forcing the building of python but I can't think of a
better alternative.

Reviewed-by: Chris Packham <judge.packham@gmail.com>

---
>  package/micropython/micropython.mk | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/package/micropython/micropython.mk b/package/micropython/
> micropython.mk
> index 3d69e152e5..c49ca23449 100644
> --- a/package/micropython/micropython.mk
> +++ b/package/micropython/micropython.mk
> @@ -11,7 +11,7 @@ MICROPYTHON_SITE = $(call
> github,micropython,micropython,v$(MICROPYTHON_VERSION)
>  # and most of the copied code is not used in the unix build.
>  MICROPYTHON_LICENSE = MIT, BSD-1-clause, BSD-3-clause, Zlib
>  MICROPYTHON_LICENSE_FILES = LICENSE
> -MICROPYTHON_DEPENDENCIES = host-pkgconf libffi
> $(BR2_PYTHON3_HOST_DEPENDENCY)
> +MICROPYTHON_DEPENDENCIES = host-pkgconf libffi host-python3
>
>  # Set GIT_DIR so package won't use buildroot's version number
>  MICROPYTHON_MAKE_ENV = \
> --
> 2.33.0
>
>
Arnout Vandecappelle Oct. 25, 2021, 7:04 p.m. UTC | #2
On 15/10/2021 09:22, Chris Packham wrote:
> 
> 
> On Fri, 15 Oct 2021, 10:32 AM Fabrice Fontaine, <fontaine.fabrice@gmail.com 
> <mailto:fontaine.fabrice@gmail.com>> wrote:
> 
>     Replace BR2_PYTHON3_HOST_DEPENDENCY by host-python3 to avoid the
>     following build failure raised since bump to version 1.17 in commit
>     32b2a03745785afeb496979aa3c0f654bc6063ce:
> 
>     Traceback (most recent call last):
>        File "../py/makeversionhdr.py", line 117, in <module>
>          make_version_header(sys.argv[1])
>        File "../py/makeversionhdr.py", line 79, in make_version_header
>          info = get_version_info_from_docs_conf()
>        File "../py/makeversionhdr.py", line 67, in get_version_info_from_docs_conf
>          for line in f:
>        File "/usr/lib/python3.5/encodings/ascii.py", line 26, in decode
>          return codecs.ascii_decode(input, self.errors)[0]
>     UnicodeDecodeError: 'ascii' codec can't decode byte 0xc2 in position 2154:
>     ordinal not in range(128)
> 
>     Indeed, this build failure is not reproduced by host-python3 (in version
>     3.9.7) so it is probably an issue with python 3.5 (which is 6-years old).
> 
>     Fixes:
>       -
>     http://autobuild.buildroot.org/results/96f7b81f5d14715b0b6673a8016a31e9e1552d0b
>     <http://autobuild.buildroot.org/results/96f7b81f5d14715b0b6673a8016a31e9e1552d0b>
> 
>     Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com
>     <mailto:fontaine.fabrice@gmail.com>>
> 
> 
> Thanks, I'd seen the failures but been unable to reproduce them. I figured it 
> was something to do with the python installation on the builders but hadn't been 
> able to dig into it.
> 
> It's a pity we're now forcing the building of python but I can't think of a 
> better alternative.

  A better alternative would be to set the encoding to UTF-8.

  Another solution would be to bump the minimum python3 to 3.6 or whatever is 
needed to make it work.

  But I applied this patch to master anyway.

  Regards,
  Arnout

> 
> Reviewed-by: Chris Packham <judge.packham@gmail.com 
> <mailto:judge.packham@gmail.com>>
> 
>     ---
>       package/micropython/micropython.mk <http://micropython.mk> | 2 +-
>       1 file changed, 1 insertion(+), 1 deletion(-)
> 
>     diff --git a/package/micropython/micropython.mk <http://micropython.mk>
>     b/package/micropython/micropython.mk <http://micropython.mk>
>     index 3d69e152e5..c49ca23449 100644
>     --- a/package/micropython/micropython.mk <http://micropython.mk>
>     +++ b/package/micropython/micropython.mk <http://micropython.mk>
>     @@ -11,7 +11,7 @@ MICROPYTHON_SITE = $(call
>     github,micropython,micropython,v$(MICROPYTHON_VERSION)
>       # and most of the copied code is not used in the unix build.
>       MICROPYTHON_LICENSE = MIT, BSD-1-clause, BSD-3-clause, Zlib
>       MICROPYTHON_LICENSE_FILES = LICENSE
>     -MICROPYTHON_DEPENDENCIES = host-pkgconf libffi $(BR2_PYTHON3_HOST_DEPENDENCY)
>     +MICROPYTHON_DEPENDENCIES = host-pkgconf libffi host-python3
> 
>       # Set GIT_DIR so package won't use buildroot's version number
>       MICROPYTHON_MAKE_ENV = \
>     -- 
>     2.33.0
> 
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
>
diff mbox series

Patch

diff --git a/package/micropython/micropython.mk b/package/micropython/micropython.mk
index 3d69e152e5..c49ca23449 100644
--- a/package/micropython/micropython.mk
+++ b/package/micropython/micropython.mk
@@ -11,7 +11,7 @@  MICROPYTHON_SITE = $(call github,micropython,micropython,v$(MICROPYTHON_VERSION)
 # and most of the copied code is not used in the unix build.
 MICROPYTHON_LICENSE = MIT, BSD-1-clause, BSD-3-clause, Zlib
 MICROPYTHON_LICENSE_FILES = LICENSE
-MICROPYTHON_DEPENDENCIES = host-pkgconf libffi $(BR2_PYTHON3_HOST_DEPENDENCY)
+MICROPYTHON_DEPENDENCIES = host-pkgconf libffi host-python3
 
 # Set GIT_DIR so package won't use buildroot's version number
 MICROPYTHON_MAKE_ENV = \