diff mbox series

[v4,1/2] package/python3: Add bzip2 option to host

Message ID 20211009002727.972605-2-aduskett@gmail.com
State Accepted
Headers show
Series package/nodejs: bump version to 14.17.6 | expand

Commit Message

Adam Duskett Oct. 9, 2021, 12:27 a.m. UTC
The bzip2 module is needed to build the host variant of NodeJS 14.

Signed-off-by: Adam Duskett <aduskett@gmail.com>
---
 package/python3/Config.in.host | 6 ++++++
 package/python3/python3.mk     | 6 ++++++
 2 files changed, 12 insertions(+)

Comments

Arnout Vandecappelle Oct. 14, 2021, 9:03 p.m. UTC | #1
On 09/10/2021 02:27, Adam Duskett wrote:
> The bzip2 module is needed to build the host variant of NodeJS 14.
> 
> Signed-off-by: Adam Duskett <aduskett@gmail.com>
> ---
>   package/python3/Config.in.host | 6 ++++++
>   package/python3/python3.mk     | 6 ++++++
>   2 files changed, 12 insertions(+)
> 
> diff --git a/package/python3/Config.in.host b/package/python3/Config.in.host
> index 70b5dacdde..65a8df0754 100644
> --- a/package/python3/Config.in.host
> +++ b/package/python3/Config.in.host
> @@ -7,6 +7,12 @@ config BR2_PACKAGE_HOST_PYTHON3
>   
>   if BR2_PACKAGE_HOST_PYTHON3
>   
> +config BR2_PACKAGE_HOST_PYTHON3_BZIP2
> +	bool "bzip2"
> +	select BR2_PACKAGE_HOST_BZIP2

  This option doesn't exist. I removed it.

  Applied to master, thanks.

  Sorry, the nodejs bump was a bit to big to include in the low-hanging-fruit 
apply, so that's for later.

  Regards,
  Arnout

> +	help
> +	  bz2 module for host Python3.
> +
>   config BR2_PACKAGE_HOST_PYTHON3_SSL
>   	bool "ssl"
>   	select BR2_PACKAGE_HOST_OPENSSL
> diff --git a/package/python3/python3.mk b/package/python3/python3.mk
> index 3e88bc0ff4..779f6dcb6c 100644
> --- a/package/python3/python3.mk
> +++ b/package/python3/python3.mk
> @@ -43,6 +43,12 @@ PYTHON3_DEPENDENCIES = host-python3 libffi
>   
>   HOST_PYTHON3_DEPENDENCIES = host-autoconf-archive host-expat host-zlib host-libffi
>   
> +ifeq ($(BR2_PACKAGE_HOST_PYTHON3_BZIP2),y)
> +HOST_PYTHON3_DEPENDENCIES += host-bzip2
> +else
> +HOST_PYTHON3_CONF_OPTS += --disable-bzip2
> +endif
> +
>   ifeq ($(BR2_PACKAGE_HOST_PYTHON3_SSL),y)
>   HOST_PYTHON3_DEPENDENCIES += host-openssl
>   else
>
diff mbox series

Patch

diff --git a/package/python3/Config.in.host b/package/python3/Config.in.host
index 70b5dacdde..65a8df0754 100644
--- a/package/python3/Config.in.host
+++ b/package/python3/Config.in.host
@@ -7,6 +7,12 @@  config BR2_PACKAGE_HOST_PYTHON3
 
 if BR2_PACKAGE_HOST_PYTHON3
 
+config BR2_PACKAGE_HOST_PYTHON3_BZIP2
+	bool "bzip2"
+	select BR2_PACKAGE_HOST_BZIP2
+	help
+	  bz2 module for host Python3.
+
 config BR2_PACKAGE_HOST_PYTHON3_SSL
 	bool "ssl"
 	select BR2_PACKAGE_HOST_OPENSSL
diff --git a/package/python3/python3.mk b/package/python3/python3.mk
index 3e88bc0ff4..779f6dcb6c 100644
--- a/package/python3/python3.mk
+++ b/package/python3/python3.mk
@@ -43,6 +43,12 @@  PYTHON3_DEPENDENCIES = host-python3 libffi
 
 HOST_PYTHON3_DEPENDENCIES = host-autoconf-archive host-expat host-zlib host-libffi
 
+ifeq ($(BR2_PACKAGE_HOST_PYTHON3_BZIP2),y)
+HOST_PYTHON3_DEPENDENCIES += host-bzip2
+else
+HOST_PYTHON3_CONF_OPTS += --disable-bzip2
+endif
+
 ifeq ($(BR2_PACKAGE_HOST_PYTHON3_SSL),y)
 HOST_PYTHON3_DEPENDENCIES += host-openssl
 else