diff mbox series

[1/1] package/pkg-autotools: fix python with automake >= 1.16.4

Message ID 20211006164031.2627877-1-fontaine.fabrice@gmail.com
State Superseded
Headers show
Series [1/1] package/pkg-autotools: fix python with automake >= 1.16.4 | expand

Commit Message

Fabrice Fontaine Oct. 6, 2021, 4:40 p.m. UTC
Set --with-python_{prefix,exec_prefix} to fix the following build
failures with python and libsoc or libgpiod raised since bump of
automake to version 1.16.4 in commit
fe90272b5128987ee7492fff950660e05324838d and
https://git.savannah.gnu.org/cgit/automake.git/commit/?id=ed8daa069a6c8ed34f7856c42402ec46f305e670:

 /bin/mkdir -p '/home/buildroot/autobuild/instance-0/output-1/host/arc-buildroot-linux-uclibc/sysroot/home/buildroot/autobuild/instance-0/output-1/host/lib/python3.9/site-packages'
 /bin/bash ../../libtool   --mode=install /usr/bin/install -c   gpiod.la '/home/buildroot/autobuild/instance-0/output-1/host/arc-buildroot-linux-uclibc/sysroot/home/buildroot/autobuild/instance-0/output-1/host/lib/python3.9/site-packages'
libtool: install: /usr/bin/install -c .libs/gpiod.so /home/buildroot/autobuild/instance-0/output-1/host/arc-buildroot-linux-uclibc/sysroot/home/buildroot/autobuild/instance-0/output-1/host/lib/python3.9/site-packages/gpiod.so

[...]

libgpiod: installs files in /home/buildroot/autobuild/instance-0/output-1/host/arc-buildroot-linux-uclibc/sysroot//home/buildroot/autobuild/instance-0/output-1

Fixes:
 - http://autobuild.buildroot.org/results/045dc3f737f58d44014a4b717b5a565388e86f63
 - http://autobuild.buildroot.org/results/6e7a129b05e7852a4dc8dd35148664ad09610f28

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/pkg-autotools.mk | 3 +++
 1 file changed, 3 insertions(+)
diff mbox series

Patch

diff --git a/package/pkg-autotools.mk b/package/pkg-autotools.mk
index 7720d6ffe7..2566bd546d 100644
--- a/package/pkg-autotools.mk
+++ b/package/pkg-autotools.mk
@@ -189,6 +189,8 @@  define $(2)_CONFIGURE_CMDS
 		--build=$$(GNU_HOST_NAME) \
 		--prefix=/usr \
 		--exec-prefix=/usr \
+		--with-python_prefix=/usr \
+		--with-python_exec_prefix=/usr \
 		--sysconfdir=/etc \
 		--localstatedir=/var \
 		--program-prefix="" \
@@ -221,6 +223,7 @@  define $(2)_CONFIGURE_CMDS
 	CONFIG_SITE=/dev/null \
 	./configure \
 		--prefix="$$(HOST_DIR)" \
+		--with-python_prefix="$$(HOST_DIR)" \
 		--sysconfdir="$$(HOST_DIR)/etc" \
 		--localstatedir="$$(HOST_DIR)/var" \
 		--enable-shared --disable-static \