diff mbox series

[1/1] package/nmap: add zlib optional dependency

Message ID 20210923221555.1409302-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/nmap: add zlib optional dependency | expand

Commit Message

Fabrice Fontaine Sept. 23, 2021, 10:15 p.m. UTC
zlib is an optional dependency since bump to version 7.60 in commit
c4faf1d4d11764da769abdd252dd3925d83378cb and
https://github.com/nmap/nmap/commit/0c142333bb356b6ff15fff5c95522c4cfc410a9c.
If it is not disabled, nmap will build its own zlib version which can
result in the following build failure:

/home/giuliobenetti/autobuild/run/instance-1/output-1/host/opt/ext-toolchain/bin/../lib/gcc/i686-buildroot-linux-uclibc/9.3.0/../../../../i686-buildroot-linux-uclibc/bin/ld: attempted static link of dynamic object `libz.so.1.2.11'

Fixes:
 - http://autobuild.buildroot.org/results/da9469e24390c94fe74f133152dc320c21872159
 - http://autobuild.buildroot.org/results/53034d8dd506bc033dc92343f9a37cd4ac8b2142

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/nmap/nmap.mk | 7 +++++++
 1 file changed, 7 insertions(+)

Comments

Arnout Vandecappelle Oct. 6, 2021, 7:26 p.m. UTC | #1
On 24/09/2021 00:15, Fabrice Fontaine wrote:
> zlib is an optional dependency since bump to version 7.60 in commit
> c4faf1d4d11764da769abdd252dd3925d83378cb and
> https://github.com/nmap/nmap/commit/0c142333bb356b6ff15fff5c95522c4cfc410a9c.
> If it is not disabled, nmap will build its own zlib version which can
> result in the following build failure:
> 
> /home/giuliobenetti/autobuild/run/instance-1/output-1/host/opt/ext-toolchain/bin/../lib/gcc/i686-buildroot-linux-uclibc/9.3.0/../../../../i686-buildroot-linux-uclibc/bin/ld: attempted static link of dynamic object `libz.so.1.2.11'
> 
> Fixes:
>   - http://autobuild.buildroot.org/results/da9469e24390c94fe74f133152dc320c21872159
>   - http://autobuild.buildroot.org/results/53034d8dd506bc033dc92343f9a37cd4ac8b2142
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

  Applied to master, thanks.

  Regards,
  Arnout

> ---
>   package/nmap/nmap.mk | 7 +++++++
>   1 file changed, 7 insertions(+)
> 
> diff --git a/package/nmap/nmap.mk b/package/nmap/nmap.mk
> index 13414a56ee..34cf61ff0b 100644
> --- a/package/nmap/nmap.mk
> +++ b/package/nmap/nmap.mk
> @@ -44,6 +44,13 @@ else
>   NMAP_CONF_OPTS += --without-openssl
>   endif
>   
> +ifeq ($(BR2_PACKAGE_ZLIB),y)
> +NMAP_CONF_OPTS += --with-libz="$(STAGING_DIR)/usr"
> +NMAP_DEPENDENCIES += zlib
> +else
> +NMAP_CONF_OPTS += --without-libz
> +endif
> +
>   NMAP_INSTALL_TARGET_OPTS = DESTDIR=$(TARGET_DIR)
>   
>   ifeq ($(BR2_PACKAGE_NMAP_NCAT),y)
>
Peter Korsgaard Oct. 7, 2021, 7:46 a.m. UTC | #2
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > zlib is an optional dependency since bump to version 7.60 in commit
 > c4faf1d4d11764da769abdd252dd3925d83378cb and
 > https://github.com/nmap/nmap/commit/0c142333bb356b6ff15fff5c95522c4cfc410a9c.
 > If it is not disabled, nmap will build its own zlib version which can
 > result in the following build failure:

 > /home/giuliobenetti/autobuild/run/instance-1/output-1/host/opt/ext-toolchain/bin/../lib/gcc/i686-buildroot-linux-uclibc/9.3.0/../../../../i686-buildroot-linux-uclibc/bin/ld:
 > attempted static link of dynamic object `libz.so.1.2.11'

 > Fixes:
 >  - http://autobuild.buildroot.org/results/da9469e24390c94fe74f133152dc320c21872159
 >  - http://autobuild.buildroot.org/results/53034d8dd506bc033dc92343f9a37cd4ac8b2142

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed to 2021.02.x, 2021.05.x and 2021.08.x, thanks.
diff mbox series

Patch

diff --git a/package/nmap/nmap.mk b/package/nmap/nmap.mk
index 13414a56ee..34cf61ff0b 100644
--- a/package/nmap/nmap.mk
+++ b/package/nmap/nmap.mk
@@ -44,6 +44,13 @@  else
 NMAP_CONF_OPTS += --without-openssl
 endif
 
+ifeq ($(BR2_PACKAGE_ZLIB),y)
+NMAP_CONF_OPTS += --with-libz="$(STAGING_DIR)/usr"
+NMAP_DEPENDENCIES += zlib
+else
+NMAP_CONF_OPTS += --without-libz
+endif
+
 NMAP_INSTALL_TARGET_OPTS = DESTDIR=$(TARGET_DIR)
 
 ifeq ($(BR2_PACKAGE_NMAP_NCAT),y)