diff mbox series

fs/ext2: fix namespace for variables

Message ID 20210917201944.3760710-1-yann.morin.1998@free.fr
State Accepted
Headers show
Series fs/ext2: fix namespace for variables | expand

Commit Message

Yann E. MORIN Sept. 17, 2021, 8:19 p.m. UTC
In filesystems, variables must be prefixed with ROOTFS_, to avoid
ckashing with packages of the same name.

We do not have a package named 'ext2', so we currently have no clash,
but it is still ebtter that the variables be properly namespaced.

Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
Cc: Kory Maincent <kory.maincent@bootlin.com>
---
 fs/ext2/ext2.mk | 16 ++++++++--------
 1 file changed, 8 insertions(+), 8 deletions(-)

Comments

Peter Korsgaard Oct. 5, 2021, 1:43 p.m. UTC | #1
>>>>> "Yann" == Yann E MORIN <yann.morin.1998@free.fr> writes:

 > In filesystems, variables must be prefixed with ROOTFS_, to avoid
 > ckashing with packages of the same name.

 > We do not have a package named 'ext2', so we currently have no clash,
 > but it is still ebtter that the variables be properly namespaced.

s/ebtter/better/ ;)

 > Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
 > Cc: Kory Maincent <kory.maincent@bootlin.com>

Committed to 2021.02.x, 2021.05.x and 2021.08.x, thanks.
Yann E. MORIN Oct. 5, 2021, 3:27 p.m. UTC | #2
Peter

On 2021-10-05 15:43 +0200, Peter Korsgaard spake thusly:
> >>>>> "Yann" == Yann E MORIN <yann.morin.1998@free.fr> writes:
>  > In filesystems, variables must be prefixed with ROOTFS_, to avoid
>  > ckashing with packages of the same name.
     ^^^^^^^^
>  > We do not have a package named 'ext2', so we currently have no clash,
>  > but it is still ebtter that the variables be properly namespaced.
> s/ebtter/better/ ;)

Lol. But you missed s/ckashing/clashing/ above. ;-)

>  > Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
>  > Cc: Kory Maincent <kory.maincent@bootlin.com>
> Committed to 2021.02.x, 2021.05.x and 2021.08.x, thanks.

Thanks for the backports! :-)

Regards,
Yann E. MORIN.
Peter Korsgaard Oct. 5, 2021, 4:57 p.m. UTC | #3
>>>>> "Yann" == Yann E MORIN <yann.morin.1998@free.fr> writes:

 > Peter
 > On 2021-10-05 15:43 +0200, Peter Korsgaard spake thusly:
 >> >>>>> "Yann" == Yann E MORIN <yann.morin.1998@free.fr> writes:
 >> > In filesystems, variables must be prefixed with ROOTFS_, to avoid
 >> > ckashing with packages of the same name.
 >      ^^^^^^^^
 >> > We do not have a package named 'ext2', so we currently have no clash,
 >> > but it is still ebtter that the variables be properly namespaced.
 >> s/ebtter/better/ ;)

 > Lol. But you missed s/ckashing/clashing/ above. ;-)

Grr, indeed ;)

 >> > Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
 >> > Cc: Kory Maincent <kory.maincent@bootlin.com>
 >> Committed to 2021.02.x, 2021.05.x and 2021.08.x, thanks.

 > Thanks for the backports! :-)

You're welcome!
diff mbox series

Patch

diff --git a/fs/ext2/ext2.mk b/fs/ext2/ext2.mk
index 74c99bd7b1..0b797f315f 100644
--- a/fs/ext2/ext2.mk
+++ b/fs/ext2/ext2.mk
@@ -4,32 +4,32 @@ 
 #
 ################################################################################
 
-EXT2_SIZE = $(call qstrip,$(BR2_TARGET_ROOTFS_EXT2_SIZE))
-ifeq ($(BR2_TARGET_ROOTFS_EXT2)-$(EXT2_SIZE),y-)
+ROOTFS_EXT2_SIZE = $(call qstrip,$(BR2_TARGET_ROOTFS_EXT2_SIZE))
+ifeq ($(BR2_TARGET_ROOTFS_EXT2)-$(ROOTFS_EXT2_SIZE),y-)
 $(error BR2_TARGET_ROOTFS_EXT2_SIZE cannot be empty)
 endif
 
-EXT2_MKFS_OPTS = $(call qstrip,$(BR2_TARGET_ROOTFS_EXT2_MKFS_OPTIONS))
+ROOTFS_EXT2_MKFS_OPTS = $(call qstrip,$(BR2_TARGET_ROOTFS_EXT2_MKFS_OPTIONS))
 
 # qstrip results in stripping consecutive spaces into a single one. So the
 # variable is not qstrip-ed to preserve the integrity of the string value.
-EXT2_LABEL = $(subst ",,$(BR2_TARGET_ROOTFS_EXT2_LABEL))
+ROOTFS_EXT2_LABEL = $(subst ",,$(BR2_TARGET_ROOTFS_EXT2_LABEL))
 #" Syntax highlighting... :-/ )
 
-EXT2_OPTS = \
+ROOTFS_EXT2_OPTS = \
 	-d $(TARGET_DIR) \
 	-r $(BR2_TARGET_ROOTFS_EXT2_REV) \
 	-N $(BR2_TARGET_ROOTFS_EXT2_INODES) \
 	-m $(BR2_TARGET_ROOTFS_EXT2_RESBLKS) \
 	-L "$(EXT2_LABEL)" \
-	$(EXT2_MKFS_OPTS)
+	$(ROOTFS_EXT2_MKFS_OPTS)
 
 ROOTFS_EXT2_DEPENDENCIES = host-e2fsprogs
 
 define ROOTFS_EXT2_CMD
 	rm -f $@
-	$(HOST_DIR)/sbin/mkfs.ext$(BR2_TARGET_ROOTFS_EXT2_GEN) $(EXT2_OPTS) $@ \
-		"$(EXT2_SIZE)" \
+	$(HOST_DIR)/sbin/mkfs.ext$(BR2_TARGET_ROOTFS_EXT2_GEN) $(ROOTFS_EXT2_OPTS) $@ \
+		"$(ROOTFS_EXT2_SIZE)" \
 	|| { ret=$$?; \
 	     echo "*** Maybe you need to increase the filesystem size (BR2_TARGET_ROOTFS_EXT2_SIZE)" 1>&2; \
 	     exit $$ret; \