diff mbox series

boot/uboot: fix hook to copy imx firmware files

Message ID 20210914192741.26306-1-heiko.thiery@gmail.com
State Accepted
Headers show
Series boot/uboot: fix hook to copy imx firmware files | expand

Commit Message

Heiko Thiery Sept. 14, 2021, 7:27 p.m. UTC
Simplification has broken it. Fix it again.

Fixes: af99e7a5f3863049 ("boot/uboot: copy IMX firmware files to uboot package dir")
Cc: Yann E. MORIN <yann.morin.1998@free.fr>
Signed-off-by: Heiko Thiery <heiko.thiery@gmail.com>
---
 boot/uboot/uboot.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Yann E. MORIN Sept. 14, 2021, 7:44 p.m. UTC | #1
Heiko, All,

On 2021-09-14 21:27 +0200, Heiko Thiery spake thusly:
> Simplification has broken it. Fix it again.
> 
> Fixes: af99e7a5f3863049 ("boot/uboot: copy IMX firmware files to uboot package dir")
> Cc: Yann E. MORIN <yann.morin.1998@free.fr>
> Signed-off-by: Heiko Thiery <heiko.thiery@gmail.com>

Thanks for fixing my mess! Applied to master, thanks.

Regards,
Yann E. MORIN.

> ---
>  boot/uboot/uboot.mk | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/boot/uboot/uboot.mk b/boot/uboot/uboot.mk
> index 184f822af4..2eb1792de9 100644
> --- a/boot/uboot/uboot.mk
> +++ b/boot/uboot/uboot.mk
> @@ -194,7 +194,7 @@ define UBOOT_COPY_IMX_FW_FILES
>  		cp $(BINARIES_DIR)/$(fw) $(@D)/
>  	)
>  endef
> -UBOOT_PRE_BUILD_HOOKS += UBOOT_COPY_IMX_DDR_FIRMWARE
> +UBOOT_PRE_BUILD_HOOKS += UBOOT_COPY_IMX_FW_FILES
>  endif
>  
>  ifeq ($(BR2_TARGET_UBOOT_NEEDS_DTC),y)
> -- 
> 2.20.1
> 
> _______________________________________________
> buildroot mailing list
> buildroot@lists.buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
diff mbox series

Patch

diff --git a/boot/uboot/uboot.mk b/boot/uboot/uboot.mk
index 184f822af4..2eb1792de9 100644
--- a/boot/uboot/uboot.mk
+++ b/boot/uboot/uboot.mk
@@ -194,7 +194,7 @@  define UBOOT_COPY_IMX_FW_FILES
 		cp $(BINARIES_DIR)/$(fw) $(@D)/
 	)
 endef
-UBOOT_PRE_BUILD_HOOKS += UBOOT_COPY_IMX_DDR_FIRMWARE
+UBOOT_PRE_BUILD_HOOKS += UBOOT_COPY_IMX_FW_FILES
 endif
 
 ifeq ($(BR2_TARGET_UBOOT_NEEDS_DTC),y)