diff mbox series

[2/3] boot/uboot: copy ATF bl31 binary to uboot package dir

Message ID 20210906094214.6142-3-heiko.thiery@gmail.com
State Superseded
Headers show
Series Add support to build imx8 images using mainline uboot | expand

Commit Message

Heiko Thiery Sept. 6, 2021, 9:42 a.m. UTC
If the U-Boot image is to be built with binman and the ATF binary is
used, the file is expected in the toplevel directory.

Signed-off-by: Heiko Thiery <heiko.thiery@gmail.com>
---
 boot/uboot/uboot.mk | 8 ++++++++
 1 file changed, 8 insertions(+)

Comments

Michael Walle Sept. 6, 2021, 10:23 a.m. UTC | #1
Am 2021-09-06 11:42, schrieb Heiko Thiery:
> If the U-Boot image is to be built with binman and the ATF binary is

btw TF-A is the new name for ATF ;)

-michael
Heiko Thiery Sept. 7, 2021, 9:16 a.m. UTC | #2
Hi Michael,

Am Mo., 6. Sept. 2021 um 12:23 Uhr schrieb Michael Walle <michael@walle.cc>:
>
> Am 2021-09-06 11:42, schrieb Heiko Thiery:
> > If the U-Boot image is to be built with binman and the ATF binary is
>
> btw TF-A is the new name for ATF ;)

Good to know. But for consistency I have used the ATF naming.
diff mbox series

Patch

diff --git a/boot/uboot/uboot.mk b/boot/uboot/uboot.mk
index 4f3c9b7c3a..1a840d9cc1 100644
--- a/boot/uboot/uboot.mk
+++ b/boot/uboot/uboot.mk
@@ -162,8 +162,16 @@  ifeq ($(BR2_TARGET_UBOOT_NEEDS_ATF_BL31),y)
 UBOOT_DEPENDENCIES += arm-trusted-firmware
 ifeq ($(BR2_TARGET_UBOOT_NEEDS_ATF_BL31_ELF),y)
 UBOOT_MAKE_OPTS += BL31=$(BINARIES_DIR)/bl31.elf
+define UBOOT_COPY_ATF_FIRMWARE
+	cp $(BINARIES_DIR)/bl31.elf $(@D)/
+endef
+UBOOT_PRE_BUILD_HOOKS += UBOOT_COPY_ATF_FIRMWARE
 else
 UBOOT_MAKE_OPTS += BL31=$(BINARIES_DIR)/bl31.bin
+define UBOOT_COPY_ATF_FIRMWARE
+	cp $(BINARIES_DIR)/bl31.bin $(@D)/
+endef
+UBOOT_PRE_BUILD_HOOKS += UBOOT_COPY_ATF_FIRMWARE
 endif
 endif