diff mbox series

[v2,1/1] package/mpv: fix build of vaapi with egl-drm

Message ID 20210819221929.99687-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [v2,1/1] package/mpv: fix build of vaapi with egl-drm | expand

Commit Message

Fabrice Fontaine Aug. 19, 2021, 10:19 p.m. UTC
Build of vaapi with egl-drm is broken since commit
6ec47c4e59c7c8c57e972dab985c8a2ba0bf7174 because egl-drm is a part of gl
group which is only enabled if BR2_PACKAGE_HAS_LIBGL or
BR2_PACKAGE_HAS_LIBGLES are set:
https://github.com/mpv-player/mpv/blob/ec0006bfa1aaf608a7141929f2871c89ac7a15d6/wscript#L572

As a result, despite what is being displayed in the autobuilder log
message, the build failure is not related to X11 but to the fact that
we try to enable vaapi through egl-drm but at the same time, we disable
gl.

To fix it, enable gl if libegl is available as gl can be enabled for
example through wayland and egl (gl-wayland):

'deps': 'gl-cocoa || gl-x11 || egl-x11 || egl-drm || '
+ 'gl-win32 || gl-wayland || rpi || '
+ 'plain-gl',

Fixes:
 - http://autobuild.buildroot.org/results/e5c15228f42a73f8c34b26630b2074c30e5f5966

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
Changes v1 -> v2 (after review of Yann E. Morin):
 - Update commit message

 package/mpv/mpv.mk | 3 +++
 1 file changed, 3 insertions(+)

Comments

Yann E. MORIN Aug. 20, 2021, 8:02 a.m. UTC | #1
Fabrice, All,

On 2021-08-20 00:19 +0200, Fabrice Fontaine spake thusly:
> Build of vaapi with egl-drm is broken since commit
> 6ec47c4e59c7c8c57e972dab985c8a2ba0bf7174 because egl-drm is a part of gl
> group which is only enabled if BR2_PACKAGE_HAS_LIBGL or
> BR2_PACKAGE_HAS_LIBGLES are set:
> https://github.com/mpv-player/mpv/blob/ec0006bfa1aaf608a7141929f2871c89ac7a15d6/wscript#L572
> 
> As a result, despite what is being displayed in the autobuilder log
> message, the build failure is not related to X11 but to the fact that
> we try to enable vaapi through egl-drm but at the same time, we disable
> gl.
> 
> To fix it, enable gl if libegl is available as gl can be enabled for
> example through wayland and egl (gl-wayland):
> 
> 'deps': 'gl-cocoa || gl-x11 || egl-x11 || egl-drm || '
> + 'gl-win32 || gl-wayland || rpi || '
> + 'plain-gl',
> 
> Fixes:
>  - http://autobuild.buildroot.org/results/e5c15228f42a73f8c34b26630b2074c30e5f5966
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Applied to master, thanks.

Regards,
Yann E. MORIN.

> ---
> Changes v1 -> v2 (after review of Yann E. Morin):
>  - Update commit message
> 
>  package/mpv/mpv.mk | 3 +++
>  1 file changed, 3 insertions(+)
> 
> diff --git a/package/mpv/mpv.mk b/package/mpv/mpv.mk
> index 91e31dd150..f8ecaeb78a 100644
> --- a/package/mpv/mpv.mk
> +++ b/package/mpv/mpv.mk
> @@ -148,6 +148,9 @@ MPV_DEPENDENCIES += libgl
>  else ifeq ($(BR2_PACKAGE_HAS_LIBGLES),y)
>  MPV_CONF_OPTS += --enable-gl
>  MPV_DEPENDENCIES += libgles
> +else ifeq ($(BR2_PACKAGE_HAS_LIBEGL),y)
> +MPV_CONF_OPTS += --enable-gl
> +MPV_DEPENDENCIES += libegl
>  else
>  MPV_CONF_OPTS += --disable-gl
>  endif
> -- 
> 2.30.2
> 
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
diff mbox series

Patch

diff --git a/package/mpv/mpv.mk b/package/mpv/mpv.mk
index 91e31dd150..f8ecaeb78a 100644
--- a/package/mpv/mpv.mk
+++ b/package/mpv/mpv.mk
@@ -148,6 +148,9 @@  MPV_DEPENDENCIES += libgl
 else ifeq ($(BR2_PACKAGE_HAS_LIBGLES),y)
 MPV_CONF_OPTS += --enable-gl
 MPV_DEPENDENCIES += libgles
+else ifeq ($(BR2_PACKAGE_HAS_LIBEGL),y)
+MPV_CONF_OPTS += --enable-gl
+MPV_DEPENDENCIES += libegl
 else
 MPV_CONF_OPTS += --disable-gl
 endif