diff mbox series

[1/1] package/opencv4: do not detect ccache

Message ID 20210801215357.696067-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/opencv4: do not detect ccache | expand

Commit Message

Fabrice Fontaine Aug. 1, 2021, 9:53 p.m. UTC
OpenCV-4's buildsystem will try to detect ccache and use it if
available. This may yield a system-installed ccache.

However, in Buildroot, ccache is entirely hidden away and handled in the
toolchain wrapper.

Forcibly disable detection of ccache.

Commit 505e7f47715c77d8586444a4fefe4a190b77aaad already applied this
change to opencv3.

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/opencv4/opencv4.mk | 1 +
 1 file changed, 1 insertion(+)

Comments

Arnout Vandecappelle Aug. 3, 2021, 3:46 p.m. UTC | #1
On 01/08/2021 23:53, Fabrice Fontaine wrote:
> OpenCV-4's buildsystem will try to detect ccache and use it if
> available. This may yield a system-installed ccache.
> 
> However, in Buildroot, ccache is entirely hidden away and handled in the
> toolchain wrapper.
> 
> Forcibly disable detection of ccache.
> 
> Commit 505e7f47715c77d8586444a4fefe4a190b77aaad already applied this
> change to opencv3.
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

 Applied to master, thanks.

 Regards,
 Arnout

> ---
>  package/opencv4/opencv4.mk | 1 +
>  1 file changed, 1 insertion(+)
> 
> diff --git a/package/opencv4/opencv4.mk b/package/opencv4/opencv4.mk
> index 3cc6c05769..040fc63e4e 100644
> --- a/package/opencv4/opencv4.mk
> +++ b/package/opencv4/opencv4.mk
> @@ -49,6 +49,7 @@ endif
>  # OpenCV build options
>  OPENCV4_CONF_OPTS += \
>  	-DBUILD_WITH_STATIC_CRT=OFF \
> +	-DENABLE_CCACHE=OFF \
>  	-DENABLE_COVERAGE=OFF \
>  	-DENABLE_FAST_MATH=ON \
>  	-DENABLE_IMPL_COLLECTION=OFF \
>
diff mbox series

Patch

diff --git a/package/opencv4/opencv4.mk b/package/opencv4/opencv4.mk
index 3cc6c05769..040fc63e4e 100644
--- a/package/opencv4/opencv4.mk
+++ b/package/opencv4/opencv4.mk
@@ -49,6 +49,7 @@  endif
 # OpenCV build options
 OPENCV4_CONF_OPTS += \
 	-DBUILD_WITH_STATIC_CRT=OFF \
+	-DENABLE_CCACHE=OFF \
 	-DENABLE_COVERAGE=OFF \
 	-DENABLE_FAST_MATH=ON \
 	-DENABLE_IMPL_COLLECTION=OFF \