diff mbox series

[1/1] package/openzwave: fix build with gcc 11

Message ID 20210801122909.3074515-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/openzwave: fix build with gcc 11 | expand

Commit Message

Fabrice Fontaine Aug. 1, 2021, 12:29 p.m. UTC
Set DEBUG_FLAGS and RELEASE_FLAGS to an empty value to remove -Werror
and fix the following build failure with gcc 11:

/tmp/instance-5/output-1/build/openzwave-62444b0f979c337d2091d77d89cf63c2ae9775cf/cpp/src/command_classes/AssociationCommandConfiguration.cpp: In member function 'virtual bool OpenZWave::Internal::CC::AssociationCommandConfiguration::HandleMsg(const uint8*, uint32, uint32)':
/tmp/instance-5/output-1/build/openzwave-62444b0f979c337d2091d77d89cf63c2ae9775cf/cpp/src/command_classes/AssociationCommandConfiguration.cpp:191:85: error: 'this' pointer is null [-Werror=nonnull]
  191 |                                                                 group->ClearCommands(nodeIdx);
      |                                                                 ~~~~~~~~~~~~~~~~~~~~^~~~~~~~~

Fixes:
 - http://autobuild.buildroot.org/results/05ad5cc1f593704ef032f3c5278695247450b94b

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/openzwave/openzwave.mk | 3 +++
 1 file changed, 3 insertions(+)

Comments

Yann E. MORIN Aug. 1, 2021, 6:48 p.m. UTC | #1
Fabrice, All,

On 2021-08-01 14:29 +0200, Fabrice Fontaine spake thusly:
> Set DEBUG_FLAGS and RELEASE_FLAGS to an empty value to remove -Werror
> and fix the following build failure with gcc 11:
> 
> /tmp/instance-5/output-1/build/openzwave-62444b0f979c337d2091d77d89cf63c2ae9775cf/cpp/src/command_classes/AssociationCommandConfiguration.cpp: In member function 'virtual bool OpenZWave::Internal::CC::AssociationCommandConfiguration::HandleMsg(const uint8*, uint32, uint32)':
> /tmp/instance-5/output-1/build/openzwave-62444b0f979c337d2091d77d89cf63c2ae9775cf/cpp/src/command_classes/AssociationCommandConfiguration.cpp:191:85: error: 'this' pointer is null [-Werror=nonnull]
>   191 |                                                                 group->ClearCommands(nodeIdx);
>       |                                                                 ~~~~~~~~~~~~~~~~~~~~^~~~~~~~~
> 
> Fixes:
>  - http://autobuild.buildroot.org/results/05ad5cc1f593704ef032f3c5278695247450b94b
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Applied to master, thanks.

Regards,
Yann E. MORIN.

> ---
>  package/openzwave/openzwave.mk | 3 +++
>  1 file changed, 3 insertions(+)
> 
> diff --git a/package/openzwave/openzwave.mk b/package/openzwave/openzwave.mk
> index 357d19f32e..9c28c0a13b 100644
> --- a/package/openzwave/openzwave.mk
> +++ b/package/openzwave/openzwave.mk
> @@ -23,6 +23,7 @@ OPENZWAVE_INSTALL_STAGING = YES
>  # the correct directory otherwise openzwave will install configuration files in
>  # $(PREFIX)/etc/openzwave.
>  # Disable doxygen documentation.
> +# Set {DEBUG,RELEASE}_CFLAGS to an empty value to remove -Werror.
>  OPENZWAVE_MAKE_OPTS = \
>  	CROSS_COMPILE="$(TARGET_CROSS)" \
>  	PREFIX=/usr \
> @@ -30,6 +31,8 @@ OPENZWAVE_MAKE_OPTS = \
>  	pkgconfigdir=/usr/lib/pkgconfig \
>  	sysconfdir=/etc/openzwave \
>  	DOXYGEN= \
> +	DEBUG_CFLAGS= \
> +	RELEASE_CFLAGS= \
>  	USE_BI_TXML=0
>  
>  ifeq ($(BR2_PACKAGE_HAS_UDEV),y)
> -- 
> 2.30.2
> 
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
diff mbox series

Patch

diff --git a/package/openzwave/openzwave.mk b/package/openzwave/openzwave.mk
index 357d19f32e..9c28c0a13b 100644
--- a/package/openzwave/openzwave.mk
+++ b/package/openzwave/openzwave.mk
@@ -23,6 +23,7 @@  OPENZWAVE_INSTALL_STAGING = YES
 # the correct directory otherwise openzwave will install configuration files in
 # $(PREFIX)/etc/openzwave.
 # Disable doxygen documentation.
+# Set {DEBUG,RELEASE}_CFLAGS to an empty value to remove -Werror.
 OPENZWAVE_MAKE_OPTS = \
 	CROSS_COMPILE="$(TARGET_CROSS)" \
 	PREFIX=/usr \
@@ -30,6 +31,8 @@  OPENZWAVE_MAKE_OPTS = \
 	pkgconfigdir=/usr/lib/pkgconfig \
 	sysconfdir=/etc/openzwave \
 	DOXYGEN= \
+	DEBUG_CFLAGS= \
+	RELEASE_CFLAGS= \
 	USE_BI_TXML=0
 
 ifeq ($(BR2_PACKAGE_HAS_UDEV),y)