diff mbox series

[1/1] package/ibrcommon: fix build with gcc 11

Message ID 20210731160701.1234967-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/ibrcommon: fix build with gcc 11 | expand

Commit Message

Fabrice Fontaine July 31, 2021, 4:07 p.m. UTC
Fix the following build failure with gcc 11:

In file included from ../../ibrcommon/data/BLOB.h:25,
                 from BLOB.cpp:22:
../../ibrcommon/thread/Mutex.h:43:40: error: ISO C++17 does not allow dynamic exception specifications
   43 |                 virtual void trylock() throw (MutexException) = 0;
      |                                        ^~~~~

Fixes:
 - http://autobuild.buildroot.org/results/7a9a4319916efe8cd7e04b8686a9ae0b233b017a

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/ibrcommon/ibrcommon.mk | 1 +
 1 file changed, 1 insertion(+)

Comments

Thomas Petazzoni July 31, 2021, 10:07 p.m. UTC | #1
On Sat, 31 Jul 2021 18:07:01 +0200
Fabrice Fontaine <fontaine.fabrice@gmail.com> wrote:

> Fix the following build failure with gcc 11:
> 
> In file included from ../../ibrcommon/data/BLOB.h:25,
>                  from BLOB.cpp:22:
> ../../ibrcommon/thread/Mutex.h:43:40: error: ISO C++17 does not allow dynamic exception specifications
>    43 |                 virtual void trylock() throw (MutexException) = 0;
>       |                                        ^~~~~
> 
> Fixes:
>  - http://autobuild.buildroot.org/results/7a9a4319916efe8cd7e04b8686a9ae0b233b017a
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
>  package/ibrcommon/ibrcommon.mk | 1 +
>  1 file changed, 1 insertion(+)

Applied to master, thanks.

Thomas
Peter Korsgaard Aug. 7, 2021, 5:08 p.m. UTC | #2
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > Fix the following build failure with gcc 11:
 > In file included from ../../ibrcommon/data/BLOB.h:25,
 >                  from BLOB.cpp:22:
 > ../../ibrcommon/thread/Mutex.h:43:40: error: ISO C++17 does not allow dynamic exception specifications
 >    43 |                 virtual void trylock() throw (MutexException) = 0;
 >       |                                        ^~~~~

 > Fixes:
 >  - http://autobuild.buildroot.org/results/7a9a4319916efe8cd7e04b8686a9ae0b233b017a

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed to 2021.02.x and 2021.05.x, thanks.
diff mbox series

Patch

diff --git a/package/ibrcommon/ibrcommon.mk b/package/ibrcommon/ibrcommon.mk
index 4d2d351c88..d9e843ebc2 100644
--- a/package/ibrcommon/ibrcommon.mk
+++ b/package/ibrcommon/ibrcommon.mk
@@ -10,6 +10,7 @@  IBRCOMMON_INSTALL_STAGING = YES
 IBRCOMMON_LICENSE = Apache-2.0
 IBRCOMMON_LICENSE_FILES = COPYING README
 IBRCOMMON_DEPENDENCIES = host-pkgconf
+IBRCOMMON_CONF_ENV = CXXFLAGS="$(TARGET_CXXFLAGS) -std=c++11"
 
 ifeq ($(BR2_PACKAGE_OPENSSL),y)
 IBRCOMMON_DEPENDENCIES += openssl