diff mbox series

[v2,2/4] package/polkit/S50polkit: new file

Message ID 20210721214518.227254-2-aduskett@gmail.com
State Accepted
Headers show
Series [v2,1/4] package/polkit: bump version to 0.119 and use duktape | expand

Commit Message

Adam Duskett July 21, 2021, 9:45 p.m. UTC
The Polkit source does not come with non-systemd init script. Add one that is
modeled after package/busybox/S01syslogd.

Signed-off-by: Adam Duskett <aduskett@gmail.com>
---
 package/polkit/S50polkit | 51 ++++++++++++++++++++++++++++++++++++++++
 package/polkit/polkit.mk |  5 ++++
 2 files changed, 56 insertions(+)
 create mode 100755 package/polkit/S50polkit

Comments

Peter Korsgaard Aug. 5, 2021, 9:46 a.m. UTC | #1
>>>>> "Adam" == Adam Duskett <aduskett@gmail.com> writes:

 > The Polkit source does not come with non-systemd init script. Add one that is
 > modeled after package/busybox/S01syslogd.

 > Signed-off-by: Adam Duskett <aduskett@gmail.com>

Committed to 2021.02.x and 2021.05.x, thanks.
diff mbox series

Patch

diff --git a/package/polkit/S50polkit b/package/polkit/S50polkit
new file mode 100755
index 0000000000..38cb463b8a
--- /dev/null
+++ b/package/polkit/S50polkit
@@ -0,0 +1,51 @@ 
+#!/bin/sh
+
+DAEMON="polkitd"
+DAEMON_PATH="/usr/lib/polkit-1/${DAEMON}"
+PIDFILE="/var/run/${DAEMON}.pid"
+POLKITD_ARGS="--no-debug"
+
+# polkitd does not create a pidfile, so pass "-n" in the command line
+# and use "-m" to instruct start-stop-daemon to create one.
+start() {
+  printf 'Starting %s: ' "${DAEMON}"
+  # shellcheck disable=SC2086 # we need the word splitting
+  start-stop-daemon -bmSqp "$PIDFILE" -x ${DAEMON_PATH} -- ${POLKITD_ARGS}
+  status=$?
+  if [ "$status" -eq 0 ]; then
+    echo "OK"
+  else
+    echo "FAIL"
+  fi
+  return "$status"
+}
+
+stop() {
+  printf 'Stopping %s: ' "${DAEMON}"
+  start-stop-daemon -Kqp "$PIDFILE"
+  status=$?
+  if [ "$status" -eq 0 ]; then
+    rm -f "$PIDFILE"
+    echo "OK"
+  else
+    echo "FAIL"
+  fi
+  return "$status"
+}
+
+restart() {
+  stop
+  sleep 1
+  start
+}
+
+case "$1" in
+  start|stop|restart|reload)
+    "$1";;
+  reload)
+    # Restart, since there is no true "reload" feature.
+    restart;;
+  *)
+    echo "Usage: $0 {start|stop|restart|reload}"
+    exit 1
+esac
diff --git a/package/polkit/polkit.mk b/package/polkit/polkit.mk
index f48c103a52..d5b3955ddb 100644
--- a/package/polkit/polkit.mk
+++ b/package/polkit/polkit.mk
@@ -57,4 +57,9 @@  define POLKIT_INSTALL_INIT_SYSTEMD
 
 endef
 
+define POLKIT_INSTALL_INIT_SYSV
+	$(INSTALL) -D -m 0755 package/polkit/S50polkit \
+		$(TARGET_DIR)/etc/init.d/S50polkit
+endef
+
 $(eval $(autotools-package))