diff mbox series

package/log4qt: add telnet optional logging

Message ID 20210505192210.1354164-1-b.bilas@grinn-global.com
State Accepted
Headers show
Series package/log4qt: add telnet optional logging | expand

Commit Message

Bartosz Bilas May 5, 2021, 7:22 p.m. UTC
Telnet logging is an optional feature that's disabled by default.

Signed-off-by: Bartosz Bilas <b.bilas@grinn-global.com>
---
 package/log4qt/log4qt.mk | 6 ++++++
 1 file changed, 6 insertions(+)

Comments

Peter Korsgaard May 11, 2021, 11:23 a.m. UTC | #1
>>>>> "Bartosz" == Bartosz Bilas <b.bilas@grinn-global.com> writes:

 > Telnet logging is an optional feature that's disabled by default.
 > Signed-off-by: Bartosz Bilas <b.bilas@grinn-global.com>

Committed, thanks.
diff mbox series

Patch

diff --git a/package/log4qt/log4qt.mk b/package/log4qt/log4qt.mk
index b01d9c6611..29b533503b 100644
--- a/package/log4qt/log4qt.mk
+++ b/package/log4qt/log4qt.mk
@@ -17,4 +17,10 @@  else
 LOG4QT_CONF_OPTS += -DBUILD_WITH_DB_LOGGING=OFF
 endif
 
+ifeq ($(BR2_PACKAGE_QT5BASE_NETWORK),y)
+LOG4QT_CONF_OPTS += -DBUILD_WITH_TELNET_LOGGING=ON
+else
+LOG4QT_CONF_OPTS += -DBUILD_WITH_TELNET_LOGGING=OFF
+endif
+
 $(eval $(cmake-package))