diff mbox series

[2/2] package/domoticz: drop boost date-time dependency

Message ID 20210418200730.3474374-2-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/2] package/domoticz: drop first patch | expand

Commit Message

Fabrice Fontaine April 18, 2021, 8:07 p.m. UTC
boost date-time is not a dependency since version 4.9700 and
https://github.com/domoticz/domoticz/commit/a3eacbc987b59dd4aa73ada24a0a6e9a0d27b740

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/domoticz/Config.in | 1 -
 1 file changed, 1 deletion(-)

Comments

Thomas Petazzoni April 19, 2021, 8:34 p.m. UTC | #1
On Sun, 18 Apr 2021 22:07:30 +0200
Fabrice Fontaine <fontaine.fabrice@gmail.com> wrote:

> boost date-time is not a dependency since version 4.9700 and
> https://github.com/domoticz/domoticz/commit/a3eacbc987b59dd4aa73ada24a0a6e9a0d27b740
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
>  package/domoticz/Config.in | 1 -
>  1 file changed, 1 deletion(-)

Applied to master, thanks. I'm curious: how do you notice this kind of
change?

Thomas
Fabrice Fontaine April 19, 2021, 8:44 p.m. UTC | #2
Hi Thomas,

Le lun. 19 avr. 2021 à 22:34, Thomas Petazzoni
<thomas.petazzoni@bootlin.com> a écrit :
>
> On Sun, 18 Apr 2021 22:07:30 +0200
> Fabrice Fontaine <fontaine.fabrice@gmail.com> wrote:
>
> > boost date-time is not a dependency since version 4.9700 and
> > https://github.com/domoticz/domoticz/commit/a3eacbc987b59dd4aa73ada24a0a6e9a0d27b740
> >
> > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> > ---
> >  package/domoticz/Config.in | 1 -
> >  1 file changed, 1 deletion(-)
>
> Applied to master, thanks. I'm curious: how do you notice this kind of
> change?
I was working on bumping domoticz to latest version and I noticed this
change when going through CMakeLists.txt.
Unfortunately, I should have noticed it sooner (back in 2018) but this
kind of changes can easily be missed.
>
> Thomas
> --
> Thomas Petazzoni, CTO, Bootlin
> Embedded Linux and Kernel engineering
> https://bootlin.com
Best Regards,

Fabrice
Thomas Petazzoni April 19, 2021, 9:42 p.m. UTC | #3
On Mon, 19 Apr 2021 22:44:39 +0200
Fabrice Fontaine <fontaine.fabrice@gmail.com> wrote:

> I was working on bumping domoticz to latest version and I noticed this
> change when going through CMakeLists.txt.
> Unfortunately, I should have noticed it sooner (back in 2018) but this
> kind of changes can easily be missed.

Absolutely: it's very easy to spot a missing dependency, as it
typically causes a build failure. But spotting dependencies that are no
longer necessary is much, much trickier, which is why I asked how you
found out this one.

Thomas
Peter Korsgaard April 26, 2021, 9:51 a.m. UTC | #4
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > boost date-time is not a dependency since version 4.9700 and
 > https://github.com/domoticz/domoticz/commit/a3eacbc987b59dd4aa73ada24a0a6e9a0d27b740

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed to 2021.02.x, thanks.
diff mbox series

Patch

diff --git a/package/domoticz/Config.in b/package/domoticz/Config.in
index 88de232642..4d1a7f9289 100644
--- a/package/domoticz/Config.in
+++ b/package/domoticz/Config.in
@@ -11,7 +11,6 @@  config BR2_PACKAGE_DOMOTICZ
 	depends on BR2_TOOLCHAIN_SUPPORTS_ALWAYS_LOCKFREE_ATOMIC_INTS # boost-thread
 	depends on !BR2_TOOLCHAIN_HAS_GCC_BUG_64735 # exception_ptr
 	select BR2_PACKAGE_BOOST
-	select BR2_PACKAGE_BOOST_DATE_TIME
 	select BR2_PACKAGE_BOOST_SYSTEM
 	select BR2_PACKAGE_BOOST_THREAD
 	select BR2_PACKAGE_JSONCPP