diff mbox series

[v1] package/util-linux: disable runuser for the host build

Message ID 20210227155413.15809-1-ps.report@gmx.net
State Accepted
Headers show
Series [v1] package/util-linux: disable runuser for the host build | expand

Commit Message

Peter Seiderer Feb. 27, 2021, 3:54 p.m. UTC
Fixes host build in case unsuitable libs are found on the system
(see [1]).

[1] http://lists.busybox.net/pipermail/buildroot/2021-February/304261.html

Reported-by: GA K <guyarkam@gmail.com>
Signed-off-by: Peter Seiderer <ps.report@gmx.net>
---
 package/util-linux/util-linux.mk | 1 +
 1 file changed, 1 insertion(+)

Comments

Yann E. MORIN March 1, 2021, 9:40 p.m. UTC | #1
Peter, All,

On 2021-02-27 16:54 +0100, Peter Seiderer spake thusly:
> Fixes host build in case unsuitable libs are found on the system
> (see [1]).
> 
> [1] http://lists.busybox.net/pipermail/buildroot/2021-February/304261.html

I would contend that this problem is a badly configured host, and if
such hosts have libraries installed that incompatible with their native
compiler, then those host should be fixed.

However, runuser really is a non-necessary tool for the Buildroot case,
so disabling it is still a good idea.

> Reported-by: GA K <guyarkam@gmail.com>
> Signed-off-by: Peter Seiderer <ps.report@gmx.net>

Applied to master, with a commit log expanded to provide a more
fundamental reason why we disable runuser. Thanks!

Regards,
Yann E. MORIN.

> ---
>  package/util-linux/util-linux.mk | 1 +
>  1 file changed, 1 insertion(+)
> 
> diff --git a/package/util-linux/util-linux.mk b/package/util-linux/util-linux.mk
> index 0178c52bac..09acaca1a7 100644
> --- a/package/util-linux/util-linux.mk
> +++ b/package/util-linux/util-linux.mk
> @@ -211,6 +211,7 @@ HOST_UTIL_LINUX_CONF_OPTS += \
>  	--disable-nsenter \
>  	--disable-pg \
>  	--disable-rfkill \
> +	--disable-runuser \
>  	--disable-schedutils \
>  	--disable-setpriv \
>  	--disable-setterm \
> -- 
> 2.30.1
> 
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
Peter Korsgaard March 13, 2021, 3:05 p.m. UTC | #2
>>>>> "Peter" == Peter Seiderer <ps.report@gmx.net> writes:

 > Fixes host build in case unsuitable libs are found on the system
 > (see [1]).

 > [1] http://lists.busybox.net/pipermail/buildroot/2021-February/304261.html

 > Reported-by: GA K <guyarkam@gmail.com>
 > Signed-off-by: Peter Seiderer <ps.report@gmx.net>

Committed to 2020.02.x and 2020.11.x, thanks.
diff mbox series

Patch

diff --git a/package/util-linux/util-linux.mk b/package/util-linux/util-linux.mk
index 0178c52bac..09acaca1a7 100644
--- a/package/util-linux/util-linux.mk
+++ b/package/util-linux/util-linux.mk
@@ -211,6 +211,7 @@  HOST_UTIL_LINUX_CONF_OPTS += \
 	--disable-nsenter \
 	--disable-pg \
 	--disable-rfkill \
+	--disable-runuser \
 	--disable-schedutils \
 	--disable-setpriv \
 	--disable-setterm \