diff mbox series

[1/2] package/gerbera: fix linking with std::filesystem

Message ID 20210126172526.2133034-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/2] package/gerbera: fix linking with std::filesystem | expand

Commit Message

Fabrice Fontaine Jan. 26, 2021, 5:25 p.m. UTC
Do not force to CXX_FILESYSTEM_NO_LINK_NEEDED to ON to allow gerbera to
link with the approriate library for std::filesystem

It should be noted that check_cxx_source_runs has been dropped since
version 1.6.0 and
https://github.com/gerbera/gerbera/commit/a3a64bed1d78fc51c7ab298db019c89852acb80c

Fixes:
 - http://autobuild.buildroot.org/results/0fcd0ce167c04f788bf1b9414ae5e7677691c7cf

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/gerbera/gerbera.mk | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)

Comments

Yann E. MORIN Jan. 26, 2021, 6:30 p.m. UTC | #1
Fabrice, All,

On 2021-01-26 18:25 +0100, Fabrice Fontaine spake thusly:
> Do not force to CXX_FILESYSTEM_NO_LINK_NEEDED to ON to allow gerbera to
> link with the approriate library for std::filesystem
> 
> It should be noted that check_cxx_source_runs has been dropped since
> version 1.6.0 and
> https://github.com/gerbera/gerbera/commit/a3a64bed1d78fc51c7ab298db019c89852acb80c
> 
> Fixes:
>  - http://autobuild.buildroot.org/results/0fcd0ce167c04f788bf1b9414ae5e7677691c7cf
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Series of 2 applied to master, thanks.

Regards,
Yann E. MORIN.

> ---
>  package/gerbera/gerbera.mk | 3 +--
>  1 file changed, 1 insertion(+), 2 deletions(-)
> 
> diff --git a/package/gerbera/gerbera.mk b/package/gerbera/gerbera.mk
> index 9468def041..6e36377798 100644
> --- a/package/gerbera/gerbera.mk
> +++ b/package/gerbera/gerbera.mk
> @@ -18,8 +18,7 @@ GERBERA_DEPENDENCIES = \
>  	zlib
>  GERBERA_CONF_OPTS = \
>  	-DWITH_DEBUG=OFF \
> -	-DWITH_JS=OFF \
> -	-DCXX_FILESYSTEM_NO_LINK_NEEDED=ON
> +	-DWITH_JS=OFF
>  
>  # Uses __atomic_fetch_add_4
>  ifeq ($(BR2_TOOLCHAIN_HAS_LIBATOMIC),y)
> -- 
> 2.29.2
> 
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
Peter Korsgaard Jan. 28, 2021, 8:02 p.m. UTC | #2
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > Do not force to CXX_FILESYSTEM_NO_LINK_NEEDED to ON to allow gerbera to
 > link with the approriate library for std::filesystem

 > It should be noted that check_cxx_source_runs has been dropped since
 > version 1.6.0 and
 > https://github.com/gerbera/gerbera/commit/a3a64bed1d78fc51c7ab298db019c89852acb80c

 > Fixes:
 >  - http://autobuild.buildroot.org/results/0fcd0ce167c04f788bf1b9414ae5e7677691c7cf

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed to 2020.02.x and 2020.11.x, thanks.
diff mbox series

Patch

diff --git a/package/gerbera/gerbera.mk b/package/gerbera/gerbera.mk
index 9468def041..6e36377798 100644
--- a/package/gerbera/gerbera.mk
+++ b/package/gerbera/gerbera.mk
@@ -18,8 +18,7 @@  GERBERA_DEPENDENCIES = \
 	zlib
 GERBERA_CONF_OPTS = \
 	-DWITH_DEBUG=OFF \
-	-DWITH_JS=OFF \
-	-DCXX_FILESYSTEM_NO_LINK_NEEDED=ON
+	-DWITH_JS=OFF
 
 # Uses __atomic_fetch_add_4
 ifeq ($(BR2_TOOLCHAIN_HAS_LIBATOMIC),y)