diff mbox series

[1/1] package/sslh: systemd needs libconfig

Message ID 20210125223420.1357779-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/sslh: systemd needs libconfig | expand

Commit Message

Fabrice Fontaine Jan. 25, 2021, 10:34 p.m. UTC
systemd-sslh-generator unconditionally uses libconfig

Fixes:
 - http://autobuild.buildroot.org/results/d46581842906f7780f4a3a1ae21963e78e7f5276

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/sslh/sslh.mk | 18 ++++++++++--------
 1 file changed, 10 insertions(+), 8 deletions(-)

Comments

Yann E. MORIN Jan. 26, 2021, 5:25 p.m. UTC | #1
Fabrice, All,

On 2021-01-25 23:34 +0100, Fabrice Fontaine spake thusly:
> systemd-sslh-generator unconditionally uses libconfig
> 
> Fixes:
>  - http://autobuild.buildroot.org/results/d46581842906f7780f4a3a1ae21963e78e7f5276
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
>  package/sslh/sslh.mk | 18 ++++++++++--------
>  1 file changed, 10 insertions(+), 8 deletions(-)
> 
> diff --git a/package/sslh/sslh.mk b/package/sslh/sslh.mk
> index 4bde143cd8..c98f1a6675 100644
> --- a/package/sslh/sslh.mk
> +++ b/package/sslh/sslh.mk
> @@ -29,8 +29,17 @@ endif
>  ifeq ($(BR2_PACKAGE_LIBCONFIG),y)
>  SSLH_DEPENDENCIES += libconfig
>  SSLH_MAKE_OPTS += USELIBCONFIG=1
> +
> +ifeq ($(BR2_PACKAGE_SYSTEMD),y)
> +SSLH_DEPENDENCIES += systemd
> +SSLH_MAKE_OPTS += USESYSTEMD=1
> +else
> +SSLH_MAKE_OPTS += USESYSTEMD=
> +endif
>  else
> -SSLH_MAKE_OPTS += USELIBCONFIG=
> +SSLH_MAKE_OPTS += \
> +	USELIBCONFIG= \
> +	USESYSTEMD=
>  endif
>  
>  ifeq ($(BR2_PACKAGE_PCRE),y)
> @@ -40,13 +49,6 @@ else
>  SSLH_MAKE_OPTS += USELIBPCRE=
>  endif
>  
> -ifeq ($(BR2_PACKAGE_SYSTEMD),y)
> -SSLH_DEPENDENCIES += systemd
> -SSLH_MAKE_OPTS += USESYSTEMD=1
> -else
> -SSLH_MAKE_OPTS += USESYSTEMD=
> -endif

I found it much simpler to select libconfig from Config.in, so I changed
the patch to do just that, and pushed to master.

At the risk of lying slightly: applied to master, thanks.

Regards,
Yann E. MORIN.

>  define SSLH_BUILD_CMDS
>  	$(TARGET_MAKE_ENV) $(MAKE) $(SSLH_MAKE_OPTS) -C $(@D)
>  endef
> -- 
> 2.29.2
> 
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
Peter Korsgaard Jan. 28, 2021, 8:01 p.m. UTC | #2
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > systemd-sslh-generator unconditionally uses libconfig
 > Fixes:
 >  - http://autobuild.buildroot.org/results/d46581842906f7780f4a3a1ae21963e78e7f5276

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed to 2020.11.x, thanks.
diff mbox series

Patch

diff --git a/package/sslh/sslh.mk b/package/sslh/sslh.mk
index 4bde143cd8..c98f1a6675 100644
--- a/package/sslh/sslh.mk
+++ b/package/sslh/sslh.mk
@@ -29,8 +29,17 @@  endif
 ifeq ($(BR2_PACKAGE_LIBCONFIG),y)
 SSLH_DEPENDENCIES += libconfig
 SSLH_MAKE_OPTS += USELIBCONFIG=1
+
+ifeq ($(BR2_PACKAGE_SYSTEMD),y)
+SSLH_DEPENDENCIES += systemd
+SSLH_MAKE_OPTS += USESYSTEMD=1
+else
+SSLH_MAKE_OPTS += USESYSTEMD=
+endif
 else
-SSLH_MAKE_OPTS += USELIBCONFIG=
+SSLH_MAKE_OPTS += \
+	USELIBCONFIG= \
+	USESYSTEMD=
 endif
 
 ifeq ($(BR2_PACKAGE_PCRE),y)
@@ -40,13 +49,6 @@  else
 SSLH_MAKE_OPTS += USELIBPCRE=
 endif
 
-ifeq ($(BR2_PACKAGE_SYSTEMD),y)
-SSLH_DEPENDENCIES += systemd
-SSLH_MAKE_OPTS += USESYSTEMD=1
-else
-SSLH_MAKE_OPTS += USESYSTEMD=
-endif
-
 define SSLH_BUILD_CMDS
 	$(TARGET_MAKE_ENV) $(MAKE) $(SSLH_MAKE_OPTS) -C $(@D)
 endef