diff mbox series

[v1,3/3] docs: add cmake-package _INSTALL_OPTS description

Message ID 20210118212700.2316-3-ps.report@gmx.net
State Accepted
Headers show
Series [v1,1/3] package/pkg-cmake.mk: fix indent | expand

Commit Message

Peter Seiderer Jan. 18, 2021, 9:27 p.m. UTC
Signed-off-by: Peter Seiderer <ps.report@gmx.net>
---
Notes:
  - why _INSTALL_OPTS and not _INSTALL_HOST_OPTS (besides historically
    reasons)?
  - mabe the cmake _INSTALL_OPTS is so seldom used, so not worth
    an extra doc entry?
---
 docs/manual/adding-packages-cmake.txt | 5 +++++
 1 file changed, 5 insertions(+)

Comments

Thomas Petazzoni Jan. 18, 2021, 9:36 p.m. UTC | #1
On Mon, 18 Jan 2021 22:27:00 +0100
Peter Seiderer <ps.report@gmx.net> wrote:

> Signed-off-by: Peter Seiderer <ps.report@gmx.net>
> ---
> Notes:
>   - why _INSTALL_OPTS and not _INSTALL_HOST_OPTS (besides historically
>     reasons)?

Note that we have the same naming in the autotools-package
infrastructure.

>   - mabe the cmake _INSTALL_OPTS is so seldom used, so not worth
>     an extra doc entry?

I've applied anyway, it's meant to be overridden if needed.

However, why are we using install/fast for the target installation, but
not for the host installation ?

Thomas
Peter Korsgaard Jan. 19, 2021, 2:56 p.m. UTC | #2
>>>>> "Peter" == Peter Seiderer <ps.report@gmx.net> writes:

 > Signed-off-by: Peter Seiderer <ps.report@gmx.net>
 > ---
 > Notes:
 >   - why _INSTALL_OPTS and not _INSTALL_HOST_OPTS (besides historically
 >     reasons)?
 >   - mabe the cmake _INSTALL_OPTS is so seldom used, so not worth
 >     an extra doc entry?

Committed to 2020.02.x and 2020.11.x, thanks.
diff mbox series

Patch

diff --git a/docs/manual/adding-packages-cmake.txt b/docs/manual/adding-packages-cmake.txt
index 00974d30d8..73f0943024 100644
--- a/docs/manual/adding-packages-cmake.txt
+++ b/docs/manual/adding-packages-cmake.txt
@@ -126,6 +126,11 @@  typical packages will therefore only use a few of them.
   in the build step. These are passed after the +make+ command. By
   default, empty.
 
+* +LIBFOO_INSTALL_OPTS+ contains the make options used to
+  install the package to the host directory. By default, the value
+  is +install+, which is correct for most CMake packages. It is still
+  possible to override it.
+
 * +LIBFOO_INSTALL_STAGING_OPTS+ contains the make options used to
   install the package to the staging directory. By default, the value
   is +DESTDIR=$(STAGING_DIR) install/fast+, which is correct for most