diff mbox series

uboot: fix binman with a new dependency

Message ID 20210112091806.906954-1-francois.perrad@gadz.org
State Superseded
Headers show
Series uboot: fix binman with a new dependency | expand

Commit Message

Francois Perrad Jan. 12, 2021, 9:18 a.m. UTC
since 2021.01, tools/binman is broken.
tools/binman/control.py imports pkg_resources
the module pkg_resources is supplied by setuptools,
so this new dependency is required.

binman is used only for building SPL

Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
---
 boot/uboot/uboot.mk | 6 ++++++
 1 file changed, 6 insertions(+)

Comments

Yann E. MORIN Jan. 14, 2021, 9:49 p.m. UTC | #1
François, All,

On 2021-01-12 10:18 +0100, Francois Perrad spake thusly:
> since 2021.01, tools/binman is broken.
> tools/binman/control.py imports pkg_resources
> the module pkg_resources is supplied by setuptools,
> so this new dependency is required.
> 
> binman is used only for building SPL
> 
> Signed-off-by: Francois Perrad <francois.perrad@gadz.org>

Cross-referencing the actual bump-patch:

    boot/uboot: bump to version 2021.01
    https://patchwork.ozlabs.org/project/buildroot/patch/20210111213312.6375-1-michael@walle.cc/

Could you guys work on a single patch doing the bump with associated
fixes if need be, please?

Regards,
Yann E. MORIN.

> ---
>  boot/uboot/uboot.mk | 6 ++++++
>  1 file changed, 6 insertions(+)
> 
> diff --git a/boot/uboot/uboot.mk b/boot/uboot/uboot.mk
> index d2b4e8dc6..a3d949a55 100644
> --- a/boot/uboot/uboot.mk
> +++ b/boot/uboot/uboot.mk
> @@ -167,8 +167,14 @@ endif
>  
>  ifeq ($(BR2_TARGET_UBOOT_NEEDS_PYTHON2),y)
>  UBOOT_DEPENDENCIES += host-python
> +ifeq ($(BR2_TARGET_UBOOT_SPL),y)
> +UBOOT_DEPENDENCIES += host-python-setuptools
> +endif
>  else ifeq ($(BR2_TARGET_UBOOT_NEEDS_PYTHON3),y)
>  UBOOT_DEPENDENCIES += host-python3
> +ifeq ($(BR2_TARGET_UBOOT_SPL),y)
> +UBOOT_DEPENDENCIES += host-python3-setuptools
> +endif
>  endif
>  
>  ifeq ($(BR2_TARGET_UBOOT_NEEDS_PYLIBFDT),y)
> -- 
> 2.27.0
> 
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
Michael Walle Jan. 14, 2021, 10:11 p.m. UTC | #2
Hi Francois,

Am 2021-01-12 10:18, schrieb Francois Perrad:
> since 2021.01, tools/binman is broken.
> tools/binman/control.py imports pkg_resources
> the module pkg_resources is supplied by setuptools,
> so this new dependency is required.
> 
> binman is used only for building SPL

is it? AFAIK binman is just for generating images and can as
well be used without SPL. There is also a CONFIG_BINMAN.
I don't know if we could check the u-boot config for that.
Otherwise, I guess we'd need yet another "u-boot uses binman"
config option. I don't think checking of SPL is enough.

-michael

> 
> Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
> ---
>  boot/uboot/uboot.mk | 6 ++++++
>  1 file changed, 6 insertions(+)
> 
> diff --git a/boot/uboot/uboot.mk b/boot/uboot/uboot.mk
> index d2b4e8dc6..a3d949a55 100644
> --- a/boot/uboot/uboot.mk
> +++ b/boot/uboot/uboot.mk
> @@ -167,8 +167,14 @@ endif
> 
>  ifeq ($(BR2_TARGET_UBOOT_NEEDS_PYTHON2),y)
>  UBOOT_DEPENDENCIES += host-python
> +ifeq ($(BR2_TARGET_UBOOT_SPL),y)
> +UBOOT_DEPENDENCIES += host-python-setuptools
> +endif
>  else ifeq ($(BR2_TARGET_UBOOT_NEEDS_PYTHON3),y)
>  UBOOT_DEPENDENCIES += host-python3
> +ifeq ($(BR2_TARGET_UBOOT_SPL),y)
> +UBOOT_DEPENDENCIES += host-python3-setuptools
> +endif
>  endif
> 
>  ifeq ($(BR2_TARGET_UBOOT_NEEDS_PYLIBFDT),y)
Francois Perrad Jan. 15, 2021, 5:01 p.m. UTC | #3
Le ven. 15 janv. 2021 à 16:36, Michael Walle <michael@walle.cc> a écrit :

> Hi Francois,
>
> Am 2021-01-12 10:18, schrieb Francois Perrad:
> > since 2021.01, tools/binman is broken.
> > tools/binman/control.py imports pkg_resources
> > the module pkg_resources is supplied by setuptools,
> > so this new dependency is required.
> >
> > binman is used only for building SPL
>
> is it? AFAIK binman is just for generating images and can as
> well be used without SPL. There is also a CONFIG_BINMAN.
> I don't know if we could check the u-boot config for that.
> Otherwise, I guess we'd need yet another "u-boot uses binman"
> config option. I don't think checking of SPL is enough.
>
>
setuptools is a very small package (compared to python itself).
so, I will added it unconditionally with python.

François

-michael
>
> >
> > Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
> > ---
> >  boot/uboot/uboot.mk | 6 ++++++
> >  1 file changed, 6 insertions(+)
> >
> > diff --git a/boot/uboot/uboot.mk b/boot/uboot/uboot.mk
> > index d2b4e8dc6..a3d949a55 100644
> > --- a/boot/uboot/uboot.mk
> > +++ b/boot/uboot/uboot.mk
> > @@ -167,8 +167,14 @@ endif
> >
> >  ifeq ($(BR2_TARGET_UBOOT_NEEDS_PYTHON2),y)
> >  UBOOT_DEPENDENCIES += host-python
> > +ifeq ($(BR2_TARGET_UBOOT_SPL),y)
> > +UBOOT_DEPENDENCIES += host-python-setuptools
> > +endif
> >  else ifeq ($(BR2_TARGET_UBOOT_NEEDS_PYTHON3),y)
> >  UBOOT_DEPENDENCIES += host-python3
> > +ifeq ($(BR2_TARGET_UBOOT_SPL),y)
> > +UBOOT_DEPENDENCIES += host-python3-setuptools
> > +endif
> >  endif
> >
> >  ifeq ($(BR2_TARGET_UBOOT_NEEDS_PYLIBFDT),y)
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
>
diff mbox series

Patch

diff --git a/boot/uboot/uboot.mk b/boot/uboot/uboot.mk
index d2b4e8dc6..a3d949a55 100644
--- a/boot/uboot/uboot.mk
+++ b/boot/uboot/uboot.mk
@@ -167,8 +167,14 @@  endif
 
 ifeq ($(BR2_TARGET_UBOOT_NEEDS_PYTHON2),y)
 UBOOT_DEPENDENCIES += host-python
+ifeq ($(BR2_TARGET_UBOOT_SPL),y)
+UBOOT_DEPENDENCIES += host-python-setuptools
+endif
 else ifeq ($(BR2_TARGET_UBOOT_NEEDS_PYTHON3),y)
 UBOOT_DEPENDENCIES += host-python3
+ifeq ($(BR2_TARGET_UBOOT_SPL),y)
+UBOOT_DEPENDENCIES += host-python3-setuptools
+endif
 endif
 
 ifeq ($(BR2_TARGET_UBOOT_NEEDS_PYLIBFDT),y)