diff mbox series

[1/3] package/qt5/qt5coap: new package

Message ID 20201119102150.714800-1-angelo@amarulasolutions.com
State Superseded
Headers show
Series [1/3] package/qt5/qt5coap: new package | expand

Commit Message

Angelo Compagnucci Nov. 19, 2020, 10:21 a.m. UTC
The Qt CoAP module implements the client side of CoAP defined by RFC
7252.

Signed-off-by: Angelo Compagnucci <angelo@amarulasolutions.com>
---
 DEVELOPERS                       |  1 +
 package/qt5/Config.in            |  1 +
 package/qt5/qt5coap/Config.in    | 11 +++++++++++
 package/qt5/qt5coap/qt5coap.hash |  6 ++++++
 package/qt5/qt5coap/qt5coap.mk   | 19 +++++++++++++++++++
 5 files changed, 38 insertions(+)
 create mode 100644 package/qt5/qt5coap/Config.in
 create mode 100644 package/qt5/qt5coap/qt5coap.hash
 create mode 100644 package/qt5/qt5coap/qt5coap.mk

Comments

Peter Seiderer Nov. 19, 2020, 7:20 p.m. UTC | #1
Hello Angelo,

On Thu, 19 Nov 2020 11:21:48 +0100, Angelo Compagnucci <angelo@amarulasolutions.com> wrote:

> The Qt CoAP module implements the client side of CoAP defined by RFC
> 7252.
>
> Signed-off-by: Angelo Compagnucci <angelo@amarulasolutions.com>
> ---
>  DEVELOPERS                       |  1 +
>  package/qt5/Config.in            |  1 +
>  package/qt5/qt5coap/Config.in    | 11 +++++++++++
>  package/qt5/qt5coap/qt5coap.hash |  6 ++++++
>  package/qt5/qt5coap/qt5coap.mk   | 19 +++++++++++++++++++
>  5 files changed, 38 insertions(+)
>  create mode 100644 package/qt5/qt5coap/Config.in
>  create mode 100644 package/qt5/qt5coap/qt5coap.hash
>  create mode 100644 package/qt5/qt5coap/qt5coap.mk
>
> diff --git a/DEVELOPERS b/DEVELOPERS
> index 9ab1e125f4..3f5fa20ebc 100644
> --- a/DEVELOPERS
> +++ b/DEVELOPERS
> @@ -169,6 +169,7 @@ F:	package/python-pillow/
>  F:	package/python-pydal/
>  F:	package/python-spidev/
>  F:	package/python-web2py/
> +F:	package/qt5/qt5coap/
>  F:	package/sam-ba/
>  F:	package/sshguard/
>  F:	package/sunwait/
> diff --git a/package/qt5/Config.in b/package/qt5/Config.in
> index fc0e68e8b7..9431f4980d 100644
> --- a/package/qt5/Config.in
> +++ b/package/qt5/Config.in
> @@ -40,6 +40,7 @@ if BR2_PACKAGE_QT5
>  source "package/qt5/qt53d/Config.in"
>  source "package/qt5/qt5base/Config.in"
>  source "package/qt5/qt5charts/Config.in"
> +source "package/qt5/qt5coap/Config.in"
>  source "package/qt5/qt5connectivity/Config.in"
>  source "package/qt5/qt5declarative/Config.in"
>  source "package/qt5/qt5enginio/Config.in"
> diff --git a/package/qt5/qt5coap/Config.in b/package/qt5/qt5coap/Config.in
> new file mode 100644
> index 0000000000..b5bed342a9
> --- /dev/null
> +++ b/package/qt5/qt5coap/Config.in
> @@ -0,0 +1,11 @@
> +config BR2_PACKAGE_QT5COAP
> +	bool "qt5coap"
> +	help
> +	  Qt is a cross-platform application and UI framework for
> +	  developers using C++.
> +
> +	  CoAP is a protocol for IoT devices, and machine to machine
> +	  communication. The Qt CoAP module implements the client side
> +	  of CoAP defined by RFC 7252.
> +
> +	  https://doc.qt.io/QtCoAP/qtcoap-index.html
> diff --git a/package/qt5/qt5coap/qt5coap.hash b/package/qt5/qt5coap/qt5coap.hash
> new file mode 100644
> index 0000000000..423278e652
> --- /dev/null
> +++ b/package/qt5/qt5coap/qt5coap.hash
> @@ -0,0 +1,6 @@
> +# Hash locally calculated
> +sha256  f2addd89e94fb3945fc6ee6db795b0736cd3396760b31e04c01cd02558c53e07  qt5coap-5.15.1.tar.gz
> +
> +# Hashes for license files:
> +sha256 8ceb4b9ee5adedde47b31e975c1d90c73ad27b6b165a1dcd80c7c545eb65b903 LICENSE.GPL3
> +sha256 f827ad079686ba92cc94811e35492d0e8966f704008b6da9eeda0b659fb58a8d LICENSE.FDL

Preferred style is with two spaces as separators (see [1]), with this fixed
you can add my:

Reviewed-by: Peter Seiderer <ps.report@gmx.net>

Regards,
Peter

> diff --git a/package/qt5/qt5coap/qt5coap.mk b/package/qt5/qt5coap/qt5coap.mk
> new file mode 100644
> index 0000000000..210cebf13a
> --- /dev/null
> +++ b/package/qt5/qt5coap/qt5coap.mk
> @@ -0,0 +1,19 @@
> +################################################################################
> +#
> +# qt5coap
> +#
> +################################################################################
> +
> +QT5COAP_VERSION = $(QT5_VERSION)
> +QT5COAP_SITE = $(call github,qt,qtcoap,v$(QT5_VERSION))
> +QT5COAP_INSTALL_STAGING = YES
> +QT5COAP_LICENSE = GPL-3.0, GFDL-1.3
> +QT5COAP_LICENSE_FILES = LICENSE.GPL3 LICENSE.FDL
> +QT5COAP_DEPENDENCIES = host-perl
> +
> +define QT5COAP_FIX_INCLUDE
> +	cd $(@D); $(HOST_DIR)/bin/syncqt.pl -module QtCoap -version $(QT5_VERSION)
> +endef
> +QT5COAP_PRE_CONFIGURE_HOOKS = QT5COAP_FIX_INCLUDE
> +
> +$(eval $(qmake-package))
Peter Seiderer Nov. 19, 2020, 7:29 p.m. UTC | #2
Hello Angelo,

On Thu, 19 Nov 2020 20:20:52 +0100, Peter Seiderer <ps.report@gmx.net> wrote:

> > diff --git a/package/qt5/qt5coap/qt5coap.hash b/package/qt5/qt5coap/qt5coap.hash
> > new file mode 100644
> > index 0000000000..423278e652
> > --- /dev/null
> > +++ b/package/qt5/qt5coap/qt5coap.hash
> > @@ -0,0 +1,6 @@
> > +# Hash locally calculated
> > +sha256  f2addd89e94fb3945fc6ee6db795b0736cd3396760b31e04c01cd02558c53e07  qt5coap-5.15.1.tar.gz
> > +
> > +# Hashes for license files:
> > +sha256 8ceb4b9ee5adedde47b31e975c1d90c73ad27b6b165a1dcd80c7c545eb65b903 LICENSE.GPL3
> > +sha256 f827ad079686ba92cc94811e35492d0e8966f704008b6da9eeda0b659fb58a8d LICENSE.FDL
>
> Preferred style is with two spaces as separators (see [1]), with this fixed
> you can add my:
>
> Reviewed-by: Peter Seiderer <ps.report@gmx.net>
>
> Regards,
> Peter
>

...and the missing reference/link:

[1] https://buildroot.org/downloads/manual/manual.html#adding-packages-hash

  The format of this file is one line for each file for which to check the hash,
  each line with the following three fields separated by two spaces.

Regards,
Peter
Angelo Compagnucci Nov. 19, 2020, 10:04 p.m. UTC | #3
Il giorno gio 19 nov 2020 alle ore 20:29 Peter Seiderer
<ps.report@gmx.net> ha scritto:
>
> Hello Angelo,
>
> On Thu, 19 Nov 2020 20:20:52 +0100, Peter Seiderer <ps.report@gmx.net> wrote:
>
> > > diff --git a/package/qt5/qt5coap/qt5coap.hash b/package/qt5/qt5coap/qt5coap.hash
> > > new file mode 100644
> > > index 0000000000..423278e652
> > > --- /dev/null
> > > +++ b/package/qt5/qt5coap/qt5coap.hash
> > > @@ -0,0 +1,6 @@
> > > +# Hash locally calculated
> > > +sha256  f2addd89e94fb3945fc6ee6db795b0736cd3396760b31e04c01cd02558c53e07  qt5coap-5.15.1.tar.gz
> > > +
> > > +# Hashes for license files:
> > > +sha256 8ceb4b9ee5adedde47b31e975c1d90c73ad27b6b165a1dcd80c7c545eb65b903 LICENSE.GPL3
> > > +sha256 f827ad079686ba92cc94811e35492d0e8966f704008b6da9eeda0b659fb58a8d LICENSE.FDL
> >
> > Preferred style is with two spaces as separators (see [1]), with this fixed
> > you can add my:
> >
> > Reviewed-by: Peter Seiderer <ps.report@gmx.net>
> >
> > Regards,
> > Peter
> >
>
> ...and the missing reference/link:
>
> [1] https://buildroot.org/downloads/manual/manual.html#adding-packages-hash
>
>   The format of this file is one line for each file for which to check the hash,
>   each line with the following three fields separated by two spaces.

I took the hash file from another qt5 package, hence the error.

Out of curiosity, I wrote a simple python script to look for hash
files with wrong syntax, we have 2k+ of them!

>
> Regards,
> Peter
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
Peter Seiderer Nov. 20, 2020, 6:37 p.m. UTC | #4
Hello Angelo,

On Thu, 19 Nov 2020 23:04:59 +0100, Angelo Compagnucci <angelo.compagnucci@gmail.com> wrote:

> Il giorno gio 19 nov 2020 alle ore 20:29 Peter Seiderer
> <ps.report@gmx.net> ha scritto:
> >
> > Hello Angelo,
> >
> > On Thu, 19 Nov 2020 20:20:52 +0100, Peter Seiderer <ps.report@gmx.net> wrote:
> >
> > > > diff --git a/package/qt5/qt5coap/qt5coap.hash b/package/qt5/qt5coap/qt5coap.hash
> > > > new file mode 100644
> > > > index 0000000000..423278e652
> > > > --- /dev/null
> > > > +++ b/package/qt5/qt5coap/qt5coap.hash
> > > > @@ -0,0 +1,6 @@
> > > > +# Hash locally calculated
> > > > +sha256  f2addd89e94fb3945fc6ee6db795b0736cd3396760b31e04c01cd02558c53e07  qt5coap-5.15.1.tar.gz
> > > > +
> > > > +# Hashes for license files:
> > > > +sha256 8ceb4b9ee5adedde47b31e975c1d90c73ad27b6b165a1dcd80c7c545eb65b903 LICENSE.GPL3
> > > > +sha256 f827ad079686ba92cc94811e35492d0e8966f704008b6da9eeda0b659fb58a8d LICENSE.FDL
> > >
> > > Preferred style is with two spaces as separators (see [1]), with this fixed
> > > you can add my:
> > >
> > > Reviewed-by: Peter Seiderer <ps.report@gmx.net>
> > >
> > > Regards,
> > > Peter
> > >
> >
> > ...and the missing reference/link:
> >
> > [1] https://buildroot.org/downloads/manual/manual.html#adding-packages-hash
> >
> >   The format of this file is one line for each file for which to check the hash,
> >   each line with the following three fields separated by two spaces.
>
> I took the hash file from another qt5 package, hence the error.

No error, just a nitpick (or a matter of style and no hard requirement) ;-)

>
> Out of curiosity, I wrote a simple python script to look for hash
> files with wrong syntax, we have 2k+ of them!

It is a 'new' feature (see [1]) and the buildroot source is still in the
process of converting (mainly while updating packages)...

Regards,
Peter

[1] https://git.buildroot.net/buildroot/commit/?id=ec060ced7aacda8bb93ee3c138c8ce33f5989ef3

>
> >
> > Regards,
> > Peter
> > _______________________________________________
> > buildroot mailing list
> > buildroot@busybox.net
> > http://lists.busybox.net/mailman/listinfo/buildroot
>
>
>
diff mbox series

Patch

diff --git a/DEVELOPERS b/DEVELOPERS
index 9ab1e125f4..3f5fa20ebc 100644
--- a/DEVELOPERS
+++ b/DEVELOPERS
@@ -169,6 +169,7 @@  F:	package/python-pillow/
 F:	package/python-pydal/
 F:	package/python-spidev/
 F:	package/python-web2py/
+F:	package/qt5/qt5coap/
 F:	package/sam-ba/
 F:	package/sshguard/
 F:	package/sunwait/
diff --git a/package/qt5/Config.in b/package/qt5/Config.in
index fc0e68e8b7..9431f4980d 100644
--- a/package/qt5/Config.in
+++ b/package/qt5/Config.in
@@ -40,6 +40,7 @@  if BR2_PACKAGE_QT5
 source "package/qt5/qt53d/Config.in"
 source "package/qt5/qt5base/Config.in"
 source "package/qt5/qt5charts/Config.in"
+source "package/qt5/qt5coap/Config.in"
 source "package/qt5/qt5connectivity/Config.in"
 source "package/qt5/qt5declarative/Config.in"
 source "package/qt5/qt5enginio/Config.in"
diff --git a/package/qt5/qt5coap/Config.in b/package/qt5/qt5coap/Config.in
new file mode 100644
index 0000000000..b5bed342a9
--- /dev/null
+++ b/package/qt5/qt5coap/Config.in
@@ -0,0 +1,11 @@ 
+config BR2_PACKAGE_QT5COAP
+	bool "qt5coap"
+	help
+	  Qt is a cross-platform application and UI framework for
+	  developers using C++.
+
+	  CoAP is a protocol for IoT devices, and machine to machine
+	  communication. The Qt CoAP module implements the client side
+	  of CoAP defined by RFC 7252.
+
+	  https://doc.qt.io/QtCoAP/qtcoap-index.html
diff --git a/package/qt5/qt5coap/qt5coap.hash b/package/qt5/qt5coap/qt5coap.hash
new file mode 100644
index 0000000000..423278e652
--- /dev/null
+++ b/package/qt5/qt5coap/qt5coap.hash
@@ -0,0 +1,6 @@ 
+# Hash locally calculated
+sha256  f2addd89e94fb3945fc6ee6db795b0736cd3396760b31e04c01cd02558c53e07  qt5coap-5.15.1.tar.gz
+
+# Hashes for license files:
+sha256 8ceb4b9ee5adedde47b31e975c1d90c73ad27b6b165a1dcd80c7c545eb65b903 LICENSE.GPL3
+sha256 f827ad079686ba92cc94811e35492d0e8966f704008b6da9eeda0b659fb58a8d LICENSE.FDL
diff --git a/package/qt5/qt5coap/qt5coap.mk b/package/qt5/qt5coap/qt5coap.mk
new file mode 100644
index 0000000000..210cebf13a
--- /dev/null
+++ b/package/qt5/qt5coap/qt5coap.mk
@@ -0,0 +1,19 @@ 
+################################################################################
+#
+# qt5coap
+#
+################################################################################
+
+QT5COAP_VERSION = $(QT5_VERSION)
+QT5COAP_SITE = $(call github,qt,qtcoap,v$(QT5_VERSION))
+QT5COAP_INSTALL_STAGING = YES
+QT5COAP_LICENSE = GPL-3.0, GFDL-1.3
+QT5COAP_LICENSE_FILES = LICENSE.GPL3 LICENSE.FDL
+QT5COAP_DEPENDENCIES = host-perl
+
+define QT5COAP_FIX_INCLUDE
+	cd $(@D); $(HOST_DIR)/bin/syncqt.pl -module QtCoap -version $(QT5_VERSION)
+endef
+QT5COAP_PRE_CONFIGURE_HOOKS = QT5COAP_FIX_INCLUDE
+
+$(eval $(qmake-package))