diff mbox series

package/rauc: prevent occurring the error when directory exists

Message ID 20201113113940.842415-1-b.bilas@grinn-global.com
State Accepted
Headers show
Series package/rauc: prevent occurring the error when directory exists | expand

Commit Message

Bartosz Bilas Nov. 13, 2020, 11:39 a.m. UTC
Add -p argument that ignore that specified directory already exists.

Fixes:
 mkdir: cannot create directory ‘/home/bartekk/buildroot-2020.11-rc1/output/target/usr/lib/systemd/system/rauc.service.d’: File exists

Signed-off-by: Bartosz Bilas <b.bilas@grinn-global.com>
---
 package/rauc/rauc.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Peter Korsgaard Nov. 13, 2020, 1:50 p.m. UTC | #1
>>>>> "Bartosz" == Bartosz Bilas <b.bilas@grinn-global.com> writes:

 > Add -p argument that ignore that specified directory already exists.
 > Fixes:
 >  mkdir: cannot create directory ‘/home/bartekk/buildroot-2020.11-rc1/output/target/usr/lib/systemd/system/rauc.service.d’: File exists

 > Signed-off-by: Bartosz Bilas <b.bilas@grinn-global.com>

Committed, thanks.
Peter Korsgaard Nov. 16, 2020, 2:45 p.m. UTC | #2
>>>>> "Bartosz" == Bartosz Bilas <b.bilas@grinn-global.com> writes:

 > Add -p argument that ignore that specified directory already exists.
 > Fixes:
 >  mkdir: cannot create directory ‘/home/bartekk/buildroot-2020.11-rc1/output/target/usr/lib/systemd/system/rauc.service.d’: File exists

 > Signed-off-by: Bartosz Bilas <b.bilas@grinn-global.com>

Committed to 2020.02.x and 2020.08.x, thanks.
diff mbox series

Patch

diff --git a/package/rauc/rauc.mk b/package/rauc/rauc.mk
index 1915c783aa..61c50ab316 100644
--- a/package/rauc/rauc.mk
+++ b/package/rauc/rauc.mk
@@ -31,7 +31,7 @@  RAUC_DEPENDENCIES += systemd
 endif
 
 define RAUC_INSTALL_INIT_SYSTEMD
-	mkdir $(TARGET_DIR)/usr/lib/systemd/system/rauc.service.d
+	mkdir -p $(TARGET_DIR)/usr/lib/systemd/system/rauc.service.d
 	printf '[Install]\nWantedBy=multi-user.target\n' \
 		>$(TARGET_DIR)/usr/lib/systemd/system/rauc.service.d/buildroot-enable.conf
 endef