diff mbox series

[v2,2/2] package/abootimg: use util-linux-libs

Message ID 20201103205745.123950-2-fontaine.fabrice@gmail.com
State Changes Requested
Headers show
Series [v2,1/2] package/util-linux: select BR2_PACKAGE_UTIL_LINUX_LIBS | expand

Commit Message

Fabrice Fontaine Nov. 3, 2020, 8:57 p.m. UTC
abootimg only needs libblkid from util-linux-libs

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
Changes v1 -> v2:
 - Select util-linux-libs instead of util-linux

 package/abootimg/Config.in   | 2 +-
 package/abootimg/abootimg.mk | 4 ++--
 2 files changed, 3 insertions(+), 3 deletions(-)

Comments

Yann E. MORIN Nov. 3, 2020, 9:14 p.m. UTC | #1
Fabrice, All,

On 2020-11-03 21:57 +0100, Fabrice Fontaine spake thusly:
> abootimg only needs libblkid from util-linux-libs
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
> Changes v1 -> v2:
>  - Select util-linux-libs instead of util-linux
> 
>  package/abootimg/Config.in   | 2 +-
>  package/abootimg/abootimg.mk | 4 ++--
>  2 files changed, 3 insertions(+), 3 deletions(-)
> 
> diff --git a/package/abootimg/Config.in b/package/abootimg/Config.in
> index 30e5bd1fb0..8aa4cb414c 100644
> --- a/package/abootimg/Config.in
> +++ b/package/abootimg/Config.in
> @@ -1,7 +1,7 @@
>  config BR2_PACKAGE_ABOOTIMG
>  	bool "abootimg"
>  	depends on BR2_USE_MMU	# libblkid
> -	select BR2_PACKAGE_UTIL_LINUX
> +	select BR2_PACKAGE_UTIL_LINUX_LIBS
>  	select BR2_PACKAGE_UTIL_LINUX_LIBBLKID

BR2_PACKAGE_UTIL_LINUX_LIBBLKID is an option of util-linux, so you can't
drop the "select BR2_PACKAGE_UTIL_LINUX"

That's again probably my fault, because I was maybe not exhaustive
enough on my previous reply in the libglib2 thread.

However, please see what I replied to the v1 of this series.

Still, it is not trivial, so we colectively need to think about it...

Regards,
Yann E. MORIN.

>  	help
>  	  Tool to manipulate Android Boot Images, either on files
> diff --git a/package/abootimg/abootimg.mk b/package/abootimg/abootimg.mk
> index e906546948..d139d58ceb 100644
> --- a/package/abootimg/abootimg.mk
> +++ b/package/abootimg/abootimg.mk
> @@ -9,8 +9,8 @@ ABOOTIMG_SITE = $(call github,ggrandou,abootimg,$(ABOOTIMG_VERSION))
>  ABOOTIMG_LICENSE = GPL-2.0+
>  ABOOTIMG_LICENSE_FILES = LICENSE
>  
> -# depends on libblkid from util-linux
> -ABOOTIMG_DEPENDENCIES = util-linux
> +# depends on libblkid from util-linux-libs
> +ABOOTIMG_DEPENDENCIES = util-linux-libs

>  define ABOOTIMG_BUILD_CMDS
>  	$(TARGET_MAKE_ENV) $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D)
> -- 
> 2.28.0
> 
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
Arnout Vandecappelle Dec. 1, 2020, 9:19 p.m. UTC | #2
On 03/11/2020 21:57, Fabrice Fontaine wrote:
> abootimg only needs libblkid from util-linux-libs
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
> Changes v1 -> v2:
>  - Select util-linux-libs instead of util-linux
> 
>  package/abootimg/Config.in   | 2 +-
>  package/abootimg/abootimg.mk | 4 ++--
>  2 files changed, 3 insertions(+), 3 deletions(-)
> 
> diff --git a/package/abootimg/Config.in b/package/abootimg/Config.in
> index 30e5bd1fb0..8aa4cb414c 100644
> --- a/package/abootimg/Config.in
> +++ b/package/abootimg/Config.in
> @@ -1,7 +1,7 @@
>  config BR2_PACKAGE_ABOOTIMG
>  	bool "abootimg"
>  	depends on BR2_USE_MMU	# libblkid
> -	select BR2_PACKAGE_UTIL_LINUX
> +	select BR2_PACKAGE_UTIL_LINUX_LIBS
>  	select BR2_PACKAGE_UTIL_LINUX_LIBBLKID
>  	help
>  	  Tool to manipulate Android Boot Images, either on files
> diff --git a/package/abootimg/abootimg.mk b/package/abootimg/abootimg.mk
> index e906546948..d139d58ceb 100644
> --- a/package/abootimg/abootimg.mk
> +++ b/package/abootimg/abootimg.mk
> @@ -9,8 +9,8 @@ ABOOTIMG_SITE = $(call github,ggrandou,abootimg,$(ABOOTIMG_VERSION))
>  ABOOTIMG_LICENSE = GPL-2.0+
>  ABOOTIMG_LICENSE_FILES = LICENSE
>  
> -# depends on libblkid from util-linux
> -ABOOTIMG_DEPENDENCIES = util-linux
> +# depends on libblkid from util-linux-libs
> +ABOOTIMG_DEPENDENCIES = util-linux-libs

 This we definitely want to avoid in general. The problem is that some libraries
*may* be built in a different way in the second pass than in the first pass. The
whole reason we have this mess is because parts of util-linux depend on packages
that depend on util-linux libraries - and some of these parts may be in
libraries as well! So we *only* want to use util-linux-libs in specific cases
where we can check very carefully if the dependency chain is OK. For libmount/,
it is.

 I remember that I made this analysis when I applied the util-linux-libs split,
but unfortunately it doesn't seem to have made it to the commit message...


 Regards,
 Arnout


>  
>  define ABOOTIMG_BUILD_CMDS
>  	$(TARGET_MAKE_ENV) $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D)
>
diff mbox series

Patch

diff --git a/package/abootimg/Config.in b/package/abootimg/Config.in
index 30e5bd1fb0..8aa4cb414c 100644
--- a/package/abootimg/Config.in
+++ b/package/abootimg/Config.in
@@ -1,7 +1,7 @@ 
 config BR2_PACKAGE_ABOOTIMG
 	bool "abootimg"
 	depends on BR2_USE_MMU	# libblkid
-	select BR2_PACKAGE_UTIL_LINUX
+	select BR2_PACKAGE_UTIL_LINUX_LIBS
 	select BR2_PACKAGE_UTIL_LINUX_LIBBLKID
 	help
 	  Tool to manipulate Android Boot Images, either on files
diff --git a/package/abootimg/abootimg.mk b/package/abootimg/abootimg.mk
index e906546948..d139d58ceb 100644
--- a/package/abootimg/abootimg.mk
+++ b/package/abootimg/abootimg.mk
@@ -9,8 +9,8 @@  ABOOTIMG_SITE = $(call github,ggrandou,abootimg,$(ABOOTIMG_VERSION))
 ABOOTIMG_LICENSE = GPL-2.0+
 ABOOTIMG_LICENSE_FILES = LICENSE
 
-# depends on libblkid from util-linux
-ABOOTIMG_DEPENDENCIES = util-linux
+# depends on libblkid from util-linux-libs
+ABOOTIMG_DEPENDENCIES = util-linux-libs
 
 define ABOOTIMG_BUILD_CMDS
 	$(TARGET_MAKE_ENV) $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D)