diff mbox series

[1/2] package/zlib-ng: drop unrecognized CC variable

Message ID 20201011194357.1923003-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/2] package/zlib-ng: drop unrecognized CC variable | expand

Commit Message

Fabrice Fontaine Oct. 11, 2020, 7:43 p.m. UTC
Drop unneeded CC variable which is not recognized by cmake:

CMake Warning:
  Manually-specified variables were not used by the project:

    BUILD_DOC
    BUILD_DOCS
    BUILD_EXAMPLE
    BUILD_EXAMPLES
    BUILD_TEST
    BUILD_TESTING
    BUILD_TESTS
    CC

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/zlib-ng/zlib-ng.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Thomas Petazzoni Oct. 11, 2020, 8:57 p.m. UTC | #1
On Sun, 11 Oct 2020 21:43:56 +0200
Fabrice Fontaine <fontaine.fabrice@gmail.com> wrote:

> Drop unneeded CC variable which is not recognized by cmake:
> 
> CMake Warning:
>   Manually-specified variables were not used by the project:
> 
>     BUILD_DOC
>     BUILD_DOCS
>     BUILD_EXAMPLE
>     BUILD_EXAMPLES
>     BUILD_TEST
>     BUILD_TESTING
>     BUILD_TESTS
>     CC
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
>  package/zlib-ng/zlib-ng.mk | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)

Both applied to master. Thanks!

Thomas
Peter Korsgaard Oct. 12, 2020, 8:09 a.m. UTC | #2
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > Drop unneeded CC variable which is not recognized by cmake:
 > CMake Warning:
 >   Manually-specified variables were not used by the project:

 >     BUILD_DOC
 >     BUILD_DOCS
 >     BUILD_EXAMPLE
 >     BUILD_EXAMPLES
 >     BUILD_TEST
 >     BUILD_TESTING
 >     BUILD_TESTS
 >     CC

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed to 2020.08.x, thanks.
diff mbox series

Patch

diff --git a/package/zlib-ng/zlib-ng.mk b/package/zlib-ng/zlib-ng.mk
index 098dfcb28a..3b27574a79 100644
--- a/package/zlib-ng/zlib-ng.mk
+++ b/package/zlib-ng/zlib-ng.mk
@@ -12,7 +12,7 @@  ZLIB_NG_INSTALL_STAGING = YES
 ZLIB_NG_PROVIDES = zlib
 
 # Build with zlib compatible API, gzFile support and optimizations on
-ZLIB_NG_CONF_OPTS += -DZLIB_COMPAT=1 -DWITH_GZFILEOP=1 -DWITH_OPTIM=1 -DCC=$(TARGET_CC)
+ZLIB_NG_CONF_OPTS += -DZLIB_COMPAT=1 -DWITH_GZFILEOP=1 -DWITH_OPTIM=1
 
 # Enable NEON and ACLE on ARM
 ifeq ($(BR2_arm),y)