diff mbox series

package/alsa-utils: fix install if directories exist

Message ID 20200903133533.2505458-1-john@metanate.com
State Accepted
Headers show
Series package/alsa-utils: fix install if directories exist | expand

Commit Message

John Keeping Sept. 3, 2020, 1:35 p.m. UTC
"mkdir" (without "-p") fails if the target directory exists, which means
that if alsa-utils is being reinstalled or if other files have
previously been installed in the alsa-state.d or alsa-restore.d
directories the installation will fail.

Switch to "$(INSTALL) -d" which allows us to be explicit about the
permissions and handles the case of a pre-existing directory correctly.

Signed-off-by: John Keeping <john@metanate.com>
---
 package/alsa-utils/alsa-utils.mk | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Thomas Petazzoni Sept. 3, 2020, 7:01 p.m. UTC | #1
On Thu,  3 Sep 2020 14:35:33 +0100
John Keeping <john@metanate.com> wrote:

> "mkdir" (without "-p") fails if the target directory exists, which means
> that if alsa-utils is being reinstalled or if other files have
> previously been installed in the alsa-state.d or alsa-restore.d
> directories the installation will fail.
> 
> Switch to "$(INSTALL) -d" which allows us to be explicit about the
> permissions and handles the case of a pre-existing directory correctly.
> 
> Signed-off-by: John Keeping <john@metanate.com>
> ---
>  package/alsa-utils/alsa-utils.mk | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)

Applied to master, thanks.

Thomas
Peter Korsgaard Sept. 5, 2020, 8:18 a.m. UTC | #2
>>>>> "John" == John Keeping <john@metanate.com> writes:

 > "mkdir" (without "-p") fails if the target directory exists, which means
 > that if alsa-utils is being reinstalled or if other files have
 > previously been installed in the alsa-state.d or alsa-restore.d
 > directories the installation will fail.

 > Switch to "$(INSTALL) -d" which allows us to be explicit about the
 > permissions and handles the case of a pre-existing directory correctly.

 > Signed-off-by: John Keeping <john@metanate.com>

Committed to 2020.02.x, 2020.05.x and 2020.08.x, thanks.
diff mbox series

Patch

diff --git a/package/alsa-utils/alsa-utils.mk b/package/alsa-utils/alsa-utils.mk
index 27894d3e92..4776a17454 100644
--- a/package/alsa-utils/alsa-utils.mk
+++ b/package/alsa-utils/alsa-utils.mk
@@ -86,10 +86,10 @@  define ALSA_UTILS_INSTALL_INIT_SYSTEMD
 		$(TARGET_DIR)/usr/lib/systemd/system/alsa-restore.service
 	$(INSTALL) -D -m 0644 $(@D)/alsactl/alsa-state.service \
 		$(TARGET_DIR)/usr/lib/systemd/system/alsa-state.service
-	mkdir $(TARGET_DIR)/usr/lib/systemd/system/alsa-restore.service.d
+	$(INSTALL) -d -m 0755 $(TARGET_DIR)/usr/lib/systemd/system/alsa-restore.service.d
 	printf '[Install]\nWantedBy=multi-user.target\n' \
 		>$(TARGET_DIR)/usr/lib/systemd/system/alsa-restore.service.d/buildroot-enable.conf
-	mkdir $(TARGET_DIR)/usr/lib/systemd/system/alsa-state.service.d
+	$(INSTALL) -d -m 0755 $(TARGET_DIR)/usr/lib/systemd/system/alsa-state.service.d
 	printf '[Install]\nWantedBy=multi-user.target\n' \
 		>$(TARGET_DIR)/usr/lib/systemd/system/alsa-state.service.d/buildroot-enable.conf;
 endef