diff mbox series

package/ripgrep: fix build directories

Message ID 20200827004424.325134-1-sam.voss@gmail.com
State Accepted
Headers show
Series package/ripgrep: fix build directories | expand

Commit Message

Sam Voss Aug. 27, 2020, 12:44 a.m. UTC
From: Sam Voss <sam.voss@gmail.com>

RIPGREP_CARGO_MODE was no longer defined after 832c076f26 and caused
issues during the install step as the build directory was malformed.

This patch maintains the release/dev profile distinction, while also
assigning appropriate build folders.

Fixes:
 - http://autobuild.buildroot.net/results/a4cd7ecc6d983aa6f15d3be1e21529f17e04b825/
 - http://autobuild.buildroot.net/results/2bab8ffa590d4c4eabffe94ed27311c7f6607c98/

Signed-off-by: Sam Voss <sam.voss@gmail.com>
CC: Yann E. MORIN <yann.morin.1998@free.fr>
---
 package/ripgrep/ripgrep.mk | 10 ++++++++--
 1 file changed, 8 insertions(+), 2 deletions(-)

Comments

Yann E. MORIN Aug. 27, 2020, 7:58 a.m. UTC | #1
Sam, All,

On 2020-08-26 19:44 -0500, sam.voss@gmail.com spake thusly:
> From: Sam Voss <sam.voss@gmail.com>
> 
> RIPGREP_CARGO_MODE was no longer defined after 832c076f26 and caused
> issues during the install step as the build directory was malformed.
> 
> This patch maintains the release/dev profile distinction, while also
> assigning appropriate build folders.
> 
> Fixes:
>  - http://autobuild.buildroot.net/results/a4cd7ecc6d983aa6f15d3be1e21529f17e04b825/
>  - http://autobuild.buildroot.net/results/2bab8ffa590d4c4eabffe94ed27311c7f6607c98/
> 
> Signed-off-by: Sam Voss <sam.voss@gmail.com>
> CC: Yann E. MORIN <yann.morin.1998@free.fr>

Applied to master, thanks.

Regards,
Yann E. MORIN.

> ---
>  package/ripgrep/ripgrep.mk | 10 ++++++++--
>  1 file changed, 8 insertions(+), 2 deletions(-)
> 
> diff --git a/package/ripgrep/ripgrep.mk b/package/ripgrep/ripgrep.mk
> index 5f58630ffe..9dd8d58de1 100644
> --- a/package/ripgrep/ripgrep.mk
> +++ b/package/ripgrep/ripgrep.mk
> @@ -12,13 +12,19 @@ RIPGREP_LICENSE_FILES = LICENSE-MIT
>  RIPGREP_DEPENDENCIES = host-rustc
>  RIPGREP_CARGO_ENV = CARGO_HOME=$(HOST_DIR)/share/cargo
>  
> -RIPGREP_BIN_DIR = target/$(RUSTC_TARGET_NAME)/$(RIPGREP_CARGO_MODE)
> +RIPGREP_BIN_DIR = target/$(RUSTC_TARGET_NAME)/$(RIPGREP_CARGO_BIN_SUBDIR)
>  
>  RIPGREP_CARGO_OPTS = \
> -	$(if $(BR2_ENABLE_DEBUG),,--release) \
>  	--target=$(RUSTC_TARGET_NAME) \
>  	--manifest-path=$(@D)/Cargo.toml
>  
> +ifeq ($(BR2_ENABLE_DEBUG),y)
> +RIPGREP_CARGO_BIN_SUBDIR = debug
> +else
> +RIPGREP_CARGO_OPTS += --release
> +RIPGREP_CARGO_BIN_SUBDIR = release
> +endif
> +
>  define RIPGREP_BUILD_CMDS
>  	$(TARGET_MAKE_ENV) $(RIPGREP_CARGO_ENV) \
>  		cargo build $(RIPGREP_CARGO_OPTS)
> -- 
> 2.27.0
>
Peter Korsgaard Aug. 28, 2020, 5:29 p.m. UTC | #2
>>>>> "sam" == sam voss <sam.voss@gmail.com> writes:

 > From: Sam Voss <sam.voss@gmail.com>
 > RIPGREP_CARGO_MODE was no longer defined after 832c076f26 and caused
 > issues during the install step as the build directory was malformed.

 > This patch maintains the release/dev profile distinction, while also
 > assigning appropriate build folders.

 > Fixes:
 >  - http://autobuild.buildroot.net/results/a4cd7ecc6d983aa6f15d3be1e21529f17e04b825/
 >  - http://autobuild.buildroot.net/results/2bab8ffa590d4c4eabffe94ed27311c7f6607c98/

 > Signed-off-by: Sam Voss <sam.voss@gmail.com>
 > CC: Yann E. MORIN <yann.morin.1998@free.fr>

Committed to 2020.02.x and 2020.05.x, thanks.
diff mbox series

Patch

diff --git a/package/ripgrep/ripgrep.mk b/package/ripgrep/ripgrep.mk
index 5f58630ffe..9dd8d58de1 100644
--- a/package/ripgrep/ripgrep.mk
+++ b/package/ripgrep/ripgrep.mk
@@ -12,13 +12,19 @@  RIPGREP_LICENSE_FILES = LICENSE-MIT
 RIPGREP_DEPENDENCIES = host-rustc
 RIPGREP_CARGO_ENV = CARGO_HOME=$(HOST_DIR)/share/cargo
 
-RIPGREP_BIN_DIR = target/$(RUSTC_TARGET_NAME)/$(RIPGREP_CARGO_MODE)
+RIPGREP_BIN_DIR = target/$(RUSTC_TARGET_NAME)/$(RIPGREP_CARGO_BIN_SUBDIR)
 
 RIPGREP_CARGO_OPTS = \
-	$(if $(BR2_ENABLE_DEBUG),,--release) \
 	--target=$(RUSTC_TARGET_NAME) \
 	--manifest-path=$(@D)/Cargo.toml
 
+ifeq ($(BR2_ENABLE_DEBUG),y)
+RIPGREP_CARGO_BIN_SUBDIR = debug
+else
+RIPGREP_CARGO_OPTS += --release
+RIPGREP_CARGO_BIN_SUBDIR = release
+endif
+
 define RIPGREP_BUILD_CMDS
 	$(TARGET_MAKE_ENV) $(RIPGREP_CARGO_ENV) \
 		cargo build $(RIPGREP_CARGO_OPTS)