diff mbox series

[1/1] package/mtd: crypto support needs linux-headers

Message ID 20200811091917.1545019-1-fontaine.fabrice@gmail.com
State Superseded
Headers show
Series [1/1] package/mtd: crypto support needs linux-headers | expand

Commit Message

Fabrice Fontaine Aug. 11, 2020, 9:19 a.m. UTC
crypto support needs linux-headers as it includes <linux/hash_info.h>
since version 2.1.2 and
https://github.com/sigma-star/mtd-utils/commit/a739b59efe7996e3bdcbe8b17743dc05ac7c110a

Fixes:
 - http://autobuild.buildroot.org/results/dbaeed9e9e2af191166808d2d6d6d3c2e5051c2c

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/mtd/mtd.mk | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Thomas Petazzoni Aug. 11, 2020, 10:30 a.m. UTC | #1
On Tue, 11 Aug 2020 11:19:17 +0200
Fabrice Fontaine via buildroot <buildroot@busybox.net> wrote:

> crypto support needs linux-headers as it includes <linux/hash_info.h>
> since version 2.1.2 and
> https://github.com/sigma-star/mtd-utils/commit/a739b59efe7996e3bdcbe8b17743dc05ac7c110a
> 
> Fixes:
>  - http://autobuild.buildroot.org/results/dbaeed9e9e2af191166808d2d6d6d3c2e5051c2c

You can't do that, as linux-headers is only used for the internal
toolchain backend. Also the kernel headers are already present in all
toolchains, so how could this change anything ?

Thomas
Fabrice Fontaine Aug. 11, 2020, 3:01 p.m. UTC | #2
Le mar. 11 août 2020 à 12:30, Thomas Petazzoni
<thomas.petazzoni@bootlin.com> a écrit :
>
> On Tue, 11 Aug 2020 11:19:17 +0200
> Fabrice Fontaine via buildroot <buildroot@busybox.net> wrote:
>
> > crypto support needs linux-headers as it includes <linux/hash_info.h>
> > since version 2.1.2 and
> > https://github.com/sigma-star/mtd-utils/commit/a739b59efe7996e3bdcbe8b17743dc05ac7c110a
> >
> > Fixes:
> >  - http://autobuild.buildroot.org/results/dbaeed9e9e2af191166808d2d6d6d3c2e5051c2c
>
> You can't do that, as linux-headers is only used for the internal
> toolchain backend. Also the kernel headers are already present in all
> toolchains, so how could this change anything ?
I was not aware that kernel headers were already present in all
toolchains. Thanks for spotting my mistake. I'll send a v2 adding a
dependency on headers 4.12 as this is the real issue.

However, it should be noted that we have an "issue" with the iputils
package as it has an optional dependency on linux-headers since commit
9ffcd9279e5505535a73cf1200b3a86fd425cf32.
I assume that this dependency is also not needed?
>
> Thomas
> --
> Thomas Petazzoni, CTO, Bootlin
> Embedded Linux and Kernel engineering
> https://bootlin.com
Best Regards,

Fabrice
Yann E. MORIN Aug. 11, 2020, 3:57 p.m. UTC | #3
Fabrice, All,

On 2020-08-11 17:01 +0200, Fabrice Fontaine via buildroot spake thusly:
> Le mar. 11 août 2020 à 12:30, Thomas Petazzoni
> <thomas.petazzoni@bootlin.com> a écrit :
> > On Tue, 11 Aug 2020 11:19:17 +0200
> > Fabrice Fontaine via buildroot <buildroot@busybox.net> wrote:
> > > crypto support needs linux-headers as it includes <linux/hash_info.h>
> > > since version 2.1.2 and
> > You can't do that, as linux-headers is only used for the internal
> > toolchain backend. Also the kernel headers are already present in all
> > toolchains, so how could this change anything ?
> I was not aware that kernel headers were already present in all
> toolchains. Thanks for spotting my mistake. I'll send a v2 adding a
> dependency on headers 4.12 as this is the real issue.

Yes.

> However, it should be noted that we have an "issue" with the iputils
> package as it has an optional dependency on linux-headers since commit
> 9ffcd9279e5505535a73cf1200b3a86fd425cf32.
> I assume that this dependency is also not needed?

s/not needed/incorrect/, yes

Regards,
Yann E. MORIN.
diff mbox series

Patch

diff --git a/package/mtd/mtd.mk b/package/mtd/mtd.mk
index 8220a5ace8..312bb7e7a5 100644
--- a/package/mtd/mtd.mk
+++ b/package/mtd/mtd.mk
@@ -21,8 +21,8 @@  endif
 ifeq ($(BR2_PACKAGE_MTD_UBIFS_UTILS),y)
 MTD_DEPENDENCIES += util-linux zlib lzo host-pkgconf
 MTD_CONF_OPTS += --with-ubifs
-ifeq ($(BR2_PACKAGE_OPENSSL),y)
-MTD_DEPENDENCIES += openssl
+ifeq ($(BR2_PACKAGE_LINUX_HEADERS)$(BR2_PACKAGE_OPENSSL),yy)
+MTD_DEPENDENCIES += linux-headers openssl
 MTD_CONF_OPTS += --with-crypto
 else
 MTD_CONF_OPTS += --without-crypto