diff mbox series

[1/1] package/smstools3: fix build with gcc 10.x

Message ID 20200806095831.18563-1-mf@go-sys.de
State Changes Requested
Headers show
Series [1/1] package/smstools3: fix build with gcc 10.x | expand

Commit Message

Michael Fischer Aug. 6, 2020, 9:58 a.m. UTC
Signed-off-by: Michael Fischer <mf@go-sys.de>
---
 package/smstools3/smstools3.mk | 5 +++++
 1 file changed, 5 insertions(+)

Comments

Thomas Petazzoni Aug. 6, 2020, 3:23 p.m. UTC | #1
On Thu, 6 Aug 2020 11:58:31 +0200
Michael Fischer <mf@go-sys.de> wrote:

> Signed-off-by: Michael Fischer <mf@go-sys.de>
> ---
>  package/smstools3/smstools3.mk | 5 +++++
>  1 file changed, 5 insertions(+)
> 
> diff --git a/package/smstools3/smstools3.mk b/package/smstools3/smstools3.mk
> index 87d189baa8..b15e189c60 100644
> --- a/package/smstools3/smstools3.mk
> +++ b/package/smstools3/smstools3.mk
> @@ -10,6 +10,11 @@ SMSTOOLS3_LICENSE = GPL-2.0+
>  SMSTOOLS3_LICENSE_FILES = doc/license.html LICENSE
>  
>  SMSTOOLS3_CFLAGS = $(TARGET_CFLAGS)
> +
> +ifeq ($(BR2_GCC_VERSION_10_X),y)
> +	SMSTOOLS3_CFLAGS += -Wl,--allow-multiple-definition
> +endif

We generally try to fix the gcc 10.x issues, when possible. In this
case, Debian has a patch:

  https://salsa.debian.org/debian-mobcom-team/smstools/-/blob/57a358a9eebbe2ca5639cc526f7027944ed95ea1/debian/patches/gcc10.patch

Could you use that instead ?

Thanks,

Thomas
diff mbox series

Patch

diff --git a/package/smstools3/smstools3.mk b/package/smstools3/smstools3.mk
index 87d189baa8..b15e189c60 100644
--- a/package/smstools3/smstools3.mk
+++ b/package/smstools3/smstools3.mk
@@ -10,6 +10,11 @@  SMSTOOLS3_LICENSE = GPL-2.0+
 SMSTOOLS3_LICENSE_FILES = doc/license.html LICENSE
 
 SMSTOOLS3_CFLAGS = $(TARGET_CFLAGS)
+
+ifeq ($(BR2_GCC_VERSION_10_X),y)
+	SMSTOOLS3_CFLAGS += -Wl,--allow-multiple-definition
+endif
+
 SMSTOOLS3_CFLAGS += -D NUMBER_OF_MODEMS=$(BR2_PACKAGE_SMSTOOLS3_NB_MODEMS)
 SMSTOOLS3_CFLAGS += -D NOSTATS