diff mbox series

[1/1] package/exim: fix CC and LNCC initialization

Message ID 20200719102946.1646674-1-alejandro.gonzalez.correo@gmail.com
State Accepted
Headers show
Series [1/1] package/exim: fix CC and LNCC initialization | expand

Commit Message

Alejandro González July 19, 2020, 10:29 a.m. UTC
When using ccache to build the exim package, the
HOSTCC value contains characters that are incorrectly
interpreted by exim's Makefile, presumably spaces. This
breaks the build with "unrecognized option" ccache errors.

Fix that by wrapping the HOSTCC variable in double quotes,
as it is done for other variables that follow.

Signed-off-by: Alejandro González <alejandro.gonzalez.correo@gmail.com>
---
 package/exim/exim.mk | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Yann E. MORIN July 19, 2020, 4:55 p.m. UTC | #1
Alejandro, All,

On 2020-07-19 12:29 +0200, Alejandro González spake thusly:
> When using ccache to build the exim package, the
> HOSTCC value contains characters that are incorrectly
> interpreted by exim's Makefile, presumably spaces. This
> breaks the build with "unrecognized option" ccache errors.
> 
> Fix that by wrapping the HOSTCC variable in double quotes,
> as it is done for other variables that follow.
> 
> Signed-off-by: Alejandro González <alejandro.gonzalez.correo@gmail.com>

Applied to master, after tweaking the commit log slightly. Thanks!

Regards,
Yann E. MORIN.

> ---
>  package/exim/exim.mk | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/package/exim/exim.mk b/package/exim/exim.mk
> index 6643abbf65..19a62f497d 100644
> --- a/package/exim/exim.mk
> +++ b/package/exim/exim.mk
> @@ -123,8 +123,8 @@ endif
>  define EXIM_BUILD_CMDS
>  	$(TARGET_MAKE_ENV) build=br $(MAKE) -C $(@D) makefile
>  	$(HOST_MAKE_ENV) $(MAKE) -C $(@D)/build-br macro_predef \
> -		CC=$(HOSTCC) \
> -		LNCC=$(HOSTCC) \
> +		CC="$(HOSTCC)" \
> +		LNCC="$(HOSTCC)" \
>  		CFLAGS="-std=c99 $(HOST_CFLAGS)" \
>  		LFLAGS="-fPIC $(HOST_LDFLAGS)"
>  	$(TARGET_MAKE_ENV) build=br $(MAKE) -C $(@D) $(EXIM_STATIC_FLAGS) \
> -- 
> 2.27.0
> 
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
Peter Korsgaard July 22, 2020, 11:47 a.m. UTC | #2
>>>>> "Alejandro" == Alejandro González <alejandro.gonzalez.correo@gmail.com> writes:

 > When using ccache to build the exim package, the
 > HOSTCC value contains characters that are incorrectly
 > interpreted by exim's Makefile, presumably spaces. This
 > breaks the build with "unrecognized option" ccache errors.

 > Fix that by wrapping the HOSTCC variable in double quotes,
 > as it is done for other variables that follow.

 > Signed-off-by: Alejandro González <alejandro.gonzalez.correo@gmail.com>

Committed to 2020.02.x and 2020.05.x, thanks.
diff mbox series

Patch

diff --git a/package/exim/exim.mk b/package/exim/exim.mk
index 6643abbf65..19a62f497d 100644
--- a/package/exim/exim.mk
+++ b/package/exim/exim.mk
@@ -123,8 +123,8 @@  endif
 define EXIM_BUILD_CMDS
 	$(TARGET_MAKE_ENV) build=br $(MAKE) -C $(@D) makefile
 	$(HOST_MAKE_ENV) $(MAKE) -C $(@D)/build-br macro_predef \
-		CC=$(HOSTCC) \
-		LNCC=$(HOSTCC) \
+		CC="$(HOSTCC)" \
+		LNCC="$(HOSTCC)" \
 		CFLAGS="-std=c99 $(HOST_CFLAGS)" \
 		LFLAGS="-fPIC $(HOST_LDFLAGS)"
 	$(TARGET_MAKE_ENV) build=br $(MAKE) -C $(@D) $(EXIM_STATIC_FLAGS) \