diff mbox series

[1/1] package/keepalived: don't use --{en, dis}able-iptables

Message ID 20200714165800.995534-1-fontaine.fabrice@gmail.com
State Superseded
Headers show
Series [1/1] package/keepalived: don't use --{en, dis}able-iptables | expand

Commit Message

Fabrice Fontaine July 14, 2020, 4:58 p.m. UTC
Commit 5fcee496df262fcc304ad22738441df35a960a67 wrongly replaced
--{en,dis}able-libiptc by --{en,dis}able-iptables.

Indeed, this will raise the following build failure if
--disable-iptables and --disable-ipset are both set:

configure: error: disable-libipset requires vrrp and iptables

The issue is that when iptables flag is set, it will first check for
libiptc and then for ipset so setting --disable-iptables will disable
libiptc and ipset (which is not what we wants)

As iptables flag is enabled by default, just drop
--{en,dis}able-iptables to keep it simple

Fixes:
 - http://autobuild.buildroot.org/results/a1712b2cc3ad878e6876325ec7d4c434d0d9d11b

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/keepalived/keepalived.mk | 3 ---
 1 file changed, 3 deletions(-)

Comments

Thomas Petazzoni Aug. 15, 2020, 8:02 p.m. UTC | #1
Hello Fabrice,

On Tue, 14 Jul 2020 18:58:00 +0200
Fabrice Fontaine <fontaine.fabrice@gmail.com> wrote:

> Commit 5fcee496df262fcc304ad22738441df35a960a67 wrongly replaced
> --{en,dis}able-libiptc by --{en,dis}able-iptables.
> 
> Indeed, this will raise the following build failure if
> --disable-iptables and --disable-ipset are both set:
> 
> configure: error: disable-libipset requires vrrp and iptables
> 
> The issue is that when iptables flag is set, it will first check for
> libiptc and then for ipset so setting --disable-iptables will disable
> libiptc and ipset (which is not what we wants)
> 
> As iptables flag is enabled by default, just drop
> --{en,dis}able-iptables to keep it simple
> 
> Fixes:
>  - http://autobuild.buildroot.org/results/a1712b2cc3ad878e6876325ec7d4c434d0d9d11b
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

I was not very convinced by this explanation, so I dug deeper into this
issue. The configure.ac is far from being crystal clear, but I think I
got to the bottom of this, and submitted what I consider a better patch:

  https://patchwork.ozlabs.org/project/buildroot/patch/20200815195851.282863-1-thomas.petazzoni@bootlin.com/

The commit log contains an extensive description of how I came up with
the alternate solution.

Thanks!

Thomas
diff mbox series

Patch

diff --git a/package/keepalived/keepalived.mk b/package/keepalived/keepalived.mk
index df1ab6d306..64224e66b4 100644
--- a/package/keepalived/keepalived.mk
+++ b/package/keepalived/keepalived.mk
@@ -41,9 +41,6 @@  endif
 
 ifeq ($(BR2_PACKAGE_IPTABLES),y)
 KEEPALIVED_DEPENDENCIES += iptables
-KEEPALIVED_CONF_OPTS += --enable-iptables
-else
-KEEPALIVED_CONF_OPTS += --disable-iptables
 endif
 
 ifeq ($(BR2_PACKAGE_LIBNFTNL),y)