diff mbox series

[2/3] package/systemd: fix telinit-path and add missing pat options

Message ID 20200710234150.185609-2-nolange79@gmail.com
State Accepted
Headers show
Series [1/3] package/systemd: add option to enable SysV and utmp compatibility | expand

Commit Message

Norbert Lange July 10, 2020, 11:41 p.m. UTC
If paths are not set, then meson will search the host system for the
binaries (or the target, where those binaries are not yet installed).
So add the missing paths.

Also fixup the path to telinit (nice way to get a build path into the binary).

Signed-off-by: Norbert Lange <nolange79@gmail.com>
---
 package/systemd/systemd.mk | 6 +++++-
 1 file changed, 5 insertions(+), 1 deletion(-)

Comments

Adam Duskett Sept. 28, 2020, 6:58 p.m. UTC | #1
All:

reviewed-by: Adam Duskett <aduskett@gmail.com>

On Fri, Jul 10, 2020 at 4:42 PM Norbert Lange <nolange79@gmail.com> wrote:
>
> If paths are not set, then meson will search the host system for the
> binaries (or the target, where those binaries are not yet installed).
> So add the missing paths.
>
> Also fixup the path to telinit (nice way to get a build path into the binary).
>
> Signed-off-by: Norbert Lange <nolange79@gmail.com>
> ---
>  package/systemd/systemd.mk | 6 +++++-
>  1 file changed, 5 insertions(+), 1 deletion(-)
>
> diff --git a/package/systemd/systemd.mk b/package/systemd/systemd.mk
> index 05d8cb4934..176adb434a 100644
> --- a/package/systemd/systemd.mk
> +++ b/package/systemd/systemd.mk
> @@ -32,12 +32,16 @@ SYSTEMD_CONF_OPTS += \
>         -Dsplit-usr=false \
>         -Dsystem-uid-max=999 \
>         -Dsystem-gid-max=999 \
> -       -Dtelinit-path=$(TARGET_DIR)/sbin/telinit \
> +       -Dquotaon-path=/usr/sbin/quotaon \
> +       -Dquotacheck-path=/usr/sbin/quotacheck \
>         -Dkmod-path=/usr/bin/kmod \
>         -Dkexec-path=/usr/sbin/kexec \
>         -Dsulogin-path=/usr/sbin/sulogin \
>         -Dmount-path=/usr/bin/mount \
>         -Dumount-path=/usr/bin/umount \
> +       -Dloadkeys-path=/usr/bin/loadkeys \
> +       -Dsetfont-path=/usr/bin/setfont \
> +       -Dtelinit-path=/sbin/telinit \
>         -Dnobody-group=nogroup \
>         -Didn=true \
>         -Dnss-systemd=true
> --
> 2.27.0
>
Arnout Vandecappelle Nov. 3, 2020, 9:23 p.m. UTC | #2
Hi Norbert,

On 11/07/2020 01:41, Norbert Lange wrote:
> If paths are not set, then meson will search the host system for the
> binaries (or the target, where those binaries are not yet installed).
> So add the missing paths.

 Applied to master, thanks, except:

> 
> Also fixup the path to telinit (nice way to get a build path into the binary).

 ... since in the end we explicitly removed sysv support from the config,
keeping telinit makes no sense.

 So, in a separate patch, I set telinit_path to nothing (like it's done for the
other sysv stuff).

 I also pushed a follow-up patch that sorts the options.

 Regards,
 Arnout

> 
> Signed-off-by: Norbert Lange <nolange79@gmail.com>
> ---
>  package/systemd/systemd.mk | 6 +++++-
>  1 file changed, 5 insertions(+), 1 deletion(-)
> 
> diff --git a/package/systemd/systemd.mk b/package/systemd/systemd.mk
> index 05d8cb4934..176adb434a 100644
> --- a/package/systemd/systemd.mk
> +++ b/package/systemd/systemd.mk
> @@ -32,12 +32,16 @@ SYSTEMD_CONF_OPTS += \
>  	-Dsplit-usr=false \
>  	-Dsystem-uid-max=999 \
>  	-Dsystem-gid-max=999 \
> -	-Dtelinit-path=$(TARGET_DIR)/sbin/telinit \
> +	-Dquotaon-path=/usr/sbin/quotaon \
> +	-Dquotacheck-path=/usr/sbin/quotacheck \
>  	-Dkmod-path=/usr/bin/kmod \
>  	-Dkexec-path=/usr/sbin/kexec \
>  	-Dsulogin-path=/usr/sbin/sulogin \
>  	-Dmount-path=/usr/bin/mount \
>  	-Dumount-path=/usr/bin/umount \
> +	-Dloadkeys-path=/usr/bin/loadkeys \
> +	-Dsetfont-path=/usr/bin/setfont \
> +	-Dtelinit-path=/sbin/telinit \
>  	-Dnobody-group=nogroup \
>  	-Didn=true \
>  	-Dnss-systemd=true
>
diff mbox series

Patch

diff --git a/package/systemd/systemd.mk b/package/systemd/systemd.mk
index 05d8cb4934..176adb434a 100644
--- a/package/systemd/systemd.mk
+++ b/package/systemd/systemd.mk
@@ -32,12 +32,16 @@  SYSTEMD_CONF_OPTS += \
 	-Dsplit-usr=false \
 	-Dsystem-uid-max=999 \
 	-Dsystem-gid-max=999 \
-	-Dtelinit-path=$(TARGET_DIR)/sbin/telinit \
+	-Dquotaon-path=/usr/sbin/quotaon \
+	-Dquotacheck-path=/usr/sbin/quotacheck \
 	-Dkmod-path=/usr/bin/kmod \
 	-Dkexec-path=/usr/sbin/kexec \
 	-Dsulogin-path=/usr/sbin/sulogin \
 	-Dmount-path=/usr/bin/mount \
 	-Dumount-path=/usr/bin/umount \
+	-Dloadkeys-path=/usr/bin/loadkeys \
+	-Dsetfont-path=/usr/bin/setfont \
+	-Dtelinit-path=/sbin/telinit \
 	-Dnobody-group=nogroup \
 	-Didn=true \
 	-Dnss-systemd=true