diff mbox series

[1/6] Revert "python-m2crypto: remove"

Message ID 20200702103618.5147-2-dev.kurt@vandijck-laurijssen.be
State Changes Requested
Headers show
Series [1/6] Revert "python-m2crypto: remove" | expand

Commit Message

Kurt Van Dijck July 2, 2020, 10:36 a.m. UTC
This reverts commit 484c04878e5e76cdc0cc33c7646f98ab41698a7e.
python-m2crypto becomes needed for recompiling wireless-regdb.

Signed-off-by: Kurt Van Dijck <dev.kurt@vandijck-laurijssen.be>
---
 package/python-m2crypto/python-m2crypto.hash |  3 ++
 package/python-m2crypto/python-m2crypto.mk   | 31 ++++++++++++++++++++
 2 files changed, 34 insertions(+)
 create mode 100644 package/python-m2crypto/python-m2crypto.hash
 create mode 100644 package/python-m2crypto/python-m2crypto.mk
diff mbox series

Patch

diff --git a/package/python-m2crypto/python-m2crypto.hash b/package/python-m2crypto/python-m2crypto.hash
new file mode 100644
index 0000000000..4ac180f870
--- /dev/null
+++ b/package/python-m2crypto/python-m2crypto.hash
@@ -0,0 +1,3 @@ 
+# md5 from https://pypi.python.org/pypi/M2Crypto/, sha256 locally computed
+md5 8e87235942c76d1ba9f999ee33764fdb M2Crypto-0.24.0.tar.gz
+sha256 80a56441a1d2c0cf27e725be7554c92598b938fc8767ee2c71fdbc2fdc055ee8 M2Crypto-0.24.0.tar.gz
diff --git a/package/python-m2crypto/python-m2crypto.mk b/package/python-m2crypto/python-m2crypto.mk
new file mode 100644
index 0000000000..3d0e54eb4e
--- /dev/null
+++ b/package/python-m2crypto/python-m2crypto.mk
@@ -0,0 +1,31 @@ 
+################################################################################
+#
+# python-m2crypto
+#
+################################################################################
+
+PYTHON_M2CRYPTO_VERSION = 0.24.0
+PYTHON_M2CRYPTO_SITE = http://pypi.python.org/packages/source/M/M2Crypto
+PYTHON_M2CRYPTO_SOURCE = M2Crypto-$(PYTHON_M2CRYPTO_VERSION).tar.gz
+PYTHON_M2CRYPTO_SETUP_TYPE = setuptools
+HOST_PYTHON_M2CRYPTO_DEPENDENCIES = host-openssl host-swig
+
+PYTHON_M2CRYPTO_LICENSE = MIT
+PYTHON_M2CRYPTO_LICENSE_FILES = LICENCE
+
+# We need to use python2 because m2crypto is not python3 compliant.
+HOST_PYTHON_M2CRYPTO_NEEDS_HOST_PYTHON = python2
+
+# The --openssl option that allows to specify a custom path to OpenSSL
+# can only be used with the non-default build_ext setup.py command,
+# and calling this command directly fails. To work around this, simply
+# hardcode the path to OpenSSL in setup.py.
+# Bug reported at https://gitlab.com/m2crypto/m2crypto/issues/89
+define HOST_PYTHON_M2CRYPTO_SET_OPENSSL_PATH
+	$(SED) "s%self.openssl = '/usr'%self.openssl = '$(HOST_DIR)/usr'%" \
+		$(@D)/setup.py
+endef
+
+HOST_PYTHON_M2CRYPTO_POST_PATCH_HOOKS += HOST_PYTHON_M2CRYPTO_SET_OPENSSL_PATH
+
+$(eval $(host-python-package))