diff mbox series

[3/4] package/openjdk: copy all directories and files when installing

Message ID 20200417232922.3762195-3-aduskett@gmail.com
State Superseded, archived
Headers show
Series [1/4] package/openjdk: fix hash | expand

Commit Message

Adam Duskett April 17, 2020, 11:29 p.m. UTC
From: Adam Duskett <Aduskett@gmail.com>

Several directories and files are currently not installed during the
target installation, these include:
  - conf
    Several configuration files, including security configuration files which
    may be necessary for running various java applications.

  - legal
    This directory contains legal notices that some java applications may
    require.

  - release
    This directory contains a list of modules included in the image.

Because these directories take up less than of megabyte extra, it is not an
issue to install all of them.

Signed-off-by: Adam Duskett <Aduskett@gmail.com>
---
 package/openjdk/openjdk.mk | 4 +---
 1 file changed, 1 insertion(+), 3 deletions(-)

Comments

Yann E. MORIN April 18, 2020, 12:21 p.m. UTC | #1
Adam, All,

On 2020-04-17 16:29 -0700, aduskett@gmail.com spake thusly:
> From: Adam Duskett <Aduskett@gmail.com>
> 
> Several directories and files are currently not installed during the
> target installation, these include:
>   - conf
>     Several configuration files, including security configuration files which
>     may be necessary for running various java applications.
> 
>   - legal
>     This directory contains legal notices that some java applications may
>     require.

At runtime, really?

>   - release
>     This directory contains a list of modules included in the image.
> 
> Because these directories take up less than of megabyte extra, it is not an
> issue to install all of them.
> 
> Signed-off-by: Adam Duskett <Aduskett@gmail.com>

Reviewed-by: Yann E. MORIN <yann.morin.1998@free.fr>

Regards,
Yann E. MORIN.

> ---
>  package/openjdk/openjdk.mk | 4 +---
>  1 file changed, 1 insertion(+), 3 deletions(-)
> 
> diff --git a/package/openjdk/openjdk.mk b/package/openjdk/openjdk.mk
> index d540b65edc..19e71e98b2 100644
> --- a/package/openjdk/openjdk.mk
> +++ b/package/openjdk/openjdk.mk
> @@ -124,9 +124,7 @@ endef
>  # which makes manual installation necessary.
>  define OPENJDK_INSTALL_TARGET_CMDS
>  	mkdir -p $(TARGET_DIR)/$(OPENJDK_INSTALL_BASE)
> -	cp -dpfr $(@D)/build/linux-*-release/images/jre/bin/ \
> -		$(TARGET_DIR)/$(OPENJDK_INSTALL_BASE)
> -	cp -dpfr $(@D)/build/linux-*-release/images/jre/lib/ \
> +	cp -dpfr $(@D)/build/linux-*-release/images/jre/* \
>  		$(TARGET_DIR)/$(OPENJDK_INSTALL_BASE)
>  	cd $(TARGET_DIR)/usr/bin && ln -snf ../../$(OPENJDK_INSTALL_BASE)/bin/* .
>  endef
> -- 
> 2.25.2
> 
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
Adam Duskett April 18, 2020, 5 p.m. UTC | #2
On Sat, Apr 18, 2020 at 5:21 AM Yann E. MORIN <yann.morin.1998@free.fr> wrote:
>
> Adam, All,
>
> On 2020-04-17 16:29 -0700, aduskett@gmail.com spake thusly:
> > From: Adam Duskett <Aduskett@gmail.com>
> >
> > Several directories and files are currently not installed during the
> > target installation, these include:
> >   - conf
> >     Several configuration files, including security configuration files which
> >     may be necessary for running various java applications.
> >
> >   - legal
> >     This directory contains legal notices that some java applications may
> >     require.
>
> At runtime, really?
>
Unfortunately yes, as they can be used by some applications to print
legal information,
which means if these files exist an exception is thrown.

> >   - release
> >     This directory contains a list of modules included in the image.
> >
> > Because these directories take up less than of megabyte extra, it is not an
> > issue to install all of them.
> >
> > Signed-off-by: Adam Duskett <Aduskett@gmail.com>
>
> Reviewed-by: Yann E. MORIN <yann.morin.1998@free.fr>
>
> Regards,
> Yann E. MORIN.
>
> > ---
> >  package/openjdk/openjdk.mk | 4 +---
> >  1 file changed, 1 insertion(+), 3 deletions(-)
> >
> > diff --git a/package/openjdk/openjdk.mk b/package/openjdk/openjdk.mk
> > index d540b65edc..19e71e98b2 100644
> > --- a/package/openjdk/openjdk.mk
> > +++ b/package/openjdk/openjdk.mk
> > @@ -124,9 +124,7 @@ endef
> >  # which makes manual installation necessary.
> >  define OPENJDK_INSTALL_TARGET_CMDS
> >       mkdir -p $(TARGET_DIR)/$(OPENJDK_INSTALL_BASE)
> > -     cp -dpfr $(@D)/build/linux-*-release/images/jre/bin/ \
> > -             $(TARGET_DIR)/$(OPENJDK_INSTALL_BASE)
> > -     cp -dpfr $(@D)/build/linux-*-release/images/jre/lib/ \
> > +     cp -dpfr $(@D)/build/linux-*-release/images/jre/* \
> >               $(TARGET_DIR)/$(OPENJDK_INSTALL_BASE)
> >       cd $(TARGET_DIR)/usr/bin && ln -snf ../../$(OPENJDK_INSTALL_BASE)/bin/* .
> >  endef
> > --
> > 2.25.2
> >
> > _______________________________________________
> > buildroot mailing list
> > buildroot@busybox.net
> > http://lists.busybox.net/mailman/listinfo/buildroot
>
> --
> .-----------------.--------------------.------------------.--------------------.
> |  Yann E. MORIN  | Real-Time Embedded | /"\ ASCII RIBBON | Erics' conspiracy: |
> | +33 662 376 056 | Software  Designer | \ / CAMPAIGN     |  ___               |
> | +33 561 099 427 `------------.-------:  X  AGAINST      |  \e/  There is no  |
> | http://ymorin.is-a-geek.org/ | _/*\_ | / \ HTML MAIL    |   v   conspiracy.  |
> '------------------------------^-------^------------------^--------------------'
diff mbox series

Patch

diff --git a/package/openjdk/openjdk.mk b/package/openjdk/openjdk.mk
index d540b65edc..19e71e98b2 100644
--- a/package/openjdk/openjdk.mk
+++ b/package/openjdk/openjdk.mk
@@ -124,9 +124,7 @@  endef
 # which makes manual installation necessary.
 define OPENJDK_INSTALL_TARGET_CMDS
 	mkdir -p $(TARGET_DIR)/$(OPENJDK_INSTALL_BASE)
-	cp -dpfr $(@D)/build/linux-*-release/images/jre/bin/ \
-		$(TARGET_DIR)/$(OPENJDK_INSTALL_BASE)
-	cp -dpfr $(@D)/build/linux-*-release/images/jre/lib/ \
+	cp -dpfr $(@D)/build/linux-*-release/images/jre/* \
 		$(TARGET_DIR)/$(OPENJDK_INSTALL_BASE)
 	cd $(TARGET_DIR)/usr/bin && ln -snf ../../$(OPENJDK_INSTALL_BASE)/bin/* .
 endef