diff mbox series

[1/1] package/avahi: add gobject-introspection optional dependency

Message ID 20200407175535.409309-1-fontaine.fabrice@gmail.com
State Rejected
Headers show
Series [1/1] package/avahi: add gobject-introspection optional dependency | expand

Commit Message

Fabrice Fontaine April 7, 2020, 5:55 p.m. UTC
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/avahi/avahi.mk | 7 +++++++
 1 file changed, 7 insertions(+)

Comments

Arnout Vandecappelle Jan. 5, 2022, 10:02 a.m. UTC | #1
On 07/04/2020 19:55, Fabrice Fontaine wrote:
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
>   package/avahi/avahi.mk | 7 +++++++
>   1 file changed, 7 insertions(+)
> 
> diff --git a/package/avahi/avahi.mk b/package/avahi/avahi.mk
> index 73db37545f..3546979d83 100644
> --- a/package/avahi/avahi.mk
> +++ b/package/avahi/avahi.mk
> @@ -82,6 +82,13 @@ else
>   AVAHI_CONF_OPTS += --disable-dbus
>   endif
>   
> +ifeq ($(BR2_PACKAGE_GOBJECT_INTROSPECTION),y)
> +AVAHI_CONF_OPTS += --enable-introspection
> +AVAHI_DEPENDENCIES += gobject-introspection

  It later turned out that this fails when DBUS is enabled, and the solution is 
too ugly to apply [1]. Therefore, I marked this as Rejected.

  Regards,
  Arnout

[1] 
https://patchwork.ozlabs.org/project/buildroot/patch/20200813232351.1552307-1-aduskett@gmail.com/


> +else 
> +AVAHI_CONF_OPTS += --disable-introspection
> +endif
> +
>   ifeq ($(BR2_PACKAGE_LIBEVENT),y)
>   AVAHI_DEPENDENCIES += libevent
>   else
>
diff mbox series

Patch

diff --git a/package/avahi/avahi.mk b/package/avahi/avahi.mk
index 73db37545f..3546979d83 100644
--- a/package/avahi/avahi.mk
+++ b/package/avahi/avahi.mk
@@ -82,6 +82,13 @@  else
 AVAHI_CONF_OPTS += --disable-dbus
 endif
 
+ifeq ($(BR2_PACKAGE_GOBJECT_INTROSPECTION),y)
+AVAHI_CONF_OPTS += --enable-introspection
+AVAHI_DEPENDENCIES += gobject-introspection
+else
+AVAHI_CONF_OPTS += --disable-introspection
+endif
+
 ifeq ($(BR2_PACKAGE_LIBEVENT),y)
 AVAHI_DEPENDENCIES += libevent
 else