diff mbox series

[1/1] package: add rtty

Message ID 20200310150606.28261-1-zhaojh329@gmail.com
State Accepted
Headers show
Series [1/1] package: add rtty | expand

Commit Message

Jianhui zhao March 10, 2020, 3:06 p.m. UTC
Signed-off-by: Jianhui Zhao <zhaojh329@gmail.com>
---
 package/Config.in      |  1 +
 package/rtty/Config.in |  7 +++++++
 package/rtty/rtty.hash |  2 ++
 package/rtty/rtty.mk   | 15 +++++++++++++++
 4 files changed, 25 insertions(+)
 create mode 100644 package/rtty/Config.in
 create mode 100644 package/rtty/rtty.hash
 create mode 100644 package/rtty/rtty.mk

Comments

Romain Naour March 22, 2020, 6:06 p.m. UTC | #1
Hi Jianhui,

Le 10/03/2020 à 16:06, Jianhui Zhao a écrit :
> Signed-off-by: Jianhui Zhao <zhaojh329@gmail.com>
> ---
>  package/Config.in      |  1 +
>  package/rtty/Config.in |  7 +++++++
>  package/rtty/rtty.hash |  2 ++
>  package/rtty/rtty.mk   | 15 +++++++++++++++
>  4 files changed, 25 insertions(+)
>  create mode 100644 package/rtty/Config.in
>  create mode 100644 package/rtty/rtty.hash
>  create mode 100644 package/rtty/rtty.mk
> 
> diff --git a/package/Config.in b/package/Config.in
> index 146fc1bbc3..f5aab078e6 100644
> --- a/package/Config.in
> +++ b/package/Config.in
> @@ -2267,6 +2267,7 @@ comment "Utilities"
>  	source "package/pdmenu/Config.in"
>  	source "package/pinentry/Config.in"
>  	source "package/ranger/Config.in"
> +	source "package/rtty/Config.in"
>  	source "package/screen/Config.in"
>  	source "package/sudo/Config.in"
>  	source "package/terminology/Config.in"
> diff --git a/package/rtty/Config.in b/package/rtty/Config.in
> new file mode 100644
> index 0000000000..badb329d3e
> --- /dev/null
> +++ b/package/rtty/Config.in
> @@ -0,0 +1,7 @@
> +config BR2_PACKAGE_RTTY
> +	bool "rtty"
> +	select BR2_PACKAGE_LIBEV
> +	help
> +	  Access your device's terminal from anywhere via the web.
> +
> +	  https://github.com/zhaojh329/rtty
> diff --git a/package/rtty/rtty.hash b/package/rtty/rtty.hash
> new file mode 100644
> index 0000000000..239dc59f78
> --- /dev/null
> +++ b/package/rtty/rtty.hash
> @@ -0,0 +1,2 @@
> +sha256  6faafe75d82edbcfe154da5f1ffc0ddfd14dd88a2315f19aeed7f2631df96f41  rtty-7.1.2.tar.gz
> +sha256  99efed4bbc0b62f96f999ef23399e38234fb91651af734fd389a52b033a85b55  LICENCE
> diff --git a/package/rtty/rtty.mk b/package/rtty/rtty.mk
> new file mode 100644
> index 0000000000..857dc35751
> --- /dev/null
> +++ b/package/rtty/rtty.mk
> @@ -0,0 +1,15 @@
> +################################################################################
> +#
> +# rtty
> +#
> +################################################################################
> +
> +RTTY_VERSION = 7.1.2
> +LIBCURL_SOURCE = rtty-$(RTTY_VERSION).tar.gz

Wrong prefix.

> +RTTY_SITE = https://github.com/zhaojh329/rtty/releases/download/v$(RTTY_VERSION)
> +RTTY_LICENSE = MIT
> +RTTY_LICENSE_FILES = LICENSE
> +
> +RTTY_DEPENDENCIES = libev

What about optional dependencies: openssl, mbedtls, CyaSSl(wolfssl) ?

You can disable SSL support -DRTTY_SSL_SUPPORT=OFF for now and enable it in a
second patch.

We do not recommend adding -Werror unconditionally [1] since rtty can be built
by several compiler version and for several architecture.
Also it's not future proof since new compiler can generate new warnings.

Can you test your package using ./utils/test-pkg and ./utils/check-package

Also, add a new entry in DEVELOPERS file [3]

[1] https://github.com/zhaojh329/rtty/blob/master/src/CMakeLists.txt#L1
[2] http://nightly.buildroot.org/manual.html#_tips_and_tricks
[3] http://nightly.buildroot.org/manual.html#DEVELOPERS

Best regards,
Romain

> +
> +$(eval $(cmake-package))
>
Thomas Petazzoni March 22, 2020, 8:49 p.m. UTC | #2
Hello,

On Tue, 10 Mar 2020 23:06:06 +0800
Jianhui Zhao <zhaojh329@gmail.com> wrote:

> Signed-off-by: Jianhui Zhao <zhaojh329@gmail.com>

Thanks for your contribution. I have applied your patch, after doing a
number of changes. See below.

> ---
>  package/Config.in      |  1 +
>  package/rtty/Config.in |  7 +++++++
>  package/rtty/rtty.hash |  2 ++
>  package/rtty/rtty.mk   | 15 +++++++++++++++
>  4 files changed, 25 insertions(+)

You forgot to add an entry to the DEVELOPERS files, so I did that.

> diff --git a/package/rtty/rtty.hash b/package/rtty/rtty.hash
> new file mode 100644
> index 0000000000..239dc59f78
> --- /dev/null
> +++ b/package/rtty/rtty.hash
> @@ -0,0 +1,2 @@
> +sha256  6faafe75d82edbcfe154da5f1ffc0ddfd14dd88a2315f19aeed7f2631df96f41  rtty-7.1.2.tar.gz
> +sha256  99efed4bbc0b62f96f999ef23399e38234fb91651af734fd389a52b033a85b55  LICENCE

The license file is named LICENSE (with an S) not LICENCE (with a C).

> +RTTY_VERSION = 7.1.2
> +LIBCURL_SOURCE = rtty-$(RTTY_VERSION).tar.gz

Wrong prefix, this variable was not needed anyway, so I dropped it.

> +RTTY_SITE = https://github.com/zhaojh329/rtty/releases/download/v$(RTTY_VERSION)
> +RTTY_LICENSE = MIT
> +RTTY_LICENSE_FILES = LICENSE
> +
> +RTTY_DEPENDENCIES = libev

As suggested by Romain Naour, I've added -DRTTY_SSL_SUPPORT=OFF, and
then did a follow-up commit to add optional support for SSL.

You will receive e-mail notifications if there are build failures for
the rtty package. If there are build failures, it would be nice if you
could investigate them, and provide fixes.

Thanks a lot!

Thomas
diff mbox series

Patch

diff --git a/package/Config.in b/package/Config.in
index 146fc1bbc3..f5aab078e6 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -2267,6 +2267,7 @@  comment "Utilities"
 	source "package/pdmenu/Config.in"
 	source "package/pinentry/Config.in"
 	source "package/ranger/Config.in"
+	source "package/rtty/Config.in"
 	source "package/screen/Config.in"
 	source "package/sudo/Config.in"
 	source "package/terminology/Config.in"
diff --git a/package/rtty/Config.in b/package/rtty/Config.in
new file mode 100644
index 0000000000..badb329d3e
--- /dev/null
+++ b/package/rtty/Config.in
@@ -0,0 +1,7 @@ 
+config BR2_PACKAGE_RTTY
+	bool "rtty"
+	select BR2_PACKAGE_LIBEV
+	help
+	  Access your device's terminal from anywhere via the web.
+
+	  https://github.com/zhaojh329/rtty
diff --git a/package/rtty/rtty.hash b/package/rtty/rtty.hash
new file mode 100644
index 0000000000..239dc59f78
--- /dev/null
+++ b/package/rtty/rtty.hash
@@ -0,0 +1,2 @@ 
+sha256  6faafe75d82edbcfe154da5f1ffc0ddfd14dd88a2315f19aeed7f2631df96f41  rtty-7.1.2.tar.gz
+sha256  99efed4bbc0b62f96f999ef23399e38234fb91651af734fd389a52b033a85b55  LICENCE
diff --git a/package/rtty/rtty.mk b/package/rtty/rtty.mk
new file mode 100644
index 0000000000..857dc35751
--- /dev/null
+++ b/package/rtty/rtty.mk
@@ -0,0 +1,15 @@ 
+################################################################################
+#
+# rtty
+#
+################################################################################
+
+RTTY_VERSION = 7.1.2
+LIBCURL_SOURCE = rtty-$(RTTY_VERSION).tar.gz
+RTTY_SITE = https://github.com/zhaojh329/rtty/releases/download/v$(RTTY_VERSION)
+RTTY_LICENSE = MIT
+RTTY_LICENSE_FILES = LICENSE
+
+RTTY_DEPENDENCIES = libev
+
+$(eval $(cmake-package))